1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem downloading files with Linksys E4200v1

Discussion in 'Networking Issues' started by Raman, Mar 22, 2013.

  1. Raman

    Raman Reformed Router Member

    I have been using my router (Linksys E4200v1) with no problem for the last 6 months, but suddenly in the last couple of weeks the problem started, every time I download a large file (>500 MB) through my router it gets corrupted, however when I download it directly through the modem it download just fine.

    I tried to reset the router and used it as a bridge and also tried lowering the MTU but the problem is still there.

    BTW if I use wired connection there's no problem downloading at all.

    Any ideas how to fix this?
     
  2. Toxic

    Toxic Administrator Staff Member

    so the only issue is with wireless downloading?
     
  3. Raman

    Raman Reformed Router Member

    Yes.
     
  4. Toxic

    Toxic Administrator Staff Member

  5. Raman

    Raman Reformed Router Member

    I tried downloading using another device and it downloaded fine! so it seems the problem is from my pc! is there a way to fix it?
     
  6. Raman

    Raman Reformed Router Member

    I just tried using my friend usb wireless adapter on my pc and the problem is still there! so the problem isn't from my adapter.
     
  7. Toxic

    Toxic Administrator Staff Member

    are you using an official linksys firmware or a third party firmware like Tomato Firmware?
     
  8. Raman

    Raman Reformed Router Member

    When the problem started I was using the official firmware but a couple of days ago I installed Tomato's Toastman firmware thinking maybe the problem was from the firmware, but it solved nothing. :(
     
  9. Toxic

    Toxic Administrator Staff Member

  10. Raman

    Raman Reformed Router Member

    Well, I just formatted my OS and the problem got solved :)
     
    Toxic likes this.

Share This Page