1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem editing nvram

Discussion in 'DD-WRT Firmware' started by mowfax, Dec 21, 2005.

  1. mowfax

    mowfax Network Guru Member

    Hi,

    I have a problem when editing my NVRAM.
    I wanted to edit my "forward_port" setting and added some entries, but after committing, they don't appear in my webinterface...
    I couldn't test my settings till now, so I don't know if my settings are ignored or just don't show up...
    I need both ways of editing, so "stick to one or the other" isn't really an option :-/

    Someone up with a solution or someone with the same problem?

    P.S. WRT54GS v4 / DD-WRT beta 2 from 21.12.2005
     
  2. 4Access

    4Access Network Guru Member

    I think some examples will explain this easiest...

    The following two commands (watch out for line wrap):

    Code:
    nvram set forwardspec_entries="2"
    nvram set forward_spec="Rule1:on:both:1>192.168.1.18:2 Rule2:on:tcp:55>192.168.1.92:921"
    Result in the following Port Forwarding Rules:

    [​IMG]


    And the following to commands (watch out for line wrap):

    Code:
    nvram set forward_entries="2"
    nvram set forward_port="Rule1:on:both:2:5>192.168.1.90 Rule2:on:udp:10000:10005>192.168.1.91"
    Result in the following Port Range Forwarding Rules:

    [​IMG]

    :thumb:
     
  3. mowfax

    mowfax Network Guru Member

    Uhhh thanx a lot!!
    I missed those 'entries' Parts :p

    Now that I edited those, it works great!

    Greets, Mowfax
     

Share This Page