1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with VPN on RV042

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by bsdrocker, Jul 19, 2007.

  1. bsdrocker

    bsdrocker LI Guru Member


    I am trying to setup a VPN on my RV042. I tried for several days before realizing that me forwarding port 443 to a server was the problem. I NEED THIS PORT TO GO TO THAT SERVER. This has caused HardVPN and SoftVPN's to not work.

    I installed the newest QuickVPN Client and found that I could use another port for SoftVPN's at least. But when I set it to auto I get this message - "Server's certificate doesn't exist on your local computer. Do you want to quit this connection?". I have exported the certificate onto my computer but I am still getting this message.


    Thank you for your time,

    Josh (BSDRocker)
  2. bsdrocker

    bsdrocker LI Guru Member

    I'm attaching a drawing of what the network looks like so you guys can have a better understanding of what I'm trying to do here...

    Attached Files:

  3. ZeGhostbear

    ZeGhostbear LI Guru Member

    QuickVPN also offers alternative port 60443 to be used instead of the default. Have you tried using that instead?
  4. vpnuser

    vpnuser LI Guru Member

    Yes, forcing the client to use port 60443 should work.
  5. bsdrocker

    bsdrocker LI Guru Member

    I have been trying it on auto - thats when I get the server certificate error. When I set it to 60443 I get no error and it doesn't connect...
  6. vpnuser

    vpnuser LI Guru Member

    Do you have HTTPS enabled on RV042?
  7. bsdrocker

    bsdrocker LI Guru Member

    Yes - I do believe I do. I will double check - but I'm sure it is.

    I'm where I can't access the RV042 right now. I'll let you know after I check...

    Until then - does anyone else have any ideas?


  8. bsdrocker

    bsdrocker LI Guru Member

    I have just verified that HTTPS is turned on. It has been this whole time like I said.

    Any other idea's?


  9. ifican

    ifican Network Guru Member

    Going back to your original post, you state you need to forward 443 to an internal host. This is going to cause you grief because if you have https turned on on the RV then you cannot forward 443 becuase the RV will intercept that traffic.

    Quickvpn - i have not used the new one so i am unfamiliar with the certificate but i have heard that it works well. Also i have heard somewhere that https does not need to be turned on anymore to make quickvpn work. Are you potentially sitting behind a device that is limiting what ports or protocols can be sent and or received?
  10. bsdrocker

    bsdrocker LI Guru Member

    I haven't had a problem forwarding this port while https has been enabled. From what I've read when you enable this https feature you can manage your router thru SSL (example:

    It sounds logical that when I try the QuickVPN the router doesn't realize that its VPN traffic and just HTTPS management traffic. I'll try turning HTTPS off and see what happens.

    I am not behind anything of the sort. I am sitting behind a Cisco 2801 and SSL and IPSec traffic go thru this router all the time.


  11. ifican

    ifican Network Guru Member

    https on the lan side is not the issue, its when you have remote management enabled. In older versions of quickvpn you had to have remote management (https wan side) enabled for quickvpn to work, i dont know if that is the case anymore though.

    So your RV has a public facing interface and when you try to connect to it, it is through a 2801, and the 2801 has no ACL's in place that are limiting traffic flow?
  12. bsdrocker

    bsdrocker LI Guru Member

    I'll look into that...

    Yes, I'm sitting behind a 2801 with no ACL's blocking those ports.

    I'm trying to get this setup for a client. They were using an old SonicWALL that wasn't licensed for SoftClients. We had an extra RV042 around that we thought would be perfect.

    They have two remote workers with routers that need VPN access that also isn't working at the moment. They would also like QuickVPN as well. I figured if I could get the QuickVPN working I could worry about gateway-to-gateway VPN's later...


  13. ifican

    ifican Network Guru Member

    A better fit would be to setup pptp for the 2 remote users and ipsec vpns for the 2 routers.
  14. bsdrocker

    bsdrocker LI Guru Member

    ipsec vpns aren't working either... thats whats really stumping me. as soon as I turn port forwarding for port 443 ipsec tunnels come backup...
  15. ifican

    ifican Network Guru Member

    what do the logs show when it goes down?
  16. bsdrocker

    bsdrocker LI Guru Member

    I'll work on getting the log messages. I'm having some issue with my ISP at the moment and have had very speratic connection.

    Hopefully I'll have these up tomorrow sometime...

    Thanks for all your help!!!!!



Share This Page