1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with web setup

Discussion in 'Sveasoft Firmware' started by dfilkovi, Apr 9, 2005.

  1. dfilkovi

    dfilkovi Network Guru Member

    I flashed my WRT54G with satori firmware and I can't log on or even ping the router when i'm connected with the cable, but when I'm connected over wireless I can log on and ping it succesfully, I tried everything. Both alchemy and satori firmware, tried rebooting many times, nothing helps.
    I tried both dhcp and static ip and dhcp doesn't even asign an ip adress it just says limited or no connectivity.

    I flashed it with hyperwrt and it works fine, a flashed it back to satori and it just won't connect to router over a LAN cable.

    Can anyone help.
  2. jagboy

    jagboy Network Guru Member

    what version 1.1, 1, 2, 2.2,3
  3. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Flash a linksys firmware and reset to factory defaults. Then flash to a sveasoft version using firmare defaults. Once this is done reset it a few times to factory defaults within the web interface. I had a problem like that once and reset a few times like this to clear it up. I know it sounds crazy but the main idea is to clear up any residual nvram settings that don't get cleared when changing from one firmware to another.
  4. dfilkovi

    dfilkovi Network Guru Member


    I tried what you said, and linksys firmware works fine i restored it to the factory settings and then tried satori and alchemy, and both firmwares don't wont to accept LAN connection setup, only wireless.

    But i'm worried about something there: no matter how much I restart it (30 sec reset, or factory defaults) satori or alchemy firmware keeps the gateway default settings, and IP settings. How come this isn't restored?
  5. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    dfilkovi, you have to uninstall Satori. While running Satori telnet into the router and run nvram erase then imediately flash it back to Linksys firmware. Once that is done and the router has rebooted, do a 30 second reset. This should clear up all nvram vars from Satori. Your router does not support Satori read (http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=2463) for more info. In a nut shell, HyperWRT and official Linksys support the WRT54G 2.2 only. Alchemy 6 (rc5a and above) fully supports all router versions.
  6. dfilkovi

    dfilkovi Network Guru Member

    Can you please explain how do I do that? Is it dangerous?

    I have flashed it now with HyperWRT and it works fine, I will use wrt as an AP but I wanted to try client mode if I'll need that maybe. So can you tell me if I have to erase nvram? If I don't will that disturb HyperWRT operation?
  7. jagboy

    jagboy Network Guru Member

    Disman_ca is trying to say that your router is not supporting satori. but any alchemy6rcxx and above will work. i think that your best bet is dd-wrt if you want all the features. i have a WRT54G v2.2 with dd-wrt pre3.2 and it works great.
    ok about erasing the nvram that is just erasing all the left overs of the last firmware in the router. all the unused variables. this is not dangerous. it will just reset the routers memeory to factory defults..

    if you dont do i erasenvram;reboot it will not really affect hyperwrt. this is just used to reset the nvram.

Share This Page