1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with WRT54G3G and Huawei E620 3G datacard.

Discussion in 'General Discussion' started by SalteeDog, Sep 18, 2006.

  1. SalteeDog

    SalteeDog Guest

    My WRT54G3G is not recognising my Huawei E620 datacard.

    Here's the facts:-

    I'm on the Vodafone network in Ireland. The E620 datacard works perfectly when connected directly to my laptop, SIM is enabled etc.

    The router works fine without the card inserted but fails to get beyond self-test if it's booted with the card inserted. (Green power light keeps flashing). If I fit the card after the router has booted then I can see the card is getting power - however the maintenance screens on the router tell me that the router does not identify the card as being present.

    Prior to having the E-620 I tried it using the E-600/618 card. In that case the router was recognising the card as present.

    Linksys support has informed me by email that the Huawei cards aren't officially supported - however I do know that others have got the E620 card working with the router.

    The firmware I am using is v1.99.8 - which is the latest. I have re-installed it several times using versions I have downloaded fromt he Linksys site - in case there are any country variations.

    For what it's worth the Huawei firmware on the card is 11.16.09.09.11.

    I'd be grateful for any advice. Perhaps there is residual data on the router memory from when I was using a E618 (same SIM) that screwing it up?
     

Share This Page