Problems compiling a HelloWorld program!

Discussion in 'DD-WRT Firmware' started by NemoNowhere, May 3, 2005.

  1. NemoNowhere

    NemoNowhere Network Guru Member

    Hello,

    I'm trying to compile some simple programs for the WRT. I made a textbook helloworld c source file, downloaded the linksis GPL source, and used brcm tools to compile it like this

    mipsel-linux-gcc helloworld.c -o helloworld

    Then I downloaded it to WRT (i'm using DD-wrt) chmoded it to 711 and tried to run with:

    ./helloworld

    it then said:

    -sh: ./helloworld: not found


    Please help! I've been busing my ass to get a compiler for the WRT and it won't work. I suspect it has something to do (maybe) with libraries, maybe I have to statically link them or something.


    Hepl :(
     
  2. NemoNowhere

    NemoNowhere Network Guru Member

    Solution

    Eureka I got it!!!

    I just had to use -static switch with the compiler (uClibc) and now it works like a charm!

    Thanks NemoNowhere ;)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice