1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

progress report on dd-wrt v23

Discussion in 'DD-WRT Firmware' started by jagboy, Jul 9, 2005.

  1. dellsweig

    dellsweig Network Guru Member

    JohnSK

    WHAT ARE YOU TALKING ABOUT??

    Read my post - I am not using WPA.

    Config saves, JFFS2 enables are causing iptable corruption. Simple as that

    READ THE POST
     
  2. Cyberian75

    Cyberian75 Network Guru Member

    v23-beta:
    30.09.2005:
    kernel updated to the very lates 2.4.32-RC1 version
    recoded some function in the broadcom shared lib
    cesar gonzales pptp client updated again
    pptp for dhcp fixed (webgui)
     
  3. devil-strike

    devil-strike Network Guru Member

    Mirror Updated: http://dd-wrt.devil-strike.net/index.php?dir=v23/beta/30-9-05/
     
  4. devil-strike

    devil-strike Network Guru Member

    Found a bug on the log page, when u enable it and set it to medium and you save it will save it as high.
    CAN some1 confirm that for me?

    thnx
     
  5. Cyberian75

    Cyberian75 Network Guru Member

    Confirmed.
     
  6. devil-strike

    devil-strike Network Guru Member

    Thnx for the confirm :)
     
  7. BrainSlayer

    BrainSlayer Network Guru Member

    grrr thx too
     
  8. bigjohns

    bigjohns Network Guru Member

    LOL

    Sorry Brainslayer... I know how you feel. Squish one problem, another pops out.
    :whip:
     
  9. Cyberian75

    Cyberian75 Network Guru Member

    ...pops up.
     
  10. -jcb-

    -jcb- Network Guru Member

    Hi

    WPA2 PSK no more work with the 30.09
    work fine with the 29.09 :sad:
    I can see the AP, I click on join but nothing...

    flash, reset,ect.. done

    The only thing I change between work/don't work is WPA/WPA2 :(
    I make test 3 times.

    GS1.1 AP & GS1.1 Client router

    (I use now WPA PSK)

    JCB
     
  11. BrainSlayer

    BrainSlayer Network Guru Member

    i havent changed wpa/wpa2 in any way and it still works here.
     
  12. knight14th

    knight14th Network Guru Member

    About WPA: It is what I ve reported many times. The /usr/sbin/nas isn't started after flashing and rebooting the router. You have to disable wlan via web-gui and enable it again. Check whether /usr/sbin/nas ist running.
     
  13. HBauer

    HBauer Guest

    DHCP IP Assignment

    With the actual v23 beta I get a strange behaviour: I configured the DHCP to start assigning numbers with 192.168.x.100, but the first number assigned is 192.168.x.135.

    Greetings, HB
     
  14. -jcb-

    -jcb- Network Guru Member

    Hi,

    I make a anothers tests

    on the AP : /usr/sbin/nas /tmp/nas.lan.conf /tmp/nas.lan.pid lan
    on the client : nas -P /tmp/nas.wan.pid -H 34954 -i eth1 -S -m 4 -k c

    Everything work with WPA-PSK, I change only the choice to WPA2-PSK and the client see the AP but don't want to connect to it.

    I also test
    without afterburner
    without fram burst
    without afterburner & fram burst

    In IP fixed (normaly I fixe client IP in AP)

    Same result.

    I not enought good in wifi to make more.

    JCB (client router mode)
     
  15. hotrat

    hotrat Network Guru Member

  16. Portal

    Portal Network Guru Member

    When running BiTorent, sites load slow, or do not load at all, 192.168.1.1 loads very slow (30/09/2005)


    WRT54G v2.2 , firmware v2.3(30/09/2005)
     
  17. daenigma

    daenigma Network Guru Member

    Hey Brainslayer thanx for all of the work!

    Check your PM
     
  18. bigbaraboy

    bigbaraboy Network Guru Member

    After installing 30.09. release my wrt 2.2 is blocked after few hours. after reset everething Ok for wile,and then again
     
  19. pogiako

    pogiako Network Guru Member

    firmware

    where will i get shuch firmware?
     
  20. pogiako

    pogiako Network Guru Member

    try lowering your MTU
     
  21. Portal

    Portal Network Guru Member

    MTU=1500 (defaut)

    Overlocking for 216MHz is 1 week is ok , afterwards is slow :( , comeback for oryginal firmware linksys - action 2 - 3 day , afterwards for dd-wrt v2.2 (v2.3) and again 1 week is ok - afterwards is slow..............................
     
  22. auzroz

    auzroz Network Guru Member

    Possible bug

    I set it up to use brainslayers skin, but there are no buttons to apply settings, had to go back to linksys firmware. Every time I reload the DD-WRT firmware the same GUI appears, i have done a hard reset, flashed with numerous firmwares and reset to factory defaults, anyone help?
     
  23. pogiako

    pogiako Network Guru Member

    :) sirs' may i have a copy of that firmware as well?
     
  24. pogiako

    pogiako Network Guru Member

  25. barney34

    barney34 Network Guru Member

    Re: Possible bug


    Try opening it up with firefox and the save button is in the top left corner to change the setting back to default. I had same broblem with IE.
     
  26. 4Access

    4Access Network Guru Member

  27. space

    space Network Guru Member

    my 2 cents..

    i could see apply only using firefox not IE. Ie nothing is there aka aply refresh ect.
    Use Firefox 107..

    and
    has anyone had this problem where they are assigned a dhcp address but it is not listed in dhcp listed machines (under local). Fresh reboot it sees it but turn off and reboot later and its not listed anymore..
     
  28. Cyberian75

    Cyberian75 Network Guru Member

    Re: my 2 cents..

    Turn "DNSMasq for DHCP" off. It's a known limitation.
     
  29. Cyberian75

    Cyberian75 Network Guru Member

    04.10.2005:
    ssh is back (mini version)
    ASUS-WL500G Deluxe is supported now
    wireless mode selection fixed. (mixed mode problem)
    kromos style fixes integrated
    WMM/WME additions within the network code
    another try for a upnp solution
     
  30. king_tuk

    king_tuk Network Guru Member

    Wireless Bridge

    I have the 9-28 v23 on a WRT54G and can bridge with a dlink on channels 1-11 just fine then I tried channel 14 on the dlink and set wrt to connect and it does not see the router even when I have it scan for wireless networks. Does Channel 14 work on a US WRT54G? or is there a problem with the dlink?
     
  31. Toxic

    Toxic Administrator Staff Member

    unless your wireless device supports channle 14 (which most dont) then no is wont work.


    Channels 1-11 US
    Channels 1-13 EU
    Channels 1-14 Japan
     
  32. bytes2000

    bytes2000 Network Guru Member

    Oct 10 2005

    v23-beta:
    10.10.2005:
    ssh fixed
    auto disable for backup and firmware upgrade within https environment
    ipkg repository list updated
    kaid removed from voip version due fw size limit
    ebtables is back for qos
    (warning, lowers your network speed if you're using it)
    thats means also, never use qos with LAN/WLAN selection if you want high
    performance. use wan based networking instead


    wireless mac issue fixed (asus only)
    logging issue fixed (auto switching loglevel)
    port forwarding bug fixed (tcp/udp switch)
    port forwarding save bug fixed
    connlimit/connrate added
    internal memory management optimized (webgui only)
     
  33. crashoverride71

    crashoverride71 Network Guru Member

    port range forward problem : IP address is cutting when I save it.
    XXX.XXX.X.XXX become XXX.XXX.X . Not very useful.

    Thanks for this firmware.
     
  34. crashoverride71

    crashoverride71 Network Guru Member

    I solved this problem by using upnp forward.
     
  35. BrainSlayer

    BrainSlayer Network Guru Member

    okay. noticed at. fix@tomorrow
     
  36. jagboy

    jagboy Network Guru Member

    i like the new gui looks really good.
     
  37. jagboy

    jagboy Network Guru Member

    brainslyer are we going to see the feature were we can limit bandwidth by mac or ip.
     
  38. Cyberian75

    Cyberian75 Network Guru Member

  39. BrainSlayer

    BrainSlayer Network Guru Member

    @jagboy. where did you got the information about it?
     
  40. jagboy

    jagboy Network Guru Member

    i was looking through the forum and someone asked if it was going to be in dd-wrt so i thought i would ask....
     
  41. 4Access

    4Access Network Guru Member

  42. fracturex

    fracturex Network Guru Member

    here is a little workaround that worked for me. add another port forward, fill in same numbers (same as previous) and save the settings. It will truncate even more (at least on mine) and it will add the first digits (192) to the previous port forward line for you (which was truncated before). Just edit the 192 and change it to your own IP range, save settings, worked here.

    the bogus line then shows
    nothing in application - 0 - 0 - both - 0

    magic? :)

    grossartige firmware btw. Vielen Dank!!
     
  43. Rich-M

    Rich-M Network Guru Member

    httpd to alternate port

    Seems the past few releases I cant get the httpd to start on the port I specify in the GUI. Manually starting it with the -p works fine, except in the case of a remote reboot ;P (I know, I can ssh in and restart it...hehe)


    -Rich
     
  44. jagboy

    jagboy Network Guru Member

    the newest release bricked my router bad s times....luckly i was able to get it back and running both times. i have v3 router and tried the beta2
     
  45. unikum

    unikum Network Guru Member

    No problems here upgrading to beta2.

    One thing: Is it possible that you can enter the router´s IP when factory resetting? To explain: When doing a factory reset the IP will 192.168.1.1 but I would like to have 192.168.0.2 It´s always a little bit of work to connect the router to the laptop directly, change subnet on the laptop to .1.1 configure the router to .0.2, reconfigure the laptop to .0.x.

    Would be great if I could give the router an IP that shall be the router´s IP after a factory reset directly instead of doing all those steps described.
     
  46. unikum

    unikum Network Guru Member

    In OPERA if you click on "Aministration" the reult looks a little bit straight...
     
  47. pasys

    pasys Network Guru Member

    the admin page fails to load in safari..have to do it manually via terminal...It just will say DD-WRT in the tile , and would not load a single thing..weird eh..works fine on IE on Microshaft Windows (won't install edition) (aka Home Edition)
     
  48. 4Access

    4Access Network Guru Member

    That's a GREAT idea! Add my vote! :agree:
     
  49. dellsweig

    dellsweig Network Guru Member

    I wish we would hear from Brainslayer on this issue. MANY bricked routers on the beta 2 upgrade...
     
  50. jagboy

    jagboy Network Guru Member

    same hear....
     
  51. bytes2000

    bytes2000 Network Guru Member

    17 . 10 . 2005 build

    v23-beta-2:
    17.10.2005:
    catched 2 long term memory leakes in httpd daemon
    possibly crashbug fixed in uclibc (can also cause the strange upnp crashes)
    uclibc pipe function optimized (possibly you get enhanced speed now)
    building bug with std version fixed (WRT54G binary only), sorry about this
     
  52. BrainSlayer

    BrainSlayer Network Guru Member

    sorry about not answering to all posts. i'm busy with developing and i'm wake since 30 hours now. i do everything i can for you and i read almost everything, but sometimes (especially on weekend) i need my private time
     
  53. dellsweig

    dellsweig Network Guru Member

    THANKS

    I will try this out on my various WRT54G versions when I get home from work!!

    I will post results later this afternoon
     
  54. Morpheus

    Morpheus Network Guru Member

    Have a Good Zzzzzzzzzzzzzzzzzzz M8t.
     
  55. dellsweig

    dellsweig Network Guru Member

    Upgraded 2 of my 3 WRT54G's to 10/17 Beta2

    1) WRT54G V2 Client Bridge Mode - Successful upgrade
    No problems found

    2) WRT54G V2.2 WDS Node - Successful Upgrade
    No Problems Found

    3) WRT54G 3.0 Main AP/residential gateway
    I will upgrade this one tonight - have to get a 'maintence window' from the wife and kids so I dont disrupt the phones or Internet
     
  56. canis

    canis Network Guru Member

    Thanks, a great firmware!
    Port range forward, port forwarding and port triggering looks excellent,
    is it possible th handle blocked services in access restrictions in the same way?
     
  57. BrainSlayer

    BrainSlayer Network Guru Member

    its planned
     
  58. bombastikde

    bombastikde Network Guru Member

    DHCPd Static Leases

    Hi BrainSlayer,

    I want to inform you: DHCPd Static Leases doesn't work
     
  59. Honki

    Honki Network Guru Member

    confirmed! - http freezes when you set static IP. After reboot when you click on Adminpage->service the http dies again!
     
  60. bombastikde

    bombastikde Network Guru Member

    Hi BrainSlayer,

    I want to inform you: DHCPd Static Leases doesn't work
    Version Beta2 10/20/05 the same problem
     
  61. BrainSlayer

    BrainSlayer Network Guru Member

    dhcpd static leases works. i tested it with dnsmasq and without. possibly reset your router. httpd doesnt crash also here
     
  62. Cyberian75

    Cyberian75 Network Guru Member

    DHCP Client List/Table gets emptied when the router is rebooted even with JFFS2 enabled.
     
  63. BrainSlayer

    BrainSlayer Network Guru Member

    sure. after reboot everything is lost. you have to renew your ip
     
  64. BrainSlayer

    BrainSlayer Network Guru Member

    jffs2 support is not added to dnsmasq yet
     
  65. Cyberian75

    Cyberian75 Network Guru Member

    That's what I figured. It would be nice if it can store static leases like the old udhcpd did.
     
  66. bombastikde

    bombastikde Network Guru Member

    I don't know what i did wrong, but it did work with the new version 10/21/05.
    No I'm back to 10/18/05 and everything works fine.
     
  67. unikum

    unikum Network Guru Member

    The CYAN style is just PHANTASTIC!!!! GREAT WOW
    A "must have"

    Thanks!
     
  68. devil-strike

    devil-strike Network Guru Member

    Indeed the lastes styles are great :D
     
  69. bytes2000

    bytes2000 Network Guru Member

    v23-beta-2:
    26.10.2005:
    iptables reworked for memory optimization
    library size optimization added
    possibly tx/rx antenna selection problem fixed
     
  70. lore

    lore Network Guru Member

    Have any of you guys experienced extremely slow DHCP server respones (and timeouts) when you use DD-RT v23-beta-2 on the unit? I have both a 4.0 and a 3.1 WRT54G and both take a very long time -- if at all -- to release/renew leases.

    Thanks!
     
  71. Cyberian75

    Cyberian75 Network Guru Member

    Nope.
     
  72. BrainSlayer

    BrainSlayer Network Guru Member

    use dnsmasq for dhcp if you want a faster and stable one. the old one will be possibly removed in future versions
     
  73. lore

    lore Network Guru Member

    I tried using dnsmasq and it still takes up to 10 seconds or so before a lease is granted. Often times it just times out (usually when I do an ipconfig /renew) so I'm not sure what I'm doing wrong. But since it's happening on both units, I really have to wonder.

    How long is it taking you guys to get a lease upon connecting to the router?
     
  74. BrainSlayer

    BrainSlayer Network Guru Member

    1 - 2 seconds here. udhcpd takes 10 - 20 sek. sometimes. are you sure that you really switched to use dnsmasq? (the "use dnsmasq for dhcp" trigger)
     
  75. Cyberian75

    Cyberian75 Network Guru Member

    1 to 5 seconds with DNSMasq.
     
  76. unikum

    unikum Network Guru Member

    By the way: The name is SIPatH not Sipath as displayed in menu page ;-)
     
  77. dellsweig

    dellsweig Network Guru Member

    Greetings

    Been running V23 on the following (10/27 Std build)

    WRT54G V2 (clent bridge)
    WRT54G V2.2 (WDS repeater)
    WRT54G V3 (AP gateway router)

    My network is a mix of B and G with a max security of 128 WEP (due to existiong equipment limitations)

    DHCP is working great, wireless throughput especially on the G links is very good. Firmware stability is excellent.

    Logging still fails when a config save is attempted. Must reset (reset to defaults, re-enter config) to restore. I wish Brainslayer would find this bug

    Access restricitons: keyword restrictions or url restrictions do not seem to be working. I have 2 lists defined covering all IP's in network. If I put linksysinfo in keyword list - no effect.
     
  78. BrainSlayer

    BrainSlayer Network Guru Member

    brainslayer will fix it in near future
     
  79. lore

    lore Network Guru Member

    Yep - I enabled that checkbox. It seems to work better now - I've got the v4 and the v3.1 hooked up in my house now.

    Does udhcpd and dnsmasq run together? Both still show up on my process list. I saw a post where someone said that udhcpd is required for obtaining an IP address from the ISP, but has that been substantiated? (I have a static IP anyway so I don't really need that)
     
  80. 4Access

    4Access Network Guru Member

    Do you have keyword & url restriction rules configured as allow or deny rules? As weird as it sounds when I tested the access restrictions using DD-WRT v22-final I discovered that the rules have to actually be set to ALLOW for the keyword or url filtering to take place...! (Has to do with the way the iptables rules are configured.)
     
  81. lore

    lore Network Guru Member

    Okay, I definitely spoke too soon. Everytime I power on my desktop, Steam complains that it's not connected to the Internet and therefore can't get updates. Usually the DHCP lease is obtained by the time my desktop is on, so I'm not sure why it's taking so long, even with dnsmasq enabled.

    With my laptop, when I come out of standby it takes another 10-15 seconds for dnsmasq to assign a lease to the wireless adapter. Usually I get it within 2 or 3 seconds.

    I really have no clue why it's taking so long on both of these routers. And just FYI, when I tried using a different firmware, (HyperWRT or Linksys default) the lease was obtained very quickly.

    Any insight would be appreciated.
     
  82. space

    space Network Guru Member

    have u tried any new versions

    have u tried any new versions?
    also
    could you run steam after you are safely connected to internet?
    later
    space
     
  83. lore

    lore Network Guru Member

    Re: have u tried any new versions

    Haven't run any version other than 10-27-05 yet, but yes, I can run Steam after I get the IP. The point I was trying to make was that the DHCP server is so slow that it takes a good 20-30 seconds AFTER I'm logged into the box before it gets an IP lease.

    Once the IP is obtained, normal Internet functionality is fine. It's just that beginning period that is very painful when I'm waiting for the IP to renew.
     
  84. unikum

    unikum Network Guru Member

    changing name from Sipath -> SIPatH was only partly corrected. If I click on "Wireless" the name shwon ist Sipath again (and not SIPatH)...
     
  85. unikum

    unikum Network Guru Member

    On status page after accessing the WebGUI it says:


    Mem Info
    total used free shared buffers Mem: 30488 15312 15176 0 1596 Swap: 0 0 0 Total: 30488 15312 15176
    DD-WRT


    It would be better if those values would stand in the next line or be rearranged in another way
     
  86. dellsweig

    dellsweig Network Guru Member

    Well - general impressions of the V23 11/04 build

    Client Bridge mode:

    Attempt to configure client bridge (on an existing V23 client bridge) failed. I did a hard reset and selecting client bridge on the GUI would not save. Just for kicks, I set 'client' from the list. Worked fine - Client bridge works no problem

    WDS repeater:

    No problem upgrading and running

    AP/ Gateway Router (WRT54G V3.1)

    Upgrade worked great. Logging no longer works at all
    Tried hard reset, left ALL settings at default, enabled logging. NO ENTRIES in logging GUI)

    This bug has been around in various forms for a while. In the past saving certain features will terminate logging. In this release it just does not work

    Brainslayer. Logging in many implementations is very important. PLEASE look into gettint logging working reliably
     
  87. 4Access

    4Access Network Guru Member

    You seem to be contradicting yourself... First you say client bridge doesn't work but then you say "client bridge works no problem"... typo?
     
  88. dellsweig

    dellsweig Network Guru Member

    The configuration pull-down listed 'client bridge' and 'client'.

    Normally, I configured my client bridge using the 'client bridge' pick. When I selected this, then save - the change would not take - the device remained in AP mode. When I selected 'client', the change took and the device was correctly configured as a client bridge.
     
  89. unikum

    unikum Network Guru Member

    Maybe you could thinka bout integration of DDNS

    www.selfhost.de

    a free DynDNS service?
     
  90. bytes2000

    bytes2000 Network Guru Member

    Can we have new l7 protocols ?

    P2P
    openFT <- P2P filesharing (open fasttracker)
    ares - Ares - P2P filesharing


    dunno if "msn" from v23 matches this:
    msn-filetransfer

    dunno if "skype" from v23 rule matches this 2 rules:
    skypeout
    skypetoskype

    http://l7-filter.sourceforge.net/protocols
    thanks
     
  91. dellsweig

    dellsweig Network Guru Member

    11/08 Build

    Logging - FIXED
    backup/restore - FIXED

    dyndns - not updating

    THANKS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
     
  92. flexy

    flexy Network Guru Member

    i posted something about this not long ago...i am still on 11/1. I looked thry the source and there is a giant heap of l7 protocols with the sourcecode. But those protocols are not shows/available in the firmware itself.
    (Because they're the same ???? Like Counterstrike:Source, Halflife2:DM etc....) The files are all there but you cant select in the firmware.
     

Share This Page