1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Question about usb-hd spin down script on RT-N16

Discussion in 'Tomato Firmware' started by gaoxingbu, Jun 21, 2010.

  1. gaoxingbu

    gaoxingbu Networkin' Nut Member

    Hi,

    With the help of many threads in this forum, I set up spin down of the usb attached HD on my RT-N16. It worked fine for me for one day, and then it stopped working. Here is the details:

    What I did in initial setup:
    1. created idle-disks.sh and idle-disks.conf under /tmp/home/root
    2. created a whitelist file containing my HD info under /var/idle_disks
    3. Started the script by running idle-disks.sh &

    I then observed the spin down behavior a couple of times. It's working fine, great.

    One day later, I mapped network drive under windows to my HD, and after a while, I noticed the spin down doesn't happen anymore. Thinking it may be caused by the mapped network drive, I disconnected it and still the spin down doesn't happen. What could be wrong here?

    Now I thought I may have to reboot the router, so I went ahead and reboot the router. After the reboot, I logged in the router and found the two files I created in step one are gone. It's understandable since they are under /tmp/home/root. Can anyone tell me how to make these file permanent?

    Thanks!
     
  2. rhester72

    rhester72 Network Guru Member

    In init, you can "echo" out the scripts to those files with no need of external dependencies if they are small enough.

    Rodney
     
  3. teddy_bear

    teddy_bear Network Guru Member

  4. rhester72

    rhester72 Network Guru Member

    The scripts themselves seem to have disappeared - I was very interested in seeing how you determine 'activity' ;)

    Rodney
     
  5. gaoxingbu

    gaoxingbu Networkin' Nut Member

Share This Page