1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

R7000 File Share not working

Discussion in 'Tomato Firmware' started by .net.com, Nov 6, 2017.

  1. .net.com

    .net.com Network Newbie Member

    Hello

    I tried to set up File sharing on my tomato router (Netgear R7000) but I couldn't get file sharing working no matter how I tried the settings :(
    FTP Server and Media server working flawlessly
    I've found following messages in syslog related to smb.
    Anyone able to help?
    Nov 6 12:13:47 Main-WiFi daemon.err nmbd[22353]: Samba server MAIN-WIFI is now a domain master browser for workgroup WORKGROUP on subnet UNICAST_SUBNET
    Nov 6 12:13:55 Main-WiFi daemon.err nmbd[22353]: Samba server MAIN-WIFI is now a domain master browser for workgroup WORKGROUP on subnet 10.10.30.10
    Nov 6 12:14:10 Main-WiFi daemon.err nmbd[22353]: Samba name server MAIN-WIFI is now a local master browser for workgroup WORKGROUP on subnet 10.10.30.10
    Nov 6 12:46:51 Main-WiFi daemon.err smbd[23001]: ERROR: smbd is already running. File /var/run/samba/smbd.pid exists and process id 22361 is running.
    Nov 6 12:47:17 Main-WiFi daemon.err smbd[23012]: ERROR: smbd is already running. File /var/run/samba/smbd.pid exists and process id 22361 is running.
    Nov 6 13:20:01 Main-WiFi daemon.err nmbd[23462]: Samba server MAIN-WIFI is now a domain master browser for workgroup WORKGROUP on subnet UNICAST_SUBNET
    Nov 6 13:20:09 Main-WiFi daemon.err nmbd[23462]: Samba server MAIN-WIFI is now a domain master browser for workgroup WORKGROUP on subnet 10.10.30.10
    Nov 6 13:20:24 Main-WiFi daemon.err nmbd[23462]: Samba name server MAIN-WIFI is now a local master browser for workgroup WORKGROUP on subnet 10.10.30.10

    Any help would be much appreciated.
     
    Last edited: Nov 6, 2017
  2. ghoffman

    ghoffman LI Guru Member

    are the processes running? it looks to me that they are, and that they are functional.
    if you are concerned that you cant access the resource, are you using windows 10 as a client? updates to windows 10 have turned off unprotected SMB browsing. i spent a number of hours over the past few weeks trying to figure this out. my R7000 SMB server and shares disappeared from fview after my windows machine updated to the 1709 release. however, a router running openwrt with samba was still visible. i finally figured out that you need to set a user and password on the samba server to force the windows client to not automatically reject the samba server as a potential rogue. (this is my rudimentary understanding)
    further insight is welcome.
     
    .net.com likes this.
  3. .net.com

    .net.com Network Newbie Member

    Thanks a lot, I've turned on SMB 1.0 on win 10 worked straightway, We had the same issue with old netgear NASes too how come I didn't think of this.:)
     

Share This Page