1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Random restarts?

Discussion in 'HyperWRT Firmware' started by gamma, Jan 9, 2005.

  1. gamma

    gamma Guest

    Hi. I purchased my 2.2 WRT54G yesterday and dropped HyperWRT 2.0b4 on it. So far I'm happy (add my name to the static dhcp request list!). But, I've noticed that the router seems to be restarting every couple of hours. I went to bed last night with an uptime of about 1 hour. I got back to the router about 10 hours later, and the uptime is 2 hours, 40 minutes.

    Is there a reason that the router randomly reboots? Is there a way to track what is causing the reboots? I was pushing some P2P traffic last night (Bittorrent and ed2k). I added the "echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max" to my router's startup to aleviate some of the problems related to p2p sucking connections.

    As a follow up, it seems to be occuring sometime after the 3 hour mark. My fiancee said she got kicked from her IRC session. The router had restarted at that point. I'm getting to where I want to return this thing and put my POS netgear 802.11b back in. :(

    Thanks for the assistance!

    - Joe
  2. pharma

    pharma Network Guru Member

    I've been going on 24 hrs without a restart or any problems. I reset my router (reset button pressed 20 sec) following loading the new firmware, but don't think you need to do this.

    Good luck,
  3. Morpheus

    Morpheus Network Guru Member

    i an up to 38 hrs without a restart .
  4. jlw

    jlw Network Guru Member

    23 without a restart
  5. envoid

    envoid Network Guru Member

    I have a similar issue with my v1.0 WRT54G. I don't know if it's Avenger's changes or Linksys' code in 3.03.1 tho. Doesn't seem to reboot my router, but definitely forces a reconnect on PPoE. Wierd thing is that usually it will reconnect shortly after resetting it and doing some traffic (web, p2p, anything). After that it's fine for the most part, with maybe a reconnect with heavy traffic after runnning a few weeks.

    I've recently gone back to 1.3b. Feels more efficient or something but doesn't do this.
  6. howardp6

    howardp6 Network Guru Member

    I have been up 6 days and 4 hours with HyperWRT 2.0b4. I jave no P2P that may be the difference.
  7. Padraic

    Padraic Guest

    Uptime: up 3 days, 3:32, load average: 0.00, 0.00, 0.00

    HyperWRT 2.0b4 on a WRT54G V2.

    Haven't had to restart since I loaded the firmware.
  8. JasonM

    JasonM Network Guru Member

    Been up 5 days. Not a single problem since installing the firmware. I have used P2P.
  9. cbrunnkvist

    cbrunnkvist Network Guru Member

    You can't know the uptime without actually checking - it's easy to miss a quick "no one saw me!"-reboot that the WRT54G seems to do in some revisions (v2.2 hardware and v3.03.1 firmware for me!).

    I think there should be a reference in this thread to the "secret" page: .. :idea: There's the "uptime:" in seconds. (I've yet to see it pass 80000!)

Share This Page