1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Recovering a power zapped RT-N16

Discussion in 'Tomato Firmware' started by PJON, Jul 13, 2013.

  1. PJON

    PJON Networkin' Nut Member

    I have been running an RT-N16 behind a Netgear DG834 v4 (in bridged mode) for over a year. Recently both were zapped when I had a power outage (I didn't have a surge protector, I do now).

    I managed to get the Netgear operational again with a 30/30/30 type reset. Doing this on the RT-N16 brought the wireless back to life but not DHCP. I tried to reflash the router using TFTP but haven't had any luck so far, and the wireless no longer shows up. I've already replaced it and am wondering if I should throw it out or if there's any chance it's recoverable (it responds to pings)?

    Thanks for any advice.
     
  2. darksky

    darksky Networkin' Nut Member

    When you say that it is 'back to life but not DHCP' ... does that mean that you can connect to the http interface and everything appears good, but that DHCP does not work despite being enabled?

    I assume that it has flashing lights, looks like it's booting, etc.

    1) Do a 30-30-30 on it now.
    2) Are you able to connect to the web interface then? Note, you may have to simplify your LAN connection temporally bring just it and your PC/laptop into the picture. Note that some TomatoUSB mods have DHCP disabled by default... Toastman's for example do. You may have to assign an static IP on the PC/laptop is my point.
     
  3. PJON

    PJON Networkin' Nut Member

    Thanks for the quick reply. I tried what you suggested (30/30/30) the next day but didn't get back here until now, sorry. I wanted to try it again, which I have done, with no better luck.

    I meant by "back to life" that the SSID showed up on my phone using a wi-fi analyser. Couldn't connect via HTTP.

    After reflashing there's no SSID and HTTP connection still doesn't work. On/off icon blinks slowly. Device responds to ping on 192.168.1.1. I flashed it earlier with a netbook assigned a static IP and with just an Ethernet patch cord connected to LAN port 1. Flashing looks good but it doesn't seem to take.
     
  4. Monk E. Boy

    Monk E. Boy Network Guru Member

    If the on/off icon blinks slowly usually means the router is in recovery mode. Use the ASUS Firmware Utility to flash a new firmware onto the device.

    Edit: Given that it's suffered a power surge anything is possible but I'd check to see if you can get it into recovery mode. Disconnect it from power, hold down the restore button, connect it to power, and continue holding down the restore button until the power light starts slowly flashing on and off, release the restore button, then assign a manual IP (192.168.1.2) address to your ethernet NIC and see if http:// 192.168.1.1 responds. Alternately you can avoid assigning an IP and just fire up the recovery utility... it doesn't need an IP assigned to the interface.
     
  5. PJON

    PJON Networkin' Nut Member

    I tried reflashing it with TFTP on Linux (uploading a Toastman firmware). Are you saying that it's necessary to restore an Asus firmware first? No doubt you've read that these have security problems but if it's a necessary step I'm happy to do it.
     
  6. koitsu

    koitsu Network Guru Member

    Monk E. Boy is saying you should use Asus's Firmware Utility to recover the router back into a factory default state, i.e. into a working state where you can start fresh. Asus's utility also takes the hassle out of the TFTP upload method and also deals with NVRAM mistakes/corruption. Sure, you can TFTP a firmware yourself, etc. but it takes very precise timing and lots and lots of tries (in my experience 15-20 tries is not uncommon) to get the timing perfect (it's a lot easier if you have serial console since then you can see exactly when to issue the TFTP PUT).

    Asus's Firmware Utility will not let you upload third-party firmwares (at least the last time I tried it it didn't), but so what -- the point here is that you're trying to get the router back into a state where you can use it again. Get the stock Asus firmware on there + a working web interface, then once you have that, switch over to whatever third-party firmware you want.
     
  7. Monk E. Boy

    Monk E. Boy Network Guru Member

    The utility that shipped with the N66 had been updated to complain when flashing third party firmware, but would still flash the third party firmware after presenting the warning. The older versions that shipped with the N16 lacked this warning.

    I haven't grabbed any updated utilities since then, so maybe they've progressed to not just warning but preventing, but older versions of the utility were still available on ASUS's support site. In other words, just grab an old version of it... its not like the N16 hardware has been updated, the old software should work fine with it.

    Making sure the router is in recovery mode is key, though, which is accomplished by holding down the restore button when applying power, then continuing to hold until the light starts slowly flashing. Your router by default is trying to load the firmware and failing, which be part of the reason why it's in this odd half-alive state. By forcing it to be in recovery mode it will never progress beyond the CFE.
     
  8. PJON

    PJON Networkin' Nut Member

    Ok thanks for the clarification. I previously used TFTP with no issues but didn't know it could be problematical in this situation. I tried again using the Asus recovery tool and an Asus firmware image but got the message after 30 seconds or so:

    No wireless device in recovery mode is found

    The slow blink of the on/off light is there whether I hold the reset button for 30 seconds or not when powering up.

    Lost cause? :(
     
  9. koitsu

    koitsu Network Guru Member

    Try contacting Asus? :)
     
  10. mvsgeek

    mvsgeek Addicted to LI Member

    Which Asus recovery tool are you using? I ran into the "No wireless device..." issue with the version on the CD that came with router. This one worked for me. It's referenced in this link.
     
  11. Toastman

    Toastman Super Moderator Staff Member Member

Share This Page