1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Remote access WDS unit

Discussion in 'Tomato Firmware' started by GhaladReam, Oct 25, 2012.

  1. GhaladReam

    GhaladReam Network Guru Member

    Hi folks, i'm running into an issue where I'm unable to remotely access the Tomato webUI of a WDS repeater. I have 2 Tomato routers in a WDS setup. I enabled remote administrator on port 8080 for the main unit which is physically connected to the WAN. I am able to remotely access this unit. The only way I'm able to access the WebUI of the WDS unit is if I'm on the local LAN. I've enabled remote admin on the WDS unit, and told it to use port 8081, and then gone ahead and forwarded port 8081 on the main WAN router to the WDS unit, but I'm still unable to access it using https://x.x.x.x:8081, but i CAN access the main router using https://x.x.x.x:8080

    Am I missing something?
  2. mikester

    mikester Network Guru Member

    Did you enable "Allow Wireless Access" under /admin-access.asp?
  3. mvsgeek

    mvsgeek Addicted to LI Member

    This works for me...

    Main router ( :

    Port Forwarding ---> On TCP 8087 8087 remote https

    WDS Slave ( :

    Admin Access ---> Remote Access : HTTPS
    Port : 8087
    Allow Wireless Access : unchecked (tried it both ways, both work)

    I can then access from my droid phone using https://xxx.xxx.xxx.xxx/8087 where xxx... is my external IP.
    After much head-scratching I realized that although the Port forwarding rule was defined on the main router, I didn't have it set to "on" :oops: Duh!
  4. mikester

    mikester Network Guru Member

    BTW in case it wasnt a typo you should probably be using a colon instead of a slash to specifiy the port...

    unless android does things differently...
  5. mvsgeek

    mvsgeek Addicted to LI Member

    Thanks Mikester, yes it was a typo :oops:
  6. GhaladReam

    GhaladReam Network Guru Member

    Thanks for the help guys, but it's still not working for me. I should have mentioned I'm using HTTPS and not HTTP.. Would I also need to forward port 443? I'm worried that if I do that however that I won't be able to access the main router anymore.
  7. mvsgeek

    mvsgeek Addicted to LI Member

    Try setting the "Local Access" HTTPS port on the slave to 8081. Looks like the hop from main to slave is treated as "local". "remote" only applies to the initial connection from WAN to main, everything thereafter is "local".

    I'm also using HTTPS, and port 443 is not referenced anywhere in my configs. I can access both main and slave using the appropriate port number (with appropriate colon;))
  8. GhaladReam

    GhaladReam Network Guru Member


    That's exactly what is was! Thanks for this. I disabled remote access on the WDS slave, and kept local access to 8081 and now I'm able to access main router on 8080 and WDS slave on 8081.

Share This Page