1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Router not getting an ip adress?

Discussion in 'Tomato Firmware' started by flxfxp, Jul 13, 2009.

  1. flxfxp

    flxfxp LI Guru Member

    Hello,

    For a long while I have used tomato on my Buffalo WHR-HP-54 as an access point while I was using a crappy linksys gateway for the rest of the stuff. However, today I have been blessed with a faster internet connection and a new modem. The modem works on DHCP and when I plug my laptop I get the following settings:

    [​IMG]

    This works perfectly, but when I try to use my tomato router it doesnt get an ip adress, it keeps saying renewing:

    [​IMG]

    I am using the following settings for the tomato router to pick up the dhcp adress broadcasted by the modem:

    [​IMG]

    I have tried the following things:
    - Upgrade to latest firmware
    - Reset all settings (including nvram)
    - Enabled "Reduce packet size for DHCP WAN"
    - Filled things in statically instead of dhcp for modem (using settings earlier from laptop)
    - Tried the WAN port for modem
    - Tried one of 4 LAN ports for modem
    Can anyone please help me fix my problem? Without help I cannot use my new internet connection.

    Thank you in advance!

    Kind regards,

    Dennis
     
  2. fyellin

    fyellin LI Guru Member

    Have you tried power-cycling the modem? I typically need to reboot the modem when I switch routers.
     
  3. flxfxp

    flxfxp LI Guru Member

    Hi fyellin,

    Thank you for your swift reply, much obliged.
    In what order would you like me to power cycle?
     
  4. fyellin

    fyellin LI Guru Member

    You don't need to power cycle the router. Just the modem. When you're done, you may need to click "Renew DHCP Lease" on the router.

    I won't guarantee this to solve your problem, but if you haven't rebooted the modem, you should.
     
  5. flxfxp

    flxfxp LI Guru Member

    Damnit man, you did it! Stupid of me, thanks for your help!

    Dennis
     
  6. fyellin

    fyellin LI Guru Member

    That's what this forum is for.

    It seems that some cable modems have badly written software in them, and can only handle a single device plugged into them. If you plug something else into them, they just can't deal.
     

Share This Page