1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Router time not available

Discussion in 'Tomato Firmware' started by sim642, Jan 2, 2012.

  1. sim642

    sim642 Networkin' Nut Member

    I'm loving Tomato firmware so far, but I've got a problem with it. It doesn't have time available: under Basic>Time it says: "Router Time Not Available". The time problem (I think) is causing bandwidth monitoring not to work properly: only realtime and last 24h work, but not months and so on. Can anyone help me?
  2. shibby20

    shibby20 Network Guru Member

    this is your prime-router? Has an internet access? Has set gateway and dns server? Tomato is downloading time from internet.
  3. mvsgeek

    mvsgeek Addicted to LI Member

    On my secondary (AP+WDS) routers I have to set DNS server to LAN IP of the primary (, otherwise the time doesn't get updated.
  4. shibby20

    shibby20 Network Guru Member

    gateway? WAN type set to Disable, then Default Gateway set as

    have you ping from this router? (tools -> ping -> 0.europe.pool.ntp.org)
  5. Mercjoe

    Mercjoe Network Guru Member

    Thank you for the DNS idea.

    Setting the gateway to the main router did not allow time to be resolved. I just cut and pasted the DNS servers address from the main router to the remote router and now the time is updated on the remote router.

    Such a simple solution.

    With that said, when a router is used in a WDS, why doesn't the remote router get the DNS info from the main router??? Why does it have to be manually resolved. It would make sense that is does it automatically as part of the service/protocol.
  6. sim642

    sim642 Networkin' Nut Member

    Got the time working after I set default gateway and DNS to the main gateway. The tomato device is in wireless ethernet bridge mode.
  7. mvsgeek

    mvsgeek Addicted to LI Member

    By setting both default gateway and DNS server to on all my WDS remote routers, I don't need to specify external ISP DNS servers. My main is running vanilla Tomato 1.28, remotes are Toastman 7625. All are WRT54GL's. When I implemented Toastman 7625 on the main, the WDS connections were subject to random drops, so I reluctantly reverted to 1.28.
  8. Mercjoe

    Mercjoe Network Guru Member

    Setting the Gateway and DNS servers to my main router did not allow time to be set on my setup.

    Let me experiment and see what it up.
  9. Mercjoe

    Mercjoe Network Guru Member


    No idea what was wrong. I could not ping the time server from the remote router with main router set as a gateway and as DNS server on the remote router. Repeated the test several times. If I put in external DNS servers , I could ping the time servers, otherwise it would time out with 100% packet loss.

    I spent well over an hour trying different setting on both the main and remote router.

    I thought I had it down to the the "Use Internal DNS" on the Advanced --> DCHP/DNS Server menu on the main router. When I turned it on (I have it defaulted to off) suddenly the configuration worked. So I went back to the original settings to do a conformation test and it STILL worked. I could ping the time servers no problem now after I turned that setting on and then back off.

    So I rebooted BOTH the routers and now everything works when Gateway and DNS servers are set to the main router IP with my original configuration.

    Ahh, the strange world of software.

    Mvsgeek, update to the latest ND version (see my sig). It is extremely stable in a WDS configuration. I have NEVER had a dropout and the speed it a rock steady 54/54 for me. Yes, I can state NEVER as I have my house server at the other end of the WDS and it logs whenever it loses the internet connection, which it never has since the update on the router.
  10. mvsgeek

    mvsgeek Addicted to LI Member

    Mercjoe, I just checked that "Use internal DNS" setting, and it's set ON in all my routers. ON must be the default, because I've never touched that setting.

    Thanks for the ND reco, I'll give it a whirl on the secondary routers. However I'm going to replace the main with an Asus RT-16N as soon as I resolve another issue (see recent "Fun with..." thread).
  11. Mercjoe

    Mercjoe Network Guru Member

    Yehh, on is the default.

    Strange thing is that for some reason, ,my wife was getting numerous 'failure to open DNS' errors when browsing and/or doing her work. She can have upwards of 40+ URL's open at a time on her machine.

    When I turned it off, the errors stopped. When I turn it on, they come back on the errors return. But only on her machine. It did it both on her old XP machine and now on her newer Windows 7 machine.

    All it does I think is cache the recently used DNS lookups on the router.
  12. Paul C.

    Paul C. Reformed Router Member

    If you are still having trouble using the Tomato 1.28 as an access point and not getting the Router Time here are the steps:

    Menu-> Basic-> Network, WAN/Internet Type: Disabled, Check - Use WAN port for LAN

    Use the Router IP you are assigning your access point (example:
    Default Gateway: This is the gateway IP of your main router (example ATT U-verse uses
    Static DNS: Same as Gateway (
    Uncheck DHCP Server

    Wireless should be setup however your preferences are.

    Make sure you save the setup and check the Status Overview page and the Router Time should be there for you.

    Hope this helps

    Paul C.

Share This Page