1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Router wrt54gs is unable to keep time after reboot

Discussion in 'Tomato Firmware' started by tomatodude, Jul 31, 2008.

  1. tomatodude

    tomatodude Addicted to LI Member

    I was running tomato firmware 1.19 on a linksys router wrt54gs v1 for about three months now without any issues. Last night I decide to upgrade my router to version 1.21. Then my problems begun.

    After the upgrade had completed successfully I notice that the router time (Under Basic-->Time) was not available. I tried rebooting the router, clearing the NVRAM (Normal and thorough) but it did not help. Then I tried to manually set the time using the command "date". All seem to go well until I rebooted the router. Then the time was lost again and I have to set it manually once again.

    After spending many hours without finding any solution to my problem I decide to go back to version 1.19. But for unknown reasons now the problem appears there as well. This problem was not present to version 1.19 before!!!

    After flashing my router to version 1.19 I tried both to erase the nvram and start all over again, and to load my backup settings prior to the upgrade to version 1.21. The problem however did not go away.

    Currently I am running scripts that they need to know the correct time in order to run without any problems. Does anybody has an idea why this is happening and perhaps how can I resolve this? This is very important to me.

    Thanks in advance,

  2. TexasFlood

    TexasFlood Network Guru Member

    I wish I could help. It's working for me on my routers. Running Victek's v1.20.8002 on one and Jon's v1.21.1515 on the other.

    Settings are mountain time zone, auto DST, Auto update every 24 hrs, no trigger COD

    For some reason, I have one router set to:
    North America NTP server (0.north-america.pool.ntp.org, 1.north-america.pool.ntp.org 2.north-america.pool.ntp.org)

    and the other set to

    custom NTP of pool.ntp.org, and time.windows.com.

    Hmm, wonder why I did that? Both are working. I changed that custom NTP setting back to the Tomato North America NTP server, rebooted and working that way so leaving it. I must have been experimenting earlier for some reason and didn't clean up after.
  3. tomatodude

    tomatodude Addicted to LI Member

    Hi TexasFlood,

    Mine is not working :(. This is very strange. As I explain earlier I flash back my older version (after erasing nvram) but hte problem is still there.

    Any ideas anybody please?


  4. TexasFlood

    TexasFlood Network Guru Member

    What are your time settings? Can you ping the selected NTP server?
  5. tomatodude

    tomatodude Addicted to LI Member

    Hi TexasFlood,

    Yes I can ping it and trace it both through a pc in my network and through the UI of the router. I also try other NTP servers as well with the same results.

    One think that I have notice is that my time settings say UTC+02:00 and my time after I manually set it, it says +3:00

    Can you confirm if this is the case with your settings as well?



    Attached Files:

  6. TexasFlood

    TexasFlood Network Guru Member

    Quite a puzzler. Have you added/edited any scripts recently, particularly ones that might contain the date command? Kinda grasping at straws, wondering if the router might be getting the time then clobbered by a date command with a typo or something.

    My time settings in the GUI says UTC-7:00 Mountain Time in the drop down. Above that it reads Router Time Thu, 31 Jul 2008 16:39:28 -0600

    Here is what I got from the command line:

    /tmp/home/root # date -s 073116362008
    Thu Jul 31 17:36:00 MDT 2008

    Didn't change the way the GUI time was reported at the top of the page, still UTC-6:00 (Moutain DST).
  7. tomatodude

    tomatodude Addicted to LI Member

    Hi TexasFlood,

    I do have a script that is run at WAN_UP and it does contains the date command. But this script was not changed recently and it was working fine long before I upgrade to version 1.21. Also this script only reads the date, it does not attempts to alter it by any way. Finally I have checked it and it does not contains any typos.

    This script however was present in the WAN_UP when I attempted to upgrade to version 1.21. It was not present though when I cleared the NVRAM and checked again for the problem. During that check the problem still existed.


  8. TexasFlood

    TexasFlood Network Guru Member

    OK, well, good luck, I'm out of ideas for the moment, will come back if I think of anything else. Weird....
  9. tomatodude

    tomatodude Addicted to LI Member

    Thanks TexasFlood,

    This is really strange. I do not have an explanation either. This is why I came to this forum to ask about it. A lot of people here deal with similar problems every day, I thought that maybe someone has an idea how to solve my problem as well.

    Anybody please?


  10. TexasFlood

    TexasFlood Network Guru Member

    Only way I could get time "not available" on that page was to put a custom bogus NTP server name in there. If you're using names, perhaps could be related to DNS somehow so maybe try an IP address if so, or try OpenDNS like I use now. Again, kinda grasping at straws, bugs me when I hear of something broken that really shouldn't be, but is. Anything interesting in the logs? I can usually tell when my NTP has kicked in by a message like:
    "cron.err crond[214]: time disparity of 20292421 minutes detected"
  11. krux01

    krux01 LI Guru Member

    are there any errors reported in /var/log/messages ?
  12. tomatodude

    tomatodude Addicted to LI Member


    I am currently at work and I can not see the logs from here. I will check them as soon as I get home and I will get back at you.

    If you think that this might be a DNS related probelm I will also try to reboot my ISP's modem to see if this resovles the issue somehome.

    Thanks a lot,

  13. tomatodude

    tomatodude Addicted to LI Member

    Hi again,

    I am now home and I have access to my router. I am using a script that backups all the /var/log/Messages/ to an external storage. After searching all the logs since last night these are the only messages that appear in the logs regarding time:

    "Jan 1 08:58:20 homerouter user.info rcheck[15928]: Time not yet set. Only "all day, everyday" restrictions will be activated."

    "Aug 1 01:14:00 homerouter cron.warn crond[286]: time disparity of 20292371 minutes detected"

    "Aug 2 00:14:03 homerouter cron.warn crond[286]: time disparity of 1380 minutes detected"

    Do these messages mean anything to you?

    Thanks a lot,

  14. TexasFlood

    TexasFlood Network Guru Member

    You mentioned rebooting the ISPs router.

    Since I started playing with 3rd party firmware that I have found a few situations where the hardware seems to lose "sync" and needs a hard power cycle to get back on track.

    Examples of this:
    My Comcast cable modem will not recognize at least some service upgrades / reconfigurations unless I unplug it for several minutes then plug back in.
    With some firmwares, don't think Tomato, WDS reconfigurations will not work unless I unplug the routers for a minute or two and plug them back in.

    When I run into an unknown issue with my network that is really kicking my rear, I start with a like 5 minute removal of power from my routers and the ISP cable modem, just to be sure that potential variable is taken care of to the extent possible.

    The message:

    "Aug 1 01:14:00 homerouter cron.warn crond[286]: time disparity of 20292371 minutes detected"

    Indicates to me that the router system clock was updated somehow, be it NTP or a manual date command, from the boot default of "Wed Dec 31 17:00:00 MST 1969" to current.

    I'm not sure about the message:

    ""Aug 2 00:14:03 homerouter cron.warn crond[286]: time disparity of 1380 minutes detected""

    That indicates a 23 hours change in the clock 3 seconds after the first time change. I don't see that on my router.
  15. tomatodude

    tomatodude Addicted to LI Member

    Hi TexasFlood,

    thanks my problem is now resolved!!! The problem must been have a lost in "sync" between my ISP modem and router. The reason that I first mention my ISP modem was because you mention that my problem might be related with the DNS. But I really had no idea that there could be a "sync" problem between my ISP modem and router.

    Just for the record this is how this was resolve:

    1) Shut down ISP modem
    2) Shut down router
    3) Wait up to 10 minutes to turn up the ISP modem (maybe it needs less time. in my case I awaited 10 minutes)
    4) Wait until your ISP modem is ready for connection (In my case this is indicated after a specific led begins flashing. I was informed about this from my ISP).
    5) Power up your router and wait for it to start up. Everything works fine now.

    Some more notes as well. After "re-sync" my router and ISP modem two more problems that they had appeared with the date problem there are now gone.

    The first problem was with the "Auto Daylight Savings Time". If this option was selected, and then I manually tried yo set the date and time, a wrong time was shown on the router. For example in order to set the time to 16:35 I had to set it to 15:35, otherwise on the time will appeared to be an hour later.

    The second problem was a big delay when I telnet to the router. In some cases I could even waited up to a minute or two before I even get the prompt to enter my login name.

    Both of these problems are now gone as well.

    Again thanks a lot you are a great help,


Share This Page