1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rstats keeps crashing and wont effectively monitor bw

Discussion in 'Tomato Firmware' started by lanmtl, Nov 23, 2009.

  1. lanmtl

    lanmtl Addicted to LI Member

    I just got myself a WRT54G v2 and loaded it with Tomato 1.25
    I am not sure why but rstats keeps crashing.
    I try to deactivate it save then reactivate it so it restarts the service... This works for a while (usually a coule of hours) then it is down again.
    I tried starting from scratch resetting the file but it doesn't change anything.
    I tried saving to NVRAM or to an external FTP server via the following method: http://digiex.net/networking/776-how-backup-tomato-firmwares-bandwidth-logs-rstats-ftp-server.html to no avail.
    Any thoughts?
  2. TexasFlood

    TexasFlood Network Guru Member

    Maybe you did this already but wasn't clear from reading your message.

    After initially loading the firmware did you
    Administration -> Configuration -> Restore Default Configuration -> Erase all data in NVRAM memory (thorough)
  3. lanmtl

    lanmtl Addicted to LI Member

    no i didnt do this.
    should I backup before proceeding? This will wipe all my config and QoS config as well, right?
  4. TexasFlood

    TexasFlood Network Guru Member

    According to the official Tomato FAQ (click here to see), "if you upgraded from another firmware, a complete reset is recommended."
  5. lanmtl

    lanmtl Addicted to LI Member

    Fair enough.
    I did it then restored from a backup I did because I spent quite a few hours (ie 15) tweaking up the QoS to get it working perfectly.
    Does restoring from a backup negates the goodness of wiping the NVRAM?
    rstats seems to work now but when I start adding the script for uploading to an FTP server then it all crashes again :(
  6. TexasFlood

    TexasFlood Network Guru Member

    Unfortunately I think a restore puts you back where you were before the reset.

    I certainly understand not wanting to lose all of your configuration efforts. What I do is capture all configuration pages using firefox scrapbook before resetting so I don't lose anything. Some of the pages, like static dhcp and dhcp/dns, maybe anything with boxes to fill in, not sure, require you check the javascript box to capture those settings. You still have to put everything back in from scratch, but can cut and paste to make it easier and limit human error.

    This is, of course, not the only way to capture config data, just the one that I use.
    Perhaps if the symptoms don't occur until you put the script in then somehow it is related to the script? I would still think the reset is recommended but perhaps not the root of the current issue, hard to say. Since leftover nvram junk can cause weird issues, seems wise to rule it out first before spending a lot of time on diagnosing issues but it does take some time to do a full reset and re-enter settings. If you do find the time to do so, make sure you take a backup when you're done to be safe.
  7. lanmtl

    lanmtl Addicted to LI Member

    Ok I will try when everybody is offline.
    What puzzles me is that this script works fine for others but not for me.
  8. Toastman

    Toastman Super Moderator Staff Member Member

    I had rstats 24 hour graph failing to work properly, in my case I tracked it to too many port entries on one line of a QOS rule. Sometimes the web GUI became unavailable. Something not documented, perhaps overwriting some memory somewhere, whatever. Might be something like this in your setup? It may be your script is too big. If it's still there after NVRAM erase and rebuild, take a look.

Share This Page