1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RT-N16 and Ubuntu 11.04 speed issue

Discussion in 'Tomato Firmware' started by agentsmith23, May 7, 2011.

  1. agentsmith23

    agentsmith23 Networkin' Nut Member

    I really don't think this has anything to do with my RT-N16 or Tomato but I just want to see what kind of advice I may get here. I already posted this same question in an Ubuntu forum but haven't gotten a reply as of yet.

    I have something very odd happening in Ubuntu. I just installed Ubuntu 11.04 and upgraded my internet speed from 7Mbps to 15Mbps a few days after installing 11.04. The issue is the speed I get in Ubuntu previously in 10.10 I got excellent speeds when downloading or running a speed test and everything seemed to be fine in 11.04 under the 7Mb connection also (never ran a speed test for the 7Mb connection under 11.04). With the 15Mb connection I am only downloading around 110KBps and speed tests reflect around 1.2-1.5Mbps and that is when connected wired or wireless through my Asus RT-N16 router running Tomato. If I eliminate the router I get full speed when connected directly to the modem. Normally that would make me think there is an issue with my router however when booting into Windows 7 on the same laptop I get excellent speeds when connected wired or wirelessly to the RT-N16. I have tried factory resetting the router and clearing nvram and running a speed test with just the stock router configuration and get the same results. I troubleshoot internet service for a living for a large ISP but have never seen anything like this, what could cause it?


    Just ran a speed test on my desktop running 11.04 and got great speeds on it. It is connected a little differently though. It is hardwired into a Linksys E2000 running DD-WRT operating as a repeater bridge of the RT-N16.
     

Share This Page