1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RT-N16 issue, suspect HW

Discussion in 'Tomato Firmware' started by jed_99, Jul 11, 2014.

  1. jed_99

    jed_99 Addicted to LI Member

    I have an RT-N16 that worked great for a year, then DHCP quit working on my WAN. I reflashed to stock, Victek, Shibby and Easy Tomato, all work the same, the port shows activity (where applicable) but cannot get an IP. If I use the stock and dual WAN, I can get an IP by using one of the LAN ports.

    Anything else I can try before I turn this into a WET?
  2. mstombs

    mstombs Network Guru Member

    Last edited: Jul 12, 2014
    PBandJ likes this.
  3. jed_99

    jed_99 Addicted to LI Member

    I think this one was because of a bad POE power adapter, that makes sense then.

    Thanks for the input, appreciate it.
  4. PBandJ

    PBandJ Networkin' Nut Member

    My Asus RT-N16 failed in a similar fashion. When powering it up: the leds blinks for a second and died.
    Findind this thead inspired me to look take a look inside and, indeed, it was the same bad cap as in the thread posted by mstombs (thank you!).

    I bought a capacitor with similar specs, de-soldered the bad cap but couldn't mount the new one at the same location. Either I couldn't clean up the through holes well enough or that the holes were too small (they are very small). Instead, found equivalent points on the board and soldered them there instead.
    Not the cleanest/prettiest things ever but it works just fine.
  5. Monk E. Boy

    Monk E. Boy Network Guru Member

    Yeah, cleaning up residual solder is annoying, especially with small holes. It doesn't take much solder to effectively block the hole so I use a combination of solder wicks and solder suckers and blow way too much time clearing out the old solder. I don't remember it being this difficult in ye olden days, I guess the lead-free solder is harder (for me, at least) to remove.
    koitsu likes this.
  6. JugsteR

    JugsteR Serious Server Member

    I changed a bulging cap on mine too. Soldered cables to the back side and a new cap to the cables. Worked for a couple of days without stressing it too much. It was just on basically.

    Tried downloading a few GBs of data over a 100Mbit wire and after an hour it shut off and has been unresponsive ever since.

    A tenda W1800R is now on its way. I hope it was a good choice, tomato wise.
  7. jed_99

    jed_99 Addicted to LI Member

    The Tenda works great, but I'm on my third one. The first two(setup as a router and a wireless bridge) died within two weeks of each other. I replaced one with a third Tenda and but now am also trying out a DIR-868L that I got on sale during Christmas. Tenda would do jack about RMA too. Hopefully this plays out ok as the W1800R are a huge value. If they stay working.
  8. Toastman

    Toastman Super Moderator Staff Member Member

    Anyone reading this who doesn't have much experience with soldering these pcb's ...

    The tracks on these pcb's dissipate heat very well, and you need a powerful soldering iron to melt the solder enough to extract capacitors and clean out the holes. Most people don't have soldering tools hot enough, such tools are expensive. The chinese crap sold in most hardware stores are completely useless. Don't persist in trying unless you have decent tools .. or you may damage the PCB and ruin the router.

    Easiest way is to just grab the capacitor in some pliers and pull it hard. The leads will pull out of the capacitor. Now you can cut the leads a little shorter and then just solder the new capacitor to them. Lay the capacitor down against the PCB instead of standing up vertically. Yes, it doesn't look so nice, but ... you have a working router again.
    Monk E. Boy and mstombs like this.
  9. remlei

    remlei Networkin' Nut Member

    well, as long as you had the right tools you can do it properly, when replacing parts, of course you need a soldering iron, solder sucker or maybe a solder wick.
  10. Monk E. Boy

    Monk E. Boy Network Guru Member

    Not just any soldering iron. The solder used on the unit I worked on wouldn't melt unless you got it VERY hot. I had three soldering irons available, one an older professional unit, another a newer professional unit, and a third of that had a vacuum-based solder sucker attached. Only the older professional unit got it hot enough to melt. The newer unit was actually made by the same company and simply didn't get as hot as the older unit.

    Now, before I attempted this I cut the capacitor off the board so I could extract leads individually. Made a nasty hissing sound when the cap got squeezed but it didn't leak anything so I considered myself good (/lucky). I don't know how you'd get them out with the cap intact, the solder solidifies as soon as heat is removed.

    If I had to do it over again I would certainly take Toastman's advice and just stop after cutting the leads and go from there. Makes me feel kinda dumb about sourcing a capacitor that's identical in every way except it's maybe 1mm taller than the original. At least it looks pretty on the one I brought back to life. So I got that going for me, which is nice.
  11. mstombs

    mstombs Network Guru Member

    Using fresh multicore flux lead solder helps to wet/melt old lead-free solder that its probably covered with a fine lacquer, professional tools have temperature setpoint controlled tips. Definitely follow Toastmans advice, one leg of the capacitor is probably in a ground plane that is a great heat sink!

Share This Page