1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RT-N66U / RT-AC66U and WET/WDS under Tomato Shibby

Discussion in 'Tomato Firmware' started by jnitis, Nov 1, 2013.

  1. jnitis

    jnitis Reformed Router Member

    Hiya folks,

    Long time user and financial supporter of Tomato here. I have two separate issues, the first being that WET (Wireless Ethernet Bridge) mode craps out on me after a few days of usage and my second issue is WDS won't work at all.

    Issue 1

    Router A: RT-AC66U
    Tomato Firmware 1.28.0000 MIPSR2-114 K26AC USB AIO-64K
    All settings default (aside from standard WAN/DHCP config) except:
    5Ghz radio: AP, N-only, Chan 36, 40MHz, Lower, WPA2/AES security

    Router B: RT-N66U
    Tomato Firmware 1.28.0000 MIPSR2-114 K26AC USB AIO-64K
    All settings default (aside from static IP and default gateway/DNS) except:
    5GHz radio: Wireless Ethernet Bridge, Auto, WPA2/AES security
    Bridge WAN port to primary LAN (so I get one extra Ethernet port if I need it)
    Advanced->Routing Mode is set to: Router

    So everything connects up and works fine for a few days but then Router B loses its connection with Router A. Router A is still fine because anything connected to it can still reach the Internet. After rebooting Router B everything is OK again...for a few days and the process repeats. I chose the "AC" version of the firmware for Router B (not AC capable) based on comments from Shibby saying that it includes the latest driver from ASUS and it should work fine on the N66U, and I also thought it would make the most sense to have as close to exactly the same firmware on both routers. Anyone have any idea what's going on here? Seems something gets corrupted after a few days in this mode, but I'm not sure what.

    Issue 2

    Everything is setup the same as above however I set both routers to use WDS and input the respective MAC addresses. I tried in N only and in Auto mode. I tried with the same security as above (WPA2/AES) and with no security. In both cases no packets are ever forwarded between the routers. Upon inspection of the router logs (on both ends) I see they immediately connect in WDS mode according to this (example from Router B):

    Jan 1 01:41:36 unknown user.info kernel: device wds1.1 entered promiscuous mode
    Jan 1 01:41:36 unknown user.info kernel: br0: port 3(wds1.1) entering learning state
    Jan 1 01:41:36 unknown user.info kernel: br0: topology change detected, propagating
    Jan 1 01:41:36 unknown user.info kernel: br0: port 3(wds1.1) entering forwarding state

    But no packets ever get through. Anyone have any idea on this one, too? The reason I'm trying this in the first place is A) due to the issue above with WET, and B) because WDS is standardized and as I understand it the bridging is more thorough and less prone to issues due to space being added in the network frame for the source MAC address. Interesting note: WDS worked fine with the above same setup except Router B was a WRT54GL running the appropriate Shibby 114 K26 firmware.

    Final question: what debug tools are suggested when packets aren't being forwarded such as in the broken state from Issue 1 and in Issue 2? I'm extremely familiar with Linux and networking in general but I'm not sure how to peek into what the WiFi driver is doing other than using tcpdump, iptables, and etc. The WiFi command wlan help spits back an enormous number of command line options so I'd appreciate some direction here.

    Thank you.
    Last edited: Nov 1, 2013
  2. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Have you tried simultaneous "Save" on both routers' Basic settings page? Or simultaneous checking the noise floor? (essentially simultaneously turning on the radios). Timing is sometimes the issue.

    As you know, WDS is very finicky and is most likely to fail when the hardware is not all the same. It was reasonable to try the same firmware, but you may be better off with Shibby's RT-N for the N66U.
  3. jnitis

    jnitis Reformed Router Member

    Any infrastructure configured in such a way where I'd have to save the settings at precisely the same time would just be indicative of a severely suboptimal and unreliable setup. :)

    I will go ahead and give the ole N firmware a try on the N66U. Cheers.
  4. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    No kidding. That's why many in the forum advocate wired > powerline > WET > WDS

    Some WDS setups will connect automatically, but often there's a timing issue.

    There are other reasons to go with the RT-N driver on the N66U that have come up in Shibby's thread, so you may be better off anyway.
  5. jnitis

    jnitis Reformed Router Member

    I actually went down precisely that path. Everyone was tired of the 10m wire running across the house so I went with powerline. Powerline was fine but it only got me 38Mbps max which is OK for Internet but not for my HTPC and it presented other problems for my home network. It also has increased latency compared to Wifi N in my experience. WET seems to be the most optimal thus far and solves most of my problems aside from it crashing every few days.

    As for the RT-N version on my N66U I've loaded it up and been running with it for a few hours and thus far it seems to have more packet loss and lower reported radio speeds on the Overview page in general. I'm fiddling with the advanced settings to see if I can tweak it but if it keeps up I'm going to have to go back to the AC firmware and reboot the router daily.
  6. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    WiFi speeds seem to be better with the ac branch, it's true. Good luck!
  7. jnitis

    jnitis Reformed Router Member

    Marcel, any ideas as to what I can do to debug the situation where the AC firmware locks up? I mean once I get it in that state I can still get into the router, it's just the the WET radio (5Ghz) that's dead. I'd like to be able to help the community by debugging this. Should I post in another thread? Which commands/tools to run at that time? Thanks.
  8. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    It's over my head, unfortunately. The main thread on Shibby's branch would be best (RAF with bittorrent client)

Share This Page