1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RV016 Does not pass traffic even with Firewall disabled

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by vreid4736201, Sep 23, 2006.

  1. vreid4736201

    vreid4736201 LI Guru Member

    I have an RV016 configured to allow traffic from the wan side to connect to nodes on the lan side without firewalling. This router is set up internally between two subnets. My goal is to allow some traffic from wan to lan but not all traffic. During testing, I have tried to selectively open ports, through the firewall tab's access rule page, but nothing seems to work. I have even tried the following configuration without success. Here are the details.

    RV016
    Firmware version 2.0.10
    Firewall disabled, https enabled, Multicast passthru enabled.
    Wan IP 192.168.10.x Lan IP 192.168.12.x

    With this config, I can ping all devices on the 192.168.12.x subnet, but I can't connect to any of them, other than the lan address of the RV016 itself, for any other service unless I either set up 1-to-1 NAT or set up port forwarding. Neither of these options is very appealing. (Heck, neither is the fact that I can't turn off NAT on this device, but that's been documented already on this forum).

    My goal is to enable access to remote desktop and vnc and http and https on all of the nodes on the 192.168.12.x subnet from the 192.168.10.x subnet.

    Anyone have suggestions?
     
  2. pablito

    pablito Network Guru Member

    Do you have the Setup/Routing option for "Router" instead of the default "Gateway" (NAT)? That should turn off NAT and allow proper routing (I have an RV8). Also, if you want to be selective about what passes you'll need firewalling turned on and rules in place.
    Hint, place a deny rule at the bottom so that the RV's allow rules that you can't turn off are bypassed.
     
  3. vreid4736201

    vreid4736201 LI Guru Member

    If I change the RV016 to to router mode, it routes properly, but the RV016 at the gateway stops Natting the second subnet. This is a bug/"feature" of the RV routers that keeps them from performing NAT on anything but the local subnet. So, it appears so far that if I want real routing without NAT on the second subnet that I'll lose internet access on that subnet. I may need to get a different brand for the gateway to the Internet router.
     
  4. pablito

    pablito Network Guru Member

    Check the latest beta for multi subnet support. On the RV08 it works like a charm. I'd rather use a stable version in production but this beta is miles ahead of the official version and has been stable for over a month so far.

    You have to use router mode on the inside router to do what you want. It is the only that makes sense.
     
  5. vreid4736201

    vreid4736201 LI Guru Member

    I know that I've raised this exact issue with Linksys at least 3 times, and each time it gets raised to about 3rd or 4th level tech support. Each time, I get a response that, basically, says "we don't support this feature yet. It may be available in the future, but we can't tell you when/how/or if because it may be some sort of massive corporate secret." These are also the same 3rd and 4th level tech support staff that told me that "router mode" disables all routing on the RV series and makes it into a big dumb switch, which is obviously incorrect because routing works fine on the device set in "router" mode. NAT just doesn't work correctly on the RV still set in gateway mode.

    Thanks for the info about the beta firmware, I'll test it out.
     
  6. vreid4736201

    vreid4736201 LI Guru Member

    It's interesting also that there is an official beta firmware that supports this feature (I haven't tried it yet) because I just asked Linksys Tech Support if they specifically had a beta that would help with this issue just 2 to 3 weeks ago, and the response was no. There were no betas currently available for any of the RV series routers.
     
  7. pablito

    pablito Network Guru Member

    We've been testing some betas for a while now but they wouldn't be called official. Check "downloads..". We're not Linksys, we're just goofs with ideas. :)
    The beta that you want only came out today/yesterday.

    By now perhaps you've done the scary deed of pushing it to the router?
    Copy the config and be prepared to factory reset. Mine went well but I did a factory reset anyway.

    {stop banging your head with support when dealing with these kinds of issues.}
     
  8. vreid4736201

    vreid4736201 LI Guru Member

    I'll probably test this on the network tomorrow. I've played around with it tonight on an auxilliary setup that I have. I totally agree with your summary of Linksys tech support, and I might add -- their abysmal documentation.
     
  9. pablito

    pablito Network Guru Member

    I can't say anything bad about tech support. Partly because I've never called them :) Their margin isn't enough to give everything that some people expect they should. I just accept that from almost any company. That's slightly different than an ISP that makes a healthy margin on their product. But I don't expect them to have decent support either.
    On the rare occasion that I've needed to call an ISP I knew exactly what I wanted and didn't have any questions for them. :)
     
  10. vreid4736201

    vreid4736201 LI Guru Member

    True enough. I'd like to be able to purchase tech support contracts from linksys for better and more responsive support.
     
  11. Toxic

    Toxic Administrator Staff Member

    the beta that was released yesterday was "Alpha" until yesterday. tesch support knows nothing on Alpha firmwares. they may not even know of the beta until monday/tuesday.
     
  12. vreid4736201

    vreid4736201 LI Guru Member

    Thanks for the clarification. I'm going to be testing it today on a multi-subnet setup. I'll report my findings back as soon as I have data.
     
  13. vreid4736201

    vreid4736201 LI Guru Member

    Ok, here are my findings so far with the 2.0.13 beta for the RV016 and 1.3.3.5 on the RV082.

    I have a setup with a customer that has an RV016 at the Internet Gateway, with an RV082 separating 2 192.168..x.x subnets, and with another RV016 separating this customer from a business partner. Installing the 2 firmwares mentioned above and configuring the RV082 into router mode allowed the nodes on the second subnet to be Natted on the Internet gateway RV016, and it allowed nodes on the first subnet to be Natted by the RV016 sitting between the customer and its business partner.

    So far, the new RV016 firmware also seems to be noticably faster than the 2.0.10 firmware.
     

Share This Page