1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RV042 PPPoE connection DNS problems.

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Sfor, Jun 29, 2011.

  1. Sfor

    Sfor Network Guru Member

    WAN1 is not connected (disabled). Everything is working fine while WAN2 is using DHCP. But, after connecting WAN2 with PPPoE, I'm experiencing problems with page browsing. Some portals are working correctly (Google included), but most portals are not loading, at all. I'm suspecting the effect is DNS related. Router does have the newest firmware loaded.
  2. elzix

    elzix Network Guru Member

    Have you assigned DNS statically? If not try using a public one, eg
  3. Sfor

    Sfor Network Guru Member

    I did set the DHCP server to assign public DNS servers. But, the result was still the same, as with ISP DNS servers.
  4. elzix

    elzix Network Guru Member

    Whats the output of nslookup from PC/RV for domains which are not responding?
    What if you assign static ip on a pc, with DNS set to gateways/routers IP?
  5. Sfor

    Sfor Network Guru Member

    I can not check the nslookup, since I could not leave the RV042 working in such a way. WRV200 works correctly with DNS, but it has a tendency to hang.

    I did test the DNS server as gateway IP. But, I did it through the DHCP, not the static IP. The result was the same. With WRV200 on PPPoE DNS works right, while with RV042 does not.

    The same RV042 in a different location with the same setting except for the WAN set to DHCP, works fine as well.
  6. elzix

    elzix Network Guru Member

    I'm sorry but i cannot understand your troubleshooting process.
    So you have
    modem<->RV042<->PC right?

    What are the setting on above devices?
  7. Sfor

    Sfor Network Guru Member

    (ISP ADSL)<==>[ADSL(ST456 in bridge mode)LAN]<==>[WAN2(RV042)LAN]<==>[DHCP(PC)]
    Modem Thomson SpeedTouch ST546 is in bridge mode. RV042 does all the PPPoE related authentication. Workstations are getting all IP related settings through DHCP. I have tested multiple scenarios with ISP DNS servers and other DNS servers passed to workstations through DHCP. However, it did not work as expected. Just replacing the RV042 to WRV200 solved the problem, while workstations were using the same settings obtained through DHCP.

    I'm planning to test other setup in the close future. In this scenario the modem will do the PPPoE related ISP connetion in NAT router mode. I hope the G2G IPSec tunnel will work through modem NAT with ports 500 and 4500 forwarded to the RV042 WAN2. The workstations will remain just as they were. In theory it should work, as ST546 does support IPSec passthrough.
  8. Toxic

    Toxic Administrator Staff Member

    i'll ask a friend at cisco to see if there are known issues with the rv042 and new firmware.
  9. Sfor

    Sfor Network Guru Member

    Well. I did as I said. The St 546 is working as a NAT router and RV042 is placed behind ST 546 with static IP WAN settings. Everything seem to be working fine, so far. The only changes in the RV042 setup are:
    - WAN settings changed to static IP
    - DDNS disabled (ST 546 does the DDNS, now)
    - G2G IPSec VPN Nat Traversal enabled.

    I did not confirm it yet, but it seems sometimes the VPN tunnel is reported as disconnected, while working correctly. The RV042 behind NAT does report the tunnel status correctly, but RV042 or RV082 on the other end of the tunnel are reporting the tunnel as not connected.
  10. Sfor

    Sfor Network Guru Member

    I did encounter another problem with another v1 RV042 working with the same firmware. This time in dual WAN mode I was unable to get WAN2 to work correctly with both DHCP and static IP. The WEB interface was getting unresponsive when working with WAN2 connected. I had to unplug WAN2 and reboot the router through power cycle. This time The issue was solved by degrading the firmware to It seems, there are some issues with WAN2 in the newest firmware

Share This Page