1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RV042 - RV082 Gateway to Gatway VPN

Discussion in 'Networking Issues' started by coxylaad, Jun 28, 2007.

  1. coxylaad

    coxylaad LI Guru Member

    Hi,
    I am looking for a bit help on setting up my site to site vpn. I have done as much as I can think of and am still coming back with errors.

    This is my current setup:

    [main site] [remote site]
    RV082--->AG241(modem router) ---> Internet <--- AG241(modem router) <--- RV042

    both sites have static public IP addresses.

    I have setup the modems with DHCP disabled and the DMZ pointing to the internal WAN interface IP of their respective routers behind them.

    the rv082 has a wan interface IP of 192.168.0.100
    and a local lan IP of 192.168.1.1 running DHCP server

    the rv042 has a wan interface IP of 192.168.0.101
    and a local lan IP of 192.168.5.1 running DHCP server

    I have set a gateway to gateway vpn connection up, using all these values, but I keep getting the error message " No suitable connection for peer '192.168.0.100', Please check Phase 1 ID value"

    I have tried allsorts to get it to work but it just cant seem to be able to see the opposite WAN interface IP. I have tried initiating the connection from the remote side and it comes back with the same error only it cant find other wan interface IP.
    Here's my VPN log from the RV042 after a connection attempt from the rv082:
    Jun 28 02:23:03 2007 VPN Log [Tunnel Negotiation Info] <<< Responder Received Main Mode 1st packet
    Jun 28 02:23:03 2007 VPN Log [Tunnel Negotiation Info] >>> Responder Send Main Mode 2nd packet
    Jun 28 02:23:03 2007 VPN Log [Tunnel Negotiation Info] <<< Responder Received Main Mode 3rd packet
    Jun 28 02:23:04 2007 VPN Log [Tunnel Negotiation Info] >>> Responder send Main Mode 4th packet
    Jun 28 02:23:04 2007 VPN Log [Tunnel Negotiation Info] <<< Responder Received Main Mode 5th packet
    Jun 28 02:23:04 2007 VPN Log Main mode peer ID is ID_IPV4_ADDR: '192.168.0.100'
    Jun 28 02:23:04 2007 VPN Log No suitable connection for peer '192.168.0.100', Please check Phase 1 ID value
    Jun 28 02:23:14 2007 VPN Log [Tunnel Negotiation Info] <<< Responder Received Main Mode 5th packet
    Jun 28 02:23:14 2007 VPN Log Main mode peer ID is ID_IPV4_ADDR: '192.168.0.100'
    Jun 28 02:23:14 2007 VPN Log No suitable connection for peer '192.168.0.100', Please check Phase 1 ID value


    any help would be greatly appreciated - I am pulling my hair out!

    thanks

    Ian
     
  2. Toxic

    Toxic Administrator Staff Member

    I think you WAN IPs need to have Public IP addresses. put the DSL modems in bridge mode and then allow the WANs of the RV units to have the Public IP addresses. the VPN tunnels will then know where to look for the other tunnel. or you need to port forward IPSec ports from the DSL modem to the RV0xx.
     
  3. coxylaad

    coxylaad LI Guru Member

    ah right!

    I have bridged one end, nipping out to do the other, but it appears on the surface that its going to work - the WAN interface IP on the RV082 is now showing the public wan IP

    Cheers Tox
     

Share This Page