1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RV042, RV082 to Cisco IOS

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by justindd, Mar 4, 2005.

  1. justindd

    justindd Network Guru Member

    Anyone figured out an appropriate config for a Cisco 2600 to be used to connect to a RV042/82 or the other way around?
     
  2. rjb02

    rjb02 Network Guru Member

    Hi Justindd,
    I presume you are talking about connecting an RV082/42 to a 2600 via VPN? If so, please find below a sample IOS config that I have tested successfully between an RV082 and a 7200 with IOS Firewall. The relevant commands are in bold, and are the same for a 2600 (presuming it is running the firewall feature set):

    Building configuration...

    Current configuration : 2117 bytes
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname p32-7200-5
    !
    boot-start-marker
    boot system flash disk2:c7200-ik9s-mz.123-8.T3.bin
    boot-end-marker
    !
    logging snmp-authfail
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    controller ISA 2/1
    !
    !
    crypto isakmp policy 15
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 28800
    crypto isakmp key 6 linksys address 172.16.3.2
    crypto isakmp key 6 linksys address 10.1.1.1
    crypto isakmp key 6 linksys address 10.1.1.2
    !
    !
    crypto ipsec transform-set my-set esp-3des esp-md5-hmac
    !
    crypto map linksys 15 ipsec-isakmp
    set peer 172.16.3.2
    set transform-set my-set
    set pfs group2
    match address 101

    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    ip address 10.66.167.76 255.255.254.0
    duplex auto
    !
    interface GigabitEthernet0/3
    no ip address
    shutdown
    duplex auto
    speed auto
    media-type rj45
    no negotiation auto
    !
    interface FastEthernet1/0
    ip address 172.16.3.1 255.255.255.0
    load-interval 30
    duplex auto
    speed auto
    crypto map linksys
    !
    interface FastEthernet1/1
    ip address 172.16.2.2 255.255.255.0
    load-interval 30
    duplex auto
    speed auto
    !
    ip classless
    ip route 10.1.1.0 255.255.255.0 172.16.2.1
    ip route 192.168.1.0 255.255.255.0 172.16.3.2
    no ip http server
    no ip http secure-server
    !
    !
    !
    access-list 101 permit ip 10.66.166.0 0.0.1.255 192.168.1.0 0.0.0.255
    !
    line con 0
    transport preferred all
    transport output all
    stopbits 1
    line aux 0
    transport preferred all
    transport output all
    stopbits 1
    line vty 0 4
    login
    transport preferred all
    transport input all
    transport output all
    !
    !
    end

    I have also attached the setup of the RV082 as well. Hope this is of help,

    Cheers,

    Rhod
     
  3. rjb02

    rjb02 Network Guru Member

    I seem to be having a few problems uploading attachments, here are the RV082 settings the manual way :)

    Tunnel No: 1
    Tunnel Name:test
    Interface:WAN1
    Enable: tick

    Local Security Gateway Type: IP Only
    IP Address:172.16.3.2
    Local Security Group Type: Subnet
    IP Address: 192.168.3.0
    Subnet Mask: 255.255.255.0

    Remote Security Gateway Type: IP Only
    IP Address:172.16.3.2
    Local Security Group Type: Subnet
    IP Address: 10.20.3.0
    Subnet Mask: 255.255.255.0

    Keying Mode: IKE with Preshared Key
    Phase 1 DH Group: Group 2
    Phase 1 Encryption: 3DES
    Phase 1 Authentication: MD5
    Phase 1 SA Lifetime: 28800

    Perfect Forward Secrecy: tick
    Phase 2 DH Group: Group 2
    Phase 2 Encryption: 3DES
    Phase 2 Authentication: MD5
    Phase 2 SA Lifetime: 28800
    Preshared Key: Linksys

    Aggressive Mode: Tick
    Keep Alive: Tick

    This was done on a test network, hence the valid use of private IP addresses.

    Cheers,

    Rhod
     
  4. justindd

    justindd Network Guru Member

Share This Page