1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RV082 Log errors

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Outerspace, Apr 27, 2005.

  1. Outerspace

    Outerspace Guest

    I am trying to figure our why I get the following errors in my log evertimes I save changes to my config. The following entries follow a reboot. I have some port forwarding enabled. Firewall rules are enabled. I have removed all VPN settings.

    Thanks.

    Apr 27 18:00:51 2005
    System Log
    --- System is up! ---
    Apr 27 18:00:52 2005
    Failed nat control
    SIOCADNAT - Illegal seek
    Apr 27 18:00:52 2005
    Error in RNAT configuration
    Local Servers
    Apr 27 18:00:52 2005
    RNAT configuration failed

    Apr 27 18:00:52 2005
    NAT configuration failed

    Apr 27 18:00:52 2005
    Failed nat control
    SIOCADNAT - Illegal seek
    Apr 27 18:00:52 2005
    Error in RNAT configuration
    Local Servers
    Apr 27 18:00:52 2005
    RNAT configuration failed

    Apr 27 18:00:52 2005
    NAT configuration failed

    Apr 27 18:00:52 2005
    Connection Accepted
    UDP 0.0.0.0:68->255.255.255.255:67 on ixp1
    Apr 27 18:00:54 2005
    System Log
    192.168.22.100 login
    Apr 27 18:00:58 2005
    Connection Accepted
    UDP 0.0.0.0:68->255.255.255.255:67 on ixp1
    Apr 27 18:00:58 2005
    Connection Accepted
    UDP 69.xxx.xxx.xxx:67->255.255.255.255:68 on ixp1
    Apr 27 18:00:58 2005
    Connection Accepted
    UDP 0.0.0.0:68->255.255.255.255:67 on ixp1
    Apr 27 18:00:59 2005
    Connection Accepted
    UDP 69.xxx.xxx.xxx:67->255.255.255.255:68 on ixp1
    Apr 27 18:00:59 2005
    Failed nat control
    SIOCADNAT - Illegal seek
    Apr 27 18:00:59 2005
    Error in RNAT configuration
    Local Servers
    Apr 27 18:00:59 2005
    RNAT configuration failed

    Apr 27 18:00:59 2005
    NAT configuration failed

    Apr 27 18:00:59 2005
    Connection Accepted
    IGMP on ixp1
    Apr 27 18:00:59 2005
    Connection Accepted
    IGMP on ixp1
    Apr 27 18:00:59 2005
    Failed nat control
    SIOCADNAT - Success
    Apr 27 18:00:59 2005
    Error in RNAT configuration
    Local Servers
    Apr 27 18:00:59 2005
    RNAT configuration failed

    Apr 27 18:00:59 2005
    NAT configuration failed
     
  2. DocLarge

    DocLarge Super Moderator Staff Member Member

    At first glance, it looks like NAT is having problems resolving. What version firmware do you have running?

    *************EDIT**************

    I "just" saw someone post a portion of their logging file similar to this on the "broadband reports" forum. If you're not the same person, what I'd suggested to the other guy was trying another logging application to see if the same errors get reported.

    The difference was this guy said his VPN was working "but" he was still getting errors similar to the above which lead me to believe the information from his log files may be "soft errors" such as the ones you see in W2K event viewer log files or something (possibly) off with his current logging application.

    I'll never claim to be "the" expert; I'm merely suggesting this as a starting point so the "fixuns" can commence (as Jed Clampett would say) :) :)

    Doc
     
  3. netwise

    netwise Guest

    Did anyone ever figure this out? I have the same issue on every version of the firmware I've ever had, including v1.1.6.3 on two different RV082s
     
  4. danks

    danks Guest

    Similar RV016 Log errors

    I get some similar errors, but not just after rebooting. These message are repeated over and over, filling up my log at least 3 times a day:

    ipnat_add_rule:683: RGFW-CONF: Failed nat control (SIOCADNAT - Success)
    ipnat_add_rule:683: RGFW-CONF: Failed nat control (SIOCADNAT - Success)
    ipnat_add_rule:683: RGFW-CONF: Failed nat control (SIOCADNAT - Success)
    ipnat_add_rule:683: RGFW-CONF: Failed nat control (SIOCADNAT - Success)
    ipnat_add_rule:683: RGFW-CONF: Failed nat control (SIOCADNAT - Success)
    ipnat_add_rule:683: RGFW-CONF: Failed nat control (SIOCADNAT - Success)

    Can anyone point me to the cause? Is my router being attacked from an external source?

    Thanks in advance!
     
  5. and247

    and247 Network Guru Member

    UDP port forwarding is the problem

    Hi,

    I also have these errors in my RV082 log (firmware is 1.1.6.11):

    ipnat_add_rule:692: RGFW-CONF: Failed nat control (SIOCADNAT - Success)
    rnat_config:134: RGFW-CONF: Error in RNAT configuration (Local Servers)
    rnat_config:211: RGFW-CONF: RNAT configuration failed
    rgpf_nat_config:737: RGFW-CONF: NAT configuration failed


    These errors appear after restart or after configuration save, but only if some UDP port forwarding is enabled. If you disable all UDP port forwarding and keep only TCP port forwarding, these error messages no more appear.

    I have no idea why this is happening, especially because all port forwarding (also UDP) works fine. Anyone any ideas? Can these error messages be safely ignored? :?

    Thanks...
     

Share This Page