1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RV082 slow throughput with latest Firmware (Firmware Gathering)

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Maku, Feb 6, 2010.

  1. Maku

    Maku Addicted to LI Member

    Hey guys,

    I used a RV042 for some years now with my 32Mbit Internet connection, and it worked quite well.

    Now that i need to handle more VPN-TUnnels i bought a RV082 manufactured early-mid of 2009 with the latest Firmware on it (

    The RV042 gave me the Full Speed of my Internet (3,8MB/sec) but with the RV082 i only reach a maximum of 7Mbit and i dont know what is wrong.

    i tried both and Firmware and no difference.
    MTU is on manual 1500.

    i cannot think on what may be the clue.
    So i looked for older Firmware versions but i cannot find any anywhere.

    Could anyone who has any old Firmware upload it or send it to me? so i can make a little archive.

    And of course could anyone help me to solve my problem in the first place!
  2. Maku

    Maku Addicted to LI Member

    i was now able to specify the problem a little more exactly:

    no matter which firmware i use, the throughput does not exceed the 10mbit limit.
    the settings for bandwith control are proper set, mtu is 1500, everything else is set as with the rv042.

    now i have read here: http://www.jebriggs.com/blog/2009/11/load-balancing-and-routing-with-two-isp-connections/

    that it seems that the RV082 integrated switch unit has problems with cablelength exceeding 15 meters. the ethernetcable from my cable-modem to the RV082 does indeed exceed 15 meters.

    could this possibly be the cause for my problem?
    how does cable length affects throughput? and what cheap crap does it need to put in this product to make such lousy factor giving it the bullet?
    the rv042 didnt seem to bother the cable length
  3. swe_deathvalley

    swe_deathvalley LI Guru Member

    I think you should look at the port settings, make sure there not set to 10. I have not had problems with long cables, but you can test that by putting a switch between rv084 and your cable ethernet.

    I've had problems changing wan router where the cable modem would MAC lock for 30 minutes, could this be part of your troubles?
  4. Maku

    Maku Addicted to LI Member

    Port setting are on Auto Negotiate, but i even testet with manually setting to 100 Full Duplex. I tried also with setting to half-duplex to see if a line of the cable was damaged, but nothing changed.

    After i changed the RV042 to the RV082 i reseted the Cable Modem so that it renews the MAC-Binding. And i think that if it didnt renew the MAC-Binding, i would not have Internet Connectivity at all.

    I should try using a hub/repeater between the Modem and the RV082, a switch should not work because of the MAC-Binding. Thanks for the tip!

    Any other advices???


    finally i testet with a hub/repeater, and even put the RV082 directly beneath the cable modem....no difference.
    So i assume that its the RV082 itself. How do i find out which Hardware Revision it is? Maybe i got the old one.

    Now i have the RV042 again (btw manufactured 2006, compared to the RV082 manufactured 2009) in duty, and it works perfect as before.
    Full 32Mbit internet.

    Seems i have to wait for dd-wrt to use for the RV082 if its the firmware which is f***ed.
  5. swe_deathvalley

    swe_deathvalley LI Guru Member

    You could also try to do a factory reset of the rv082. Did you by any chance have throttle setup on it? If you set max/min on bandwidth management to lets say 10 then thats what you get.
  6. Maku

    Maku Addicted to LI Member

    Did factory reset before and after every firmware change. So thats not the point. And as i searched the forum for every RV082 Problem in any correlation i already did the bandwith management settings the right way.

    I friend of mine brought a cable-test-device (about 1200$ worth, so its quite exact :) ) and we checked the cables. The only thing that came out was that the cable from cable-modem to the RV082 was pinned as a Crossover-Cable. Could this do the trick?
    Doesnt the WAN-Port also have auto-mdix interfaces??

    Still bothering me that this RV082 doesnt work as fast as expected...
  7. Maku

    Maku Addicted to LI Member

    a little update for you guys....

    i bought another RV082 but with Hardware Revision V1.1. the old one with the problems i mentioned seems to be revision 1.0. And with the new one i got the full download speed of (now upgraded ;) ) 50Mbit!! Even with the old 1.3.2 Firmware without Selective ACKs.

    So a good advice: Hands off from devices with Hardware Revision 1.0 even if they are manufactured in 2008/2009 which mine was...the new one with 1.1 is manufactured 2006!!! Weird, but seems to do be the solution for my Bandwith problems!

Share This Page