1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rvl200 can no longer see computers by name?

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by andrew.ticknor, Jun 28, 2007.

  1. andrew.ticknor

    andrew.ticknor LI Guru Member

    Hello,
    our network is very simple, one server with 2003 and 10 client computers. mixed with xp home and pro. I know not the best but its what we can do until we slowly upgrade all of our pcs to pro.
    We used to have a WRT54G wiresless router and i took it out for an rvl200 so we could try and use the ssl vpn. we are set up as a star network with the printer and server having a static ip, everyone else is dhcp. this is because most are laptops and get taken home and out on the road.
    Well i upgraded my rvl200 to the latest firmware 1.1.5 and it is working just fine except that now when i try and use remote desktop i can no longer go to the computer with the name i have to type in the sctual ip address.
    Is there something i am missing, why would the computer name no longer work?
    everyone's computer have netbois enabled even the server, the server is set up and a file and print server. and i have not changed anything else. and for some reason my ups oftware does not work, it is like the router is not letting the workstation access the maped network drive, i have even tried re-mapping the driver with using the ip of the server instead of using the server name...
    anyone have a similar problem or know how to help me?

    Thanks,
    Andrew
     
  2. Toxic

    Toxic Administrator Staff Member

    has netbios over SSL VPN worked on any older firmware for your RVL200?
     
  3. andrew.ticknor

    andrew.ticknor LI Guru Member

    it did not work with the original version that came on it (1.0.12), but this is also the case internaly! if i am in the office behind this router i have to enter in the compter's ip to connect to it.
     
  4. Toxic

    Toxic Administrator Staff Member

  5. vpnuser

    vpnuser LI Guru Member

    If you have configured a WINS Server in the DHCP page of RVL200, it might work for you.
     
  6. vpnuser

    vpnuser LI Guru Member

    On the remote PC, under Network Connections, users also need to set WINS Server IP address for the VirtualPassage adapter.

    Step 1 Right click VirtualPassage button and select Properties
    Step 2 Select the Networking page and then Internet Protocol(TCP/IP)
    Step 3 Select Advanced button
    Step 4 Select the WINS page and enter WINS server IP address in the blank
    Step 5 Reconnect the sslvpn tunnel. Now you should be able to do things like Network Neighborhood over SSL VPN.
     
  7. andrew.ticknor

    andrew.ticknor LI Guru Member

    ok, i will try this when the user comes into the office this week.
    But what about us here in the office?
    the remote desktop only works by computer ip address.
    or when i add the wins service on my server will that take care of this problem too?

    the problem with the ups software not working is this:
    i can not tell ups where the database is by ip address, only by going U:\ups (mapped network drive) i have tried mapping it by ip adress and also computer name on each pc.
    and i think cause i can not remote desktop by name that is why that software is not working.
     
  8. DonJuancho

    DonJuancho LI Guru Member

    Andrew,

    To save yourself the time and effort, I suggest that you try the latest beta firmware, 1.1.6. Keep us posted.
     
  9. andrew.ticknor

    andrew.ticknor LI Guru Member

    I will try the latest firmware, I did gets lots of time to play with it yesturday.
    The problem is still there but i think i was looking in the wrong place so i will recap:
    1) can not remote desktop by computer name.
    2) ups software stops working.

    let me explain how the ups software is supposed to work, the database files are on the server with the worldship software on the individual computers, when the client tryins to run ups it gets stuck at %15 which is "connecting to database" which is the server!

    The ups software worked when i turned the firewall off, so this lead me to beleave that ports needed for ups were being blocked... funny on how the old router would allow it to work even with the firewall on....
    but i called ups and they said just makes sure ports 80 and 443 were open, which i made rules for it and it still did not work.

    I have started and am running the wins service on my server (server 2003)
    I have everyone's computer pointed to it in the tcp/ip settings, i also checked the box that read enable netbois over tcp/ip.

    I think i am going to try the new firmware, and if it does not work the only way i can see that this might work is either :
    a) throw this damn rvl200 router out and get a real vpn router
    b) put my old wrtg54 router back in and put the new one in the dmz zone with only the https port forwarding to it.

    thanks for the help
    ~Andrew
     
  10. weston

    weston LI Guru Member

    What a joke...

    So, have you had any luck with the new firmware? I am having the same issues a you in terms of not being able to have netbios resolution..

    I keep seeing interesting suggestions on these threads that have nothing to do with the issue. Someone was even suggesting you to setup a WINS server!? I wonder if the users offering these suggestions even know what WINS does and about the fact that it is not needed unless you have legacy clients such as NT4 in multiple subnets (since NETBIOS is not routable) and NetBios over TCP/IP serves the purpose of WINS

    I have slowly come to the conclusion that this VPN router is simply crap and deserves to be returned. Those of you who claim it is working, well, yes, you can leave it as it is and it "works" if you settle for less (edit host files, type IP addresses manually, etc). I happen to think that if you want to settle for less you might as well pick yourself up a $50 router and be done with it. At the price these RVL200s are at, it is unacceptable that these basic features are not supported. When one of your users is at a hotel's business center and attempts to access the VPN, are you going to walk him/her through editing LMHOST files?

    Give me a break Linksys! - do your customers a favor and either fix the issues with this model or remove this baby out of the business section of your site and put it in the home user section where it belongs instead.


    cheers.
     
  11. andrew.ticknor

    andrew.ticknor LI Guru Member

    well i am working on it right now and i would like to mention an important find!
    I put on the latest firmware and i still could not remote desktop by computer name. I would always change my internal network to 192.168.0.* from the default since thats how my old network was setup (old linksys). I did not want to change all of my printer ip's.
    So i decided what the hell and put the router back to 192.168.1.* and changed my entire network over to 192.168.1.* and now i can remote desktop by computer name again!
    So i think that might have to be looked at. still no ups though, but i think i might be close to fixing that.

    I did turn on the wins service on my server and pointed everything to that also. and i gave every computer a static ip and the laptops are still dhcp.

    the ssl vpn does work for me, except for in the begining when i changed the main ip address i forgot to change it in the vpn screen also, so you might want to look at that.
    ~Andrew
     
  12. Toxic

    Toxic Administrator Staff Member

    Give me a break weston! - go complain to Linksys.

    QUOTE from linksys. you could have contacted them yourself.

     
  13. weston

    weston LI Guru Member

    Toxic -

    First of all, I realize this is not a linksys sponsored forum (this is rather obvious I think). I was simply venting my frustrations towards linksys as I know they visit this forum every now and then.

    I have also tried the sugestions found on this forum so you are 'assuming' I do not wish to be helped.

    You need to ease up on your visitors a bit. Some of us may be a little more vocal about their frustration with certain linksys products, but you shouldn't get as emotional as you have with me (and others here from what I have seen), sending me off somewhere else.

    This is a forum and you should encourage open and honest communication as long as no-one is being disrespected or harrased.

    If you don't want people to speak their minds, you probably shouldn't be running/moderating a forum in the first place.

    At any rate, sorry if me being too vocal about this created any turmoil. I have actually managed to get it working with my setup and posted a guide here for anyone who might be interested:

    http://www.linksysinfo.org/forums/showthread.php?t=53760
     
  14. Toxic

    Toxic Administrator Staff Member

    The DNS entry has already been stated with the NetBios Issues with VPN Article, Thanks for the pictures though
     

Share This Page