1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RVS4000 v1.1.14 Beta Firmware Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Oct 18, 2007.

  1. Toxic

    Toxic Administrator Staff Member

    RVS4000 Firmware v1.1.14 Release Note 10/17/2007 (beta testing)

    ************************************************** *****************************
    * Please reset the router to factory default settings after firmware upgrade. *
    ************************************************** *****************************

    Issues Fixed:

    1. Fixed an IPSec VPN tunnel issue where a tunnel cannot establish when both ends use DDNS for WAN connection.
    2. Fixed a frewall issue with ports 23 and 5190.
    3. Fixed a SIP ALG issue that caused an one-way audio problem in a VoIP call.

    Known Issues:

    1. There is a known issue with Windows XP SP2 Firewall - ICMP packets are always dropped by the Firewall when the Firewall is enabled. The issue will cause the QuickVPN Client not being able to establish a tunnel with the remote QuickVPN Server successfully. Microsoft has released a patch to fix this issue. Once you install the patch, the issue should be resolved. http://support.microsoft.com/kb/889527/en-us

    Please contact Linksys Technical Support for this version of firmware.
  2. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Finally! Problem is when will Linksys rollout a public release if it is fixed. I can't justify installing beta on a production router.

    I am eager to hear impressions on this version from those of you willing to give it a go!! I only have one RVS4000 and I can’t afford a replacement right now if it dies.
  3. Toxic

    Toxic Administrator Staff Member

    you know that answer: when it is ready :)
  4. umerok

    umerok LI Guru Member

    I know its only been a few hours, but anyone have success with this version? 1.1.13 ain't cutting it, and the patch notes look promising. I'll install this when I get a chance.
  5. klazzik

    klazzik LI Guru Member

    So far so good. I have upgraded from 1.0.09 to 1.1.14. All the ports seems to be in stealth mode, apart from ports that I have opened myself.

    My connection speed seems to be a lot faster compared with when the router had firmware

    I am yet to test the VPN stuff.

    The only problem I have so far is that I still can't remotely manage the router.

    I am happy so far.

    PS: Please make sure that your restore your router to factory default after upgrading to this firmware. Do NOT backup and restore your settings as old configuration from previous version don't seem to be compatible with this release.

    I have a feeling Linksys will release this version as the final version unless something crops out.


  6. Toxic

    Toxic Administrator Staff Member

    Well first of all I have not seen enough users actually comment on the beta firmware, so far we have had 23 downloads, not really enough to speculate whether this should be the next official release or not.
  7. david803sc

    david803sc LI Guru Member

    Well so far so good, one problem, after updating I restored to factory defaults, everytime I set my correct time zone (EST) and set "auto daylight savings" I suddenly loose my WAN connection, After setting this I have to do a restore to factory settings, all other setting seem to work fine, I tried this about 6 times, and everytime the same thing happened so, now I am not messing with the time settings and all appears well.
  8. frostytech

    frostytech LI Guru Member

    Thanks for .14

    Thanks for the new firmware.

    Port Triggering still locks up the router
    Other than that seems to work fine, but I've only had it running for a day.
    I'll do more testing this weekend...
  9. jgbptl

    jgbptl LI Guru Member

    I'll soon give up...

    I just installed firmware 1.1.14, thinking it could at least not get worse than 1.1.11, that I used before. I was right, it didn't get worse, but it didn't get better either. What am I doing wrong? Or is the RVS4000 this bad?

    When I have my ADSL-modem directly connected to my Dell Dimension 9200 system (with Vista Ultimate) I get a download speed of 6.0 to 6.8 Mb/s (my ADSL service is labeled 8 Mb/s, so 6.8 Mb/s is probably a reasonable "real world" speed).

    When I use the RVS4000 with firewall an IPS enabled I get 800 to 900 kb/s. If I disable IPS I get about 2 Mb/s. If I also disable the firewall I get a very small additional increase.

    I have a fixed IP at my ADSL service.

    In addition to the performance problem the built in switch seems very unreliable; on port 1 my computer most of the time won't recognize that the switch is connected at all. The situation gets slightly better for each port and on port 4 it works most of the time.

    Is it really supposed to be like this? The store I bought it from claimed "Throughput WAN-LAN: 800 Mbps". I would be surprised if I could get those figures between two ports on the built in switch.

  10. bctrainers

    bctrainers LI Guru Member

    "2. Fixed a frewall issue with ports 23 and 5190." About time! And it be time to see if there are any performance increases! :D
  11. bctrainers

    bctrainers LI Guru Member

    Woah, this upgrade was more over a buggy one...

    Syslog is literally spewing out:

    12-31-2007 16:01:50 Kernel.Warning do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    12-31-2007 16:01:50 Kernel.Warning do_bindings: helper existing for (c0a51b20)
    12-31-2007 16:01:50 Kernel.Warning do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    12-31-2007 16:01:50 Kernel.Warning do_bindings: helper existing for (c0a51b20)
    12-31-2007 16:01:50 Kernel.Warning do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    12-31-2007 16:01:50 Kernel.Warning do_bindings: helper existing for (c0a51b20)
    12-31-2007 16:01:50 Kernel.Warning do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    12-31-2007 16:01:50 Kernel.Warning do_bindings: helper existing for (c0a51b20)
    12-31-2007 16:01:50 Kernel.Warning do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    12-31-2007 16:01:50 Kernel.Warning do_bindings: helper existing for (c0a51b20)
    12-31-2007 16:01:50 Kernel.Warning do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    12-31-2007 16:01:50 Kernel.Warning do_bindings: helper existing for (c0a51b20)
    12-31-2007 16:01:50 Kernel.Warning do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    12-31-2007 16:01:50 Kernel.Warning do_bindings: helper existing for (c0a51b20)
    12-31-2007 16:01:50 Kernel.Warning do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    12-31-2007 16:01:50 Kernel.Warning do_bindings: helper existing for (c0a51b20)

    Over and over...

    Also in firefox, all my links are showing up as white.
    Seems also my user names and passwords for the router got reset back to admin admin. :/
  12. tony4d

    tony4d LI Guru Member

    Well, that's pretty much all I need to know.

    I have been very active in evaluating beta for the RVS4000. I think I've downloaded, installed, and gave feedback on all them actually. At this point though, I'm just not up to it again. The major problems with the last beta had to do with router crashes and lock up when changing things like port forwards. I really think they need to address these issues.
  13. Toxic

    Toxic Administrator Staff Member

    what is your WAN MTU set at Jan?
  14. jgbptl

    jgbptl LI Guru Member

    Originally my WAN MTU was "Automatic". After you asked, I have tried manually setting it to 1000 and 500 but it did not increase my download speed beyond my margin of error.
  15. bctrainers

    bctrainers LI Guru Member

  16. tony4d

    tony4d LI Guru Member

    49152 is UPnP (Universal Plug-n-Play). I don't see anything wrong with that. If it was closed it would cause issues.
  17. frostytech

    frostytech LI Guru Member

    Quick VPN with .14

    Anyone tried using the QuickVPN with .14?
    I cannot get QuickVPN to work with this new beta.

    Firmware .13 and QuickVPN worked flawless
    Firmware .13 and QuickVPN failed

    I cannot get either version of QuickVPN to work with firmware .14
    QuickVPN never 'sees' the RVS4000.
    It never gets to the activating policy stage.
    Only the intial 'connecting' stage

    I will be going back to firmware .13 to verify...
    Then back to .14 to confirm.
  18. frostytech

    frostytech LI Guru Member

    The KB889527 patch

    Has anyone noticed the above patch that is always in the release notes contains a much older TCPIP.SYS driver that the current one pushed out by Windows Update?

    The KB889527 TCPIP.SYS is version 5.1.2600.2591
    Latest 'Windows Update' version is 5.1.2600.2892

    I have (had) no problems with the XP SP2 firewall enabled and ICMP incoming echo selected with build 2892.
  19. Toxic

    Toxic Administrator Staff Member

    100 or 500 is not the normal. ADSL usually should use a maximum of 1492 and lower. you only lower by factor of 8 each time. 1492, then 1484 the 1476 usually you should set it to 1492 however unless packets are broken.
  20. markbjohnson

    markbjohnson LI Guru Member

    Thanks FrostyTech for the note on Port Triggering. Upgraded to .14 and things are working fine now that I disabled the port triggers I had previously set up. Will report back with any other issues now that it isn't locking up every few minutes...
  21. marshall213

    marshall213 Guest

    when the router is connected to an existing domain which has an existing DHCP server, the VPN client can only communicate with the router but not the PCs on the other network.
    already selected DHCP relay and entered the IP address of the DHCP server of their network but still unable to ping the other PCs
    but if the RVS4000 supplies the IP address to the remote VPN client, it can ping the remote PCs .

    any work around? don't want to use the DHCP server of the router
  22. tony4d

    tony4d LI Guru Member

    Well, I felt bad and decided to try this latest beta firmware. I have to say, I'm glad I did :D

    First of all, the webui is much improved in firefox. I can't find a single thing now that does not work (javascript wise) or does not look right. Very nice linksys!

    Secondly, the lock ups and weird reboots that seemed to take forever seem to be gone. Granted, I've only been running it now for like 10 minutes, so we'll see how lock ups go in the next 5 - 7 days. That said though, when updating static ip maps and single port forwards, no problems what so ever! Before, with the last beta (1.1.13) these functions would lock up my router for 5 - 10 minutes.

    WAN down and up look good too, with IPS disabled.

    Basically, I have no complaints so far. Have not tried VPN.
  23. frostytech

    frostytech LI Guru Member

    This is false for QuickVPN...

    I have a Win2K Server acting as a DHCP server.
    The DHCP Server if OFF in the RVS4000.

    I can ping PCs and access them through Network Places IF I use the LAN IPs of the PCs in Explorer. (\\ for example)

    XP SP2 (firewall On or Off - doesn't matter) and QuickVPN works perfectly. This was with firmware .13.

    As I mentioned yesterday, could not get QuickVPN to work with firmware .14. After going back to firmware .13, QuickVPN is working again, but only with version Version hangs at the Verifying Network prompt. I will re-test firmware .14 again to verify.
  24. frostytech

    frostytech LI Guru Member

    No problem man
    You're welcome..

    For the record, Port Triggering will lock up the router with firmware .13 and .14. I was able to replicate the lock up numerous times. The instant I deleted the triggering rules and made them Port Forward rules, lock ups stopped. Plus I always leave IPS disabled because it slows down throughput and to eliminate IPS as a source of the lock ups.

    One thing I have noticed about enabling and disabling Port Forward rules...

    If the rule was enabled and then disabled, the router will 'stall' for about 10 to 30 seconds. Meaning it appears to have locked up. Yet after about 30 seconds or less, can access the routers webpages and access the Internet again. Although, it seems that repetitive attempts to access the Internet and/or the routers setup pages during this short time frame WILL cause the router to lock up.. LOL!!!!
  25. frostytech

    frostytech LI Guru Member

    QuickVPN .14 update

    Well, after going back to .13, testing, then updating back to .14 firmware...

    QuickVPN works, so I must have made a goof the first time I setup VPN with .14

    QuickVPN still hangs at Verifying Network and makes no difference if the XP SP2 firewall is On or Off.
  26. Toxic

    Toxic Administrator Staff Member

    frostytech. are you running any antivirus package that scans web pages?

    I noticed my WRV200 was slow as hell when i had it enabled. if I disabled it worked fine. I then created a rule on the Antivirus pacjage to ignore the webgui of my WRV200's IP address. I then had no problems.

    have you tried this yet?


  27. lantholin

    lantholin Guest

    Any chance of increasing the number of VPN connections allowed by the RVS4000? 5 IPSEC VPN connections is pretty limited for a small business series router.
  28. frostytech

    frostytech LI Guru Member

    I do have Symantec AV v10 installed.
    Yet I only enable autoprotect when needed.
    So, I don't think it's AV software...
    One thing to note, PPPoE for the WAN...

    I have tested with IE6 (Win2k PC), Firefox (Win2k PC), and IE7 (XP PC).

    It seems that if the forwarding rule is active, moreso with activity on that port, and the rule is disabled, my RVS4000 tends to stall like I mentioned above. If I wait until the WAN port blinks a few times, can access the Internet and the router's webpages. If I keep trying to access the Internet or router's webpages repetitively beforehand, it will lock-up. I witnessed this about half-a-dozen times with .13. Haven't spent enough time with .14 to know how the RVS4000 will react.

    I do wish they'd fix the port triggering because it's a feature I prefer over port forwarding. :)

  29. tony4d

    tony4d LI Guru Member

    Well, I had to add another static ip map and 3 single port forwards last night. I got the same behavior I experienced in the past with 1.1.13, although not as bad.

    First I added a new static ip map. It updated, then went to the reboot screen. It ook a while, but finally hit 100%, but then my browser reported could not connect, like the webgui just went away. Indeed it did, cause I could not pull it up again, and internet connections were down. I had to wait about 5 minutes, then disable and re-enable my local area connection in windows to get it back.

    When I added the 3 new single port forwards, it updated right away and brought me right back to the port forwards page. But then, I could not browse the webgui for about 30 seconds. So it was obviously still doing something, but I had no indication on screen, so it seems like its locked up during that time.

    The good news is, I still have not experienced any lockups or dropouts. :)
  30. tony4d

    tony4d LI Guru Member

    BTW, question, why doesn't port triggering support defining whether or not you want to allow the TCP or UDP port? I realize its broken right now, but this could be very useful for xbox live ports.

  31. tony4d

    tony4d LI Guru Member

    I thought about this some more, and although it would allow some more control, it's not really necessary, as long as you trust your devices inside your own network. Considering the trigger is initialized with an "outbound" request, no ports will open unless your devices inside the network ask for it. At least, I'm assuming it would only open a udp port if only a udp port was requested going out, instead of opening the tcp port with the same number as well.
  32. Recently bought this router. It failed to work out of the box (1.1.09 firmware)- required two or three power cycles a day to reset it. I have the same problem with the 1.1.14 firmware. I'm using it at home with only one or two computers connecting - just basic browsing and email, no P2P programs, minimal TCP/IP connections. Just the basic router functions, IPS turned off. There is no way I could recommend anyone buy this product. It is really sad that this is sold in the Business Series.
  33. vpnuser

    vpnuser LI Guru Member

    You should call Linksys about the problem. They will be glad to make it work for you if you are not using any fancy configuration. BTW, did you reset the router's configration to factory defaults after firmware upgrade?
  34. tony4d

    tony4d LI Guru Member

    Agreed vpnuser.

    I won't make any excuses for linksys with this router, but it has never "not worked" for me. There have been a lot of bugs, and some weird lockup issues when doing very specific things in the admin, but overall, linksys has continued to release new firmware in an effort to get it right.

    I suggest you call them and get a replacement. Before that though, I'd try:

    1) reset to factory defaults
    2) upgrade to beta 1.1.14 (even if you're already on 1.1.14)
    3) reset to factory defaults

    That may do it. If not, call them up and get a replacement.
  35. micrisc

    micrisc LI Guru Member

    I have given up on this router. Linksys sold me junk that locks up, is buggy, and can't reliably supply a good secure connection. I ended up after a year with this horrible router building a rack mount server running IPCOP. I've learned an important lesson from this router. If there isn't a 3rd party firmware for a linksys router, don't buy it. I love my WRT54GL's and the legacy WRT54G's with DD-WRT. Hopefully someone will do something with this router so it is more then just a paperweight.
  36. njprice101

    njprice101 Guest

    Site-to-site VPNs

    My challenges with the RVS4000. Have a RV082 at one site and several RVS4000 at remote sites. We intended to use them for site-to-site VPNs. Everytime I built the tunnels they would come up last for about 30secs and then the RVS4000 would lock up. All 13 RVS4000s acted the exact same way. I contacted support and they had me try some beta firmwares. I will say that the webgui is much faster in 1.1.14 than 1.1.09 was. But the RVS4000 still locked up.

    Then I finally figured out what was causing the lock up and it wasn't the VPN. After the VPN tunnel came up I would port scan the remote network (the LAN behind the RVS4000) to test IP connectivity across the tunnel and to find live hosts over there. Everytime I would get a response back from the RVS4000 itself (something I found odd) but never any other hosts. Finally one day I had a tech at the remote site while I worked remotely setting up a new tunnel. With a tech on site I was able to have him give me an address of a live host. So after the tunnel was configured I was able to ping that host just fine and it didn't lock up. After 10 minutes of the tunnel working I got out my port scanner and tried port scanning that remote network again. Within seconds the RVS4000 locked up.

    Personally I find this annoying, but glad I found a work-around as Linksys support had no clue. Second this is also a security flaw. Anyone in my network can bring them down with a simple and free tool in a matter of seconds.
  37. sinux

    sinux LI Guru Member

    I've upgraded this evening to 1.1.14. And the vpn doesn't work fine (as with the 1.1.13). When you connect with qvpn evrything goes fine except the last step. It's trying to ping the gateway and fails.
    But that's normal because the client adress is not on the same range as the local network. So the rvs4000 refuses to respond to the ping.
    I've got then same problem with another router in the lan which refuses to respond to the ping (for security reasons).
    The question is : why when you connect through vpn the client does not recieve a new ip adress?Or why the gateway does not "translate" the adress?

    The second bug I found (it was already in 1.1.13) is when you define static ip mapping. If you set then, you cannot then add!! it says that the host ip already exists! but there is nothing in the list and nothing in the status/local_network/dhcp_client table.

    Thanks for your help
    PS: why is there no button to logout(to close the connection) after finishing to manage the rvs4000?
  38. Steve Evans

    Steve Evans LI Guru Member

    The IP by DNS Resolved option in the IPSec VPN tab does not work in release 1.1.14. Given that DDNS was one of the items apparently fixed in this release, this comes as a disappointment.

    I am connecting to my RVS4000 from a Mac using IPSecuritas. The connection is established without issue if I specify an IP manually, yet using a hostname does not work. Interestingly the name does appear to resolve, as it is displayed correctly on the Summary tab, yet the connection will not open. As soon as I specify the IP Address option and enter the address manually, the tunnel springs into life.

    As I connect to this router using a Mac laptop I am unable to use the Quick VPN facility. This means that even when the above is fixed I'll need to wait for DDNS to resolve my new address and for the router to pick that up before I'll be able to connect. It would be much better if this router accepted non-address based client authentication. Is this likely in a future release of the firmware or would I be better to give up on this router now?


  39. Steve Evans

    Steve Evans LI Guru Member


    I can confirm that I too have seen the problem with setting DHCP reservations where duplication is claimed.

  40. Steve Evans

    Steve Evans LI Guru Member

    Version 1.1.14 frequently locks up when settings are applied. I can understand that some changes to the configuration will require a reboot, and others can be applied instantly, but the web interface gives no indication of which applies. This could do with being clarified.

  41. tony4d

    tony4d LI Guru Member

    Agreed Steve, I've been saying the same thing. It seems like what feels like a lookup is really just the router going though a reboot or just taking some time to apply changes and refresh. We need an indication of what is going on in the admin interface.
  42. sinux

    sinux LI Guru Member

    I just wanted to correct something I said.

    Don't ask me why but this evening I tried to connect with qvpn+ (as last evening) but it failed! So I tried qvpn (v.1.1.0 win xp) and this time everything went fine. The client could ping the gateway and acces to the webadmin!

    PS : if I try to connect only with qvpn it says " the gateway is not responding".
    if I connect with qvpn+(1.0.6) :
    quickvpnplus.exe -f config.xml -F 2
    then I disconnect :
    quickvpnplus.exe -x -f config.xml -F 2
    and after that I reconnect with qvpn I can ping the gateway from the lan interface!!
    Can someone try it to confirm?
  43. JoeQca

    JoeQca LI Guru Member

    Slow ipsec vpn tunnel

    Before i take the plunge of upgrading my 2 RVS4000 routers to the latest beta firmare 1.1.14 from the 1.1.09. Can anyone let me know if my ipsec tunnel will speed up with the upgrade? between sites i get dl speeds of 75/kbs when i should be getting over 300/kbs.

  44. tony4d

    tony4d LI Guru Member

    Well I hate to report it, but 1.1.14 still has lockup problems. I don't know how to classify it really, but after running this beta for a little over two weeks I've encountered 3 occasions where internet access was gone and I had to reboot the router to get anything back.

    I'll try to get syslog going so I can provide log info when this happens.
  45. Steve Evans

    Steve Evans LI Guru Member

    Well, I figured I should let you all know... I've given up on the piece of junk that has RVS4000 stamped on in. Had it lived up to what it said in the datasheet then I would have been singing it's praises, but instead I find myself wondering how a company could release a product with software that is not even of alpha quality. It locks up randomly, the web interface has clearly had no Information Architect oversee it's design, the web interface locks up randomly, the dynamic address resolution for remote VPN clients doesn't work and it takes an age to boot up.

    Poor effort Linksys.

    Can anybody recommend a Gbit VPN router that WORKS?

  46. Steve Evans

    Steve Evans LI Guru Member

    Ah good... the Netgear FVS124G DOES work. :smile:

    Good to know that all this time messing with the RVS4000 my understanding of VPN was not flawed.

  47. micrisc

    micrisc LI Guru Member

    The only thing I did not like with the Netgear FVS124G was that you had to buy the client VPN software.
  48. Steve Evans

    Steve Evans LI Guru Member

    Not if you're using IPSecuritas for the Mac. :smile:

    Suddenly getting all this VPN stuff up and running is a joy.

  49. JoeQca

    JoeQca LI Guru Member

    Request for Fixed Firmware

    Hey all I have been actively reading all the posts in this thread in hopping/praying/dreaming of fixes for the "slowness" I have experienced with the ipsec tunnel between 2 RVS4000 routers. Does anyone have an email address of a tech person at linksys so I can write them an email, and maybe cc a Cisco Manager. Clearly from all the posts from this model, their programmers are having troubles with squashing some of these bugs and possible Cisco can lend a hand.

  50. bctrainers

    bctrainers LI Guru Member

    Syslog wont get you very far when a lockup happens. What i see on my router during no activity is a bunch of code spam which is on page two of this thread of it spewing out random debug crap. The router still chokes on high loads with massive connections + high transfer. Syslog will lock up and web activity will cease to work. Than when syslog sends a bunch of data wan to lan speeds spike. It never use to do back back when this router first game out. :frown:
  51. Solinga

    Solinga LI Guru Member

  52. jameskil

    jameskil Guest

    No General Release of zFrimware for RVS4000 in Nine Months?

    How about next time I buy a Linksys product, I pay for it with Beta money ??:mad:
  53. bctrainers

    bctrainers LI Guru Member

    I wonder what: Kernel.Warning - - H.323_NAT: partial packet 0/6 in 0/0

    means... Guessing a packet got fragmented?
  54. toplok

    toplok LI Guru Member

    guys can you help me how to configure my RVS4000 to gateway - gateway connection. I still cannot establish a vpn tunnel between RVS4000 and RV082.. both are connected to a WAG200G modem with DDNS enabled cnnected to PPPoA (provider) Any help would be greatly appreciated. Thanks
  55. csan

    csan LI Guru Member

    ... or with garbage money !
  56. JoeQca

    JoeQca LI Guru Member

    Beta Money

    I love the comment on paying with Beta Money!

    I have 2 RVS4000 with an ipsec VPN connecting them and the speed is terrible, waiting for another firmware and will be emailing the GM very soon with a nice letter.

    P.S. the last 2 routers I have had to purchase for clients were DLink :)

    I have lost all confidence with Linksys Products, and I am tired of their crappy firmware releases.

    Maybe if their sales drop they might start to put more money behind their programmers?
  57. jackjack

    jackjack Guest

    I updated from 1.1.09 to 1.1.14 before the update the response time was

    Ping statistics for
    Packets: Sent = 50, Received = 47, Lost = 3 (6% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 4ms, Maximum = 4301ms, Average = 1093ms

    After the fireware upgrade:

    Ping statistics for
    Packets: Sent = 50, Received = 50, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 2ms, Maximum = 22ms, Average = 16ms

    At least for now, it fixed my problem.

  58. micrisc

    micrisc LI Guru Member

    Same here. I have tried to get in contact with thier corp office but the indian's I get in support don't even know the address and fax #'s for thier corp office. I also have stopped buying linksys products. the last 20 or so installs have either been netgear or a linux based setup using IPcop. I noticed that linksys really went downhill after cisco bought them. If anyone have email addresses, fax #'s or an address for linksyss' corp. office please post. I would like to get my REAL money back for my P.O.S. Beta routers. Or at least trade them in for somrthing like a WRT54GL that I can put on a 3rd party firmware.
  59. micrisc

    micrisc LI Guru Member

    Will this nightmare ever end

    Just a thought, but this thing is linux based, correct? What would it take to create a 3rd party firmware for this brick. because I have waited two years for Linksys and, well, I'm tired of waiting and get pissed off every time I see these routers sitting on the shelf, unpluged waisting space. At this point it's either throw them away or make my own firmare. So does anyone have a good site for writing linksys firmware?
  60. sgroom

    sgroom LI Guru Member

  61. Max10

    Max10 LI Guru Member

    1.1.14 fixed my ddns problem

    Just wanted to share my experience with .14. After updating to .14 my ipsec tunnel between a WRV54G and my RVS4000 seems to be working just fine. Before with .09 every time one of the ip addresses got updated on either side of the tunnel I had to go in and and manually update because DDNS was obviously not working. Now it appears that it is working. As of right now I haven't setup any port forwarding but it seems like it might be problem or at least port triggering. The funny thing is, is that I would pay double the price of what I paid for my RVS4000 if it had real hardware in it and real engineers writing the software (I'm still in the camp that the reason the RVS4000 will never be super fast is because it simply doesn't have the hardware in it. Kinda like the new WRT54G POS.) The problem is that there is no no middle option its either linksys cheap, slow, and buggy, or Cisco fast, reliable, and prohibitively expensive. You would think that the people who are being paid millions of dollars because of their brain power and experience would be able to figure out that we need real hardware as homes are getting connected with fiber optic connections and everything is being pushed onto the internet. At least give me the option to pay more for a better processor and more ram, and please, please, please start publishing the specs of the hardware instead of just saying what it is supposed to do. (When was the last time we purchased a laptop just based on marketing and not looking at how much ram it had or what processor it was) I don't know maybe Cisco is afraid that if they make a quality Linksys product then people will stop buying there small business Cisco kit.
  62. Max10

    Max10 LI Guru Member

    Just kidding 1.1.14 did not fix DDNS issue

    Just wanted to update again because I got a new address at my location with my WRV54G and my RVS4000 did not update appropriately. I had to go in and manually update the address.
  63. webaumann

    webaumann Guest

    WAN disconnect

    I run the latest beta (.14) and am fine with performance. I have cable service with 10MB/s download and guess what, I get 10 MB/s after the RVS4000 with firewall and IPS on!
    The only problem I have since the beginning (1.0.9) is that after approx. 4 days and 3 hours I loose my WAN connection and have to reboot the router manually every time. I'm using DHCP for the WAN interface and the button 'DHCP Release' on the router admin is not working, that's why I have to reboot every 4 days... :confused:
    After rebooting everything works fine again for the next 4 days... :)

    Any idea what might be the cause?
  64. tony4d

    tony4d LI Guru Member

    I have the same issue. I had not correlated it to the WAN IP renew though, it just seems to happen every few days. Interesting.
  65. tony4d

    tony4d LI Guru Member

    Man, this router lockup, must reset issue every few days is getting really frustrating.

    Please help Linksys, you're my only hope :(
  66. bctrainers

    bctrainers LI Guru Member

    I've noticed this same issue myself. WAN just instantly will drop, or will sputter out until it looses complete connectivity. I notice it when the DNS begins to fail on the device. When DNS gives out, the rest of the router will than go in a spiral downward.
  67. Jamesss

    Jamesss LI Guru Member

    I am using also using RVS4000 latest firmware Gateway to Gateway connection to RV082. The tunnel was stable for me. All is running fine but their is a flooding system log file that is so annoying and reads like this:

    Dec 30 17:16:06 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:16:06 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:16:06 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:16:06 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:16:06 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:16:37 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:16:37 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:16:37 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:16:37 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:16:37 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:16:37 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:16:37 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:16:37 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:17:18 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:17:18 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:17:18 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:17:18 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:17:18 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:17:18 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:17:18 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:17:18 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:17:34 - do_bindings: helper existing for (c1db0800)
    Dec 30 17:17:34 - do_bindings:813 exp list is EMPTY!!!!!!!!!!!!
    Dec 30 17:17:34 - do_bindings: helper existing for (c1db0800)

    Anyone with the same problem? Any ideas?
  68. tony4d

    tony4d LI Guru Member

  69. bctrainers

    bctrainers LI Guru Member

  70. cmajewsk

    cmajewsk LI Guru Member

    Ha - you got FTP to work?
  71. bctrainers

    bctrainers LI Guru Member

    Works flawlessly for me despite the masses of syslog spam i get from it. :)
  72. tony4d

    tony4d LI Guru Member

    Throughout all the firmwares I've never had a problem using ftp with this router. Weird how it affects some and not others.
  73. westsyde

    westsyde Guest

    I've had FTP problems with the RVS4000, and have had intermittant lockups also. These problems have carried over with every firmware upgrade.

    I read somewhere that there was a wrt available for the RVS4400, I would pave this brick in a second if there is a wrt that can be applied on the 4000. If someone can point me in that direction I would be happy to report results.
  74. Toxic

    Toxic Administrator Staff Member

    I have not heard of any 3rd party firmware for this device, please point me into where you seen this?
  75. tony4d

    tony4d LI Guru Member

    I'm seriously fed up with this thing. It bombs out on me at least 3 - 5 times a week, forcing me to reset it and wait for like 3 minutes for it to come back up. Then, if I'm lucky it will work for a couple more days, if not, I end up having to reset it 2 - 3 more times until it finally works.

    I even went back to beta firmware 1.1.11 because that was stable for me back in the day. Well, it has the same issue.

    I'm on the phone with linksys support now, and they are going to send me a new one. I highly doubt it will help, but worth a shot I guess.

    Overall, I'm extremely disappointed in this purchase. I've owned this router since February 15th of 2007. Almost a year now and still no stable software!
  76. thebeck

    thebeck LI Guru Member

    Anyone know when we are going to get the next beta RVS4000 firmware? And/or the Linksys approved production RVS4000 firmware?
  77. tony4d

    tony4d LI Guru Member

    A small copy bug:

    On the port triggering page in the admin interface, the help text in the right column refers to a "Wireless Router". Obviously this is a wired only router so this copy is incorrect. Here's an excerpt:

    Port Range Triggering is used for special applications that can request a port to be opened on demand. For this feature, the Wireless Router will watch outgoing packets for specific port numbers. This will trigger the Wireless Router to allow the incoming packets within the specified forwarding range and forward those packets to the triggering PC.

    Be nice if they fix that AND fix port triggering :)

    Also, I can confirm a bug reported earlier about static ip maps, here:

    This condition only occurs given sinux's example though. The problem is in the js function "check_ip_mapping_same()". Notice here that javascript's indexOf() search is used:

    if(cf.static_ip_mapping_list.options[index].value.toUpperCase().indexOf(cf.static_ip.value.toUpperCase()) != -1)
    		msg+= "One same IP has been already in the List!";
    		return false;
    Of course this has a problem because indexOf() will return 1 when searching for indexOf() is not an exact match search, it simply searches for the needle ( in the haystack ( So, they just need to change this conditional to a straight string comparison.
  78. donzoomik

    donzoomik Guest

    Is it just me or is UPnP unable to foward ports automatically...? I'm using Vista and no success so far. Sure worked as charm under DD-WRT...
    Also, i've never got VPN to work, even after consulting tech support or searching Google. Overall i consider this a failed product, as i took RV042 instead of this one and all the problems have gone away.
  79. goozerin

    goozerin LI Guru Member

    Is the FW for the RVS4000 also compatible with WRVS 4400n??

  80. tony4d

    tony4d LI Guru Member

    No, completely different firmware for each.
  81. sgroom

    sgroom LI Guru Member

    Since we all bought this router for it's gigabit speed and expected performance, at the very least, to match linksys equipment we already owned... What's the alternative? I'd love to swap this thing out and have it hold the door to my office open.
  82. justme01

    justme01 LI Guru Member

    Version 1.1.14 opens port 443, even with an ACL to specifically deny, it remains open and visible.

    Another issue I have is with WAN side logging. Nothing shows except for LAN side as "incoming", even when IPS shows 100+ hits on the firewall (probably port 443).
  83. justme01

    justme01 LI Guru Member

    Belay that! I reset to default and it did not occur for port 443. It only comes to life somewhere in the backup router.cfg file.

    Also could you fix the spelling on the "reboot_guage.htm" page? It is gauge.
  84. simmons777

    simmons777 LI Guru Member

    Anyone else have a message in the log every 60 second telling you what the WAN MAC address is and the LAN MAC address? This firmware version has been working for me but it is annoying to tray and filter through 100's of messages telling what my MAC address is to see if something more serious is going on.
  85. tony4d

    tony4d LI Guru Member

    Do you have incoming and outgoing logs enabled?

    I don't, just normal log levels with syslog output. Only stuff I get is the messages every (EDIT correction) 10 minutes that have been posted before in this thread.
  86. tony4d

    tony4d LI Guru Member

    FYI, I finally got syslog running on windows home server. This is what I get every 10 minutes:

  87. tony4d

    tony4d LI Guru Member

  88. simmons777

    simmons777 LI Guru Member

    I did have incoming logs enabled. I'll turn it off and see if the messages continue.
  89. tony4d

    tony4d LI Guru Member

    Toxic, any word from Linksys devs about another firmware?
  90. System48

    System48 LI Guru Member

    Who enforced the GPL rules and made you take down the beta firmwares?
  91. Toxic

    Toxic Administrator Staff Member

  92. tony4d

    tony4d LI Guru Member

    It's linksys. Why don't they provide you with the source?

    This sucks. I hope this means that they will actually start doing something with their new "betas" website. As bad as some of their betas have been they need public testing.
  93. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    They do release source code just not for beta fimware http://www.linksys.com/servlet/Sate...mmon/VisitorWrapper&lid=4638033867B25#RVS4000. Follow the link and you'll find the source for the most recent "public" firmware released by Linksys.
  94. tony4d

    tony4d LI Guru Member

    Yes, I knew that. My point is they need to provide the source for the betas when they supply them to linksysinfo.org. Why won't they?

    In all honesty I'm really pissed off. I'm seriously considering selling all of my linksys equipment and moving on to dlink. I bought a business class router that constantly crashes and a business class wireless access point that cannot use WPA or WPA2 without dropping connections constantly. Both products have been available for over a year. Are you kidding me!? AFTER A YEAR AND THEIR PRODUCTS ARE STILL NOT STABLE!!! I can understand missing features, or feature they intend to add, BUT THE PRODUCTS DO NOT DO WHAT THEY ARE SUPPOSED TO DO!!!

    Seriously, complete crap and I feel like I was ripped off.
  95. simmons777

    simmons777 LI Guru Member

    This really does suck. I bought this router and the VPN just wouldn't work. The first thing I do is go to the Linksys website for the latest firmware. They have 1.1.09 posted which is older than what the router shipped with which was 1.1.12. That's when I came tothis site to look at beta's and 1.1.14 fixed my problem. Now where can I go?
  96. Powersurge69

    Powersurge69 Guest

    Tony4d, I couldn't agree with you more! I've been buying Linksys products for almost a decade, and used to even recommend Linksys to my clients back when I worked in sales. The company really took a turn for the worse when they became a division of Cisco... This RVS4000 that I'm using as a doorstop right now will be the last Linksys product that I'll ever buy!
  97. OxleyDave

    OxleyDave LI Guru Member

    Why should people complain to FSF? Linksys are the ones that were violating the GPL! Complain to Linksys for not supplying the source code for the betas! And while you're at it complain to Linksys about the poor quality of the firmwares in the last couple of years! After all this is the reason people are wanting the betas!!!
  98. System48

    System48 LI Guru Member

  99. tony4d

    tony4d LI Guru Member

  100. System48

    System48 LI Guru Member

    You're right, now who do I report them to?

Share This Page