1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Satori 4 WallWatcher logging setup...

Discussion in 'Sveasoft Firmware' started by Mark_Venture, Aug 8, 2004.

  1. Mark_Venture

    Mark_Venture Network Guru Member

    Long story short.. I had read the setup instructions on Sveasoft's site before the forums became Subscriber only, as well as the thread on DSLReports about how to get Sveasoft Satori-4.0 v2.07.1.7sv ( http://www.dslreports.com/forum/remark,10220283~mode=flat ) working with wallwatcher and had some problems.

    So to help others, here is what finally got it working for me... THANKS TO SUNE!!

    1. Load the FREE Public Sveasoft Satori-4.0 v2.07.1.7sv. After flashing, it is recommended to clear the router by holding the reset button 30 seconds to be sure everything is set back to defaults.
    2. On the Administration/Management page, Enable Telnet and Syslogd. Under Syslogd, in the Remote Server box enter the LAN IP address of the computer running Wall Watcher.
    3. On the Administration/Log page, enable logging. (I'm unsure if this is really needed since syslogd does the logging but I'd read in the original instructions I was following to do it, and it can't hurt).
    4. Install wall watcher if you haven't already. ( go to WW web site, download the latest WW and its libraries, two different zip files. Unzip them both into the directory where you want Wall Watcher installed. Run the Setup.exe from there and answer the questions.)
    5. From inside WW, use the Options pull down and select Special. In the router drop down, choose Linksys WRT54G (Sveasoft). Fill in the Router's LAN IP address. Set any other options you want.
    6. Telnet into the router... (in winxp, start -> run -> Telnet 192.168.1.1 or whatever the lan ip address is for your router) For user name enter ROOT for password enter the admin password of your router.
    7. Here is a screen shot of my Telnet session for what to type in bold...
    8. to leave the telnet session, type EXIT.
    9. Optional... In the router's Administration/Management tab, disable Telnet.

    Since these changes get committed to NVRAM, they survive power off/on of the router.

    :oops: Stumbling blocks for me prior to SUNE's help... 1. having read elsewhere that the built in command shell (from the diag's tab) gives you the same console as telnet, I first tried that way instead of telnet. My mistake!! While it works to change the logging using the IPTABLES commands via the command shell, I HAD to use Telnet to be able to commit these settings to NVRAM so they survive power off/on. 2. I did not understand what was "quoted" as needed to be typed in during the telnet session to committ the changes to NVRAM as I was thinking I could use the command shell and it didn't look the same.
     
  2. Mark_Venture

    Mark_Venture Network Guru Member

    Btw, after doing the steps above, WW logs in/out bound traffic and router messages just like when using my Linksys BEFSR41, with a few minor exceptions...

    I get more details. Including mac address of remote machines.

    I get additional messages and status.. example I am now seeing inbound UDP from remote IP address es 10.83.48.1 and 68.34.252.1, remote port 67. Local IP is 255.255.255.255 and local port 68. Every 10 to 12 minutes, I get multiple listings of this. It appears to be normal DHCP traffic from my ISP (comcast).
     
  3. mcook

    mcook Network Guru Member

    WRT54G+Satori-4.0 v2.07.1.7sv+WallWatcher-3.0.12

    Well, I followed the earlier version of those instructions and it works great.

    Now I must make it over with the nvram commands too.

    Thanks for a great job,

    Michael Cook
    WRT54G+Satori-4.0 v2.07.1.7sv+WallWatcher-3.0.12
     
  4. Hi, Mark_Venture

    I followed your instruction and committed the changes to nvram, now I can't access the web setup thru http://192.168.1.1, I can telnet to my router, also "ps" no httpd is running.

    How do I bring back the web access thru http://192.168.1.1 ?

    Thanks.
     
  5. Mark_Venture

    Mark_Venture Network Guru Member

    The only time I lost access to the router's web based configs while doing this was when I used the command shell rather than telnet. When I lost access, I cycled the power on the router.

    Unfortunately I am not sure why you lost web access to the routers setup pages after doing this. :( The above has worked for me on two WRT54G's (a v1.0 and a v2.0) without loosing access to the web based setup screens. Also, I have made no config changes to my router from the defaults other than what I typed above. I am using no other "features" or "functions" besides the defaults.
     

Share This Page