1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Satori IP problems

Discussion in 'Sveasoft Firmware' started by dnlhnmn, Oct 21, 2004.

  1. dnlhnmn

    dnlhnmn Network Guru Member

    After flashing the Satori 4 firmware on my WRT54GS, nothing on my network can get the correct IP. My network is setup for DHCP handing out 192.168.x.x. This IP is correct for one day, until the IPs are supposed to be reissued, and then i get the default microsoft 169.254.x.x address... any thoughts?

    Works fine with original linksys firmware...
  2. grcore

    grcore Network Guru Member

    Have you done a factory default reset since flashing. That is critical.

  3. dnlhnmn

    dnlhnmn Network Guru Member

    yes, ive done the factory reset after flashing, and it still happens. It hands out the 192.168.x.x ip for one day, and then stops handing them out. This happens on my wireless laptop (XP pro SP2), and my wired PC (Win 2k SP4).
  4. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Not this wil solve the problem but you might want to disabel th APIPA function in Windows


    You should also make sure your lease is longer than a few hours as there is not requirement to keep renewing leases all the time on a smal network. This doesn't fix the dhcp server problem, but you won't need to reboot as often to find out windows gave you and address.
  5. dnlhnmn

    dnlhnmn Network Guru Member

    I am still having this problem. It seems to be a random thing, not happening at set times. All the clients seem to lose the IP addressing... I disabled APIPA on one of my clients, but now instead of getting a 169.254.x.x it gets a My router is set to give leases for 1440 minutes (1 day) but when I do an ipconfig /all it says the lease is only 5 minutes. I ran ethereal and found that the lease is only 5 minutes long..... Any other thoughts?

    Also, i noticed that if i ping my routers IP address from both clients at the same time the client that pings first loses connection. whats the deal? :?
  6. FlyNavy

    FlyNavy Guest

    Mine is doing the same thing. This is my first try with 3rd party firmware. Love the power settings, but am about ready to go back. Also, internet connection seems to be considerably slower in resolving addresses upon initial connection. Any solution to this or recommended other 3rd party firmware? I am using Satori-4.0 v2.07.1.7sv

  7. dnlhnmn

    dnlhnmn Network Guru Member

    After doing hours of searching, maybe I've come up with the answer. I read a lot of posts on the sveasoft site, and it seems that enabling syslogd has solved similar DHCP problems. Anyone know any information about this?

    I'll give it a try and see what happens...
  8. dnlhnmn

    dnlhnmn Network Guru Member

    Seems to have fixed my problem...

Share This Page