Segmentation Fault on Radius query

Discussion in 'TinyPEAP Firmware' started by eNGinE, May 4, 2005.

  1. eNGinE

    eNGinE Network Guru Member


    I recently installed TinyPEAP on my WRT54GS v1.0

    I can config, start, ect. the the Router and peapd without Problems.
    But once i make a Radius query I get a Segmentation Fault, and peapd terminates.

    Here is a screen from the ssh:
    (none):[/]# peapd run
    end of db_read_file
    DEBUG: config_db:
    end of db_read_file
    DEBUG: user_db:
    DEBUG: radius password: password
    ---Wireless Authenticator v2---
    Listening on, UDP port 1812

    ---Received Packet---
    Packet Size: 28
    Code: 12
    Ident: 8
    Length: 28

    TIMESTAMP: 1115214201.564317
    Segmentation fault

    I also tried the Windows Version of peapd, but it crashes likewise.

    Radius Request Type (Status Server/Auth Request/Acc Start/Acc Stop) doesn't matter; always the same result. :-(

    Tested with 'NTRadPing Test Utility'. Download here

    Any Ideas???

  2. eNGinE

    eNGinE Network Guru Member

    btw. defining a specific IP/Interface doesn't change anything either.

    Used Versions are TinyPEAP Beta2.13 for WRT54GS, and PEAPD Beta1 for Windows.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice