1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Set up SSH on Tomato, but confused by user:pass messages from ad servers

Discussion in 'Tomato Firmware' started by Sunspark, Jun 5, 2008.

  1. Sunspark

    Sunspark LI Guru Member

    Hi, I'm pretty confused by this as it was a bit unexpected!

    I wanted to experiment with getting SSH working as a tunnel for remote browsing through my home connection when out and about.. I've managed to generate a key, and I've managed to get it installed into Tomato and it's working as I set Firefox up as a manual proxy, and it asks me for my passphrase before I can browse the web and using -v in the terminal shows that it's negotiated everything and is connected.

    Ok, well, on a number of websites I get this popup dialog entry box often: "A username and password are being requested by http://ad.doubleclick.net. The site says: "myrouternamehere""

    WTF!?

    Obviously I am not entering any user/pass for an ad server, but what is going on that I'm being harassed by this dialog box over and over.. yieldmanager is another annoyance.. both of those domains are blocked on the router's rules too to route them to 0.0.0.0
     
  2. Sunspark

    Sunspark LI Guru Member

    I have new information.

    I commented out the lines:
    #address=/doubleclick.net/0.0.0.0
    #address=/yieldmanager.com/0.0.0.0
    in the dns/dhcp tomato server box

    and the password demands have gone away.

    Really?! If I want to use SSH tunnels I am not allowed to block websites on the router??

    WTF? Still confused. But at least I now know what was generating the message.
     
  3. nvtweak

    nvtweak LI Guru Member

    Try blocking them using the loopback address 127.0.0.1 instead of 0.0.0.0. Or specify a port like 127.0.0.1:81

    If this doesn't help, try OpenDNS to block unwanted domains. Or change the HTTP Port on your router to something like 82.

    What seems to be happening is that those sites in your block list are being redirected to the local http socket on the router.
     
  4. Sunspark

    Sunspark LI Guru Member

    nvtweak thank you!!

    You solved it. Changing tomato's port away from 80 to 88 stops the ad servers being blocked by dnsmasq with 0.0.0.0 from asking for a user:password on tomato.

    So now the question becomes.. IS THIS A BUG?

    (I also tried 127.0.0.1, it doesn't change the behaviour)
     
  5. nvtweak

    nvtweak LI Guru Member

    You're welcome :)

    It might be a bug, or just an unfortunate side effect. I think 0.0.0.0 is supposed to be treated as a null address, but maybe dnsmasq and/or ssh is having issues..
     
  6. mstombs

    mstombs Network Guru Member

    The problem seems to me to be the PC with the browser, normally it looks up the IP address and asks itself for the 0.0.0.0 page. In this ssh tunnel it seems to be asking the router.
     

Share This Page