1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sharing DSL with Linksys WRT54g

Discussion in 'Networking Issues' started by boast, Jul 6, 2005.

  1. boast

    boast Network Guru Member

    I got EarthLink DSL and a Linksys WRT54G router. How do I setup the router to allow the computers connected to it to use the internet also?

    I already set up my router to connect to the internet, and my computer works fine. My computer can also access the 2nd computer, and visa-versa. But the second computer's internet does not work.

    I tried setting up ICS, but is it possible with one nic? I set my network connection as my internet connection, but my network setup wizard cannot be completed.

    So what do I have to do to share my dsl?

    I want to have to use a proxy or w/e as my last resort. Thanks.
     
  2. gila

    gila Network Guru Member

    @boast

    the router should be set up by default to share your internet connection...

    make sure your second computer is set up for a dynamic ip address... if it already is, try releasing and renewing the ip

    -Jason
     
  3. boast

    boast Network Guru Member

    it's assigned the IP givin by my router, DHCP or w/e enabled. I also tried with it disabled, but it still didn't work.
     
  4. gila

    gila Network Guru Member

    have you tried connecting that (2nd) computer directly to the dsl modem to see if the internet works that way? could be a problem with the computer itself (spyware, etc.)

    Also, try running a ping from the command prompt to see if anything is getting out at all... if it is then it could be IE settings or spyware/adware/etc.

    to reset IE settings go to Tools->Internet Options->Advanced Tab->Restore Defaults
     
  5. boast

    boast Network Guru Member

    I can ping anything that is not internet. I've tried both firefox and IE for using the internet, and nothing.
     
  6. gila

    gila Network Guru Member

    okay, let's get some details...

    OS?
    any firewall/security software? (including XP's firewall)
    can you ping the router? (192.168.1.1 by default)
    when you try to ping anything else (i.e. yahoo.com) does it get the ip address? i.e. "Pinging yahoo.com [216.109.112.135]"

    what if you try to ping that ip address (yahoo's) directly? if that works then it's a DNS issue...

    I'm gonna be out for the night, but let me know what you find and I'll check back tomorrow.

    -Jason
     
  7. boast

    boast Network Guru Member

    Computer 1 - Wired to router and working - Windows xp home sp2 w/ Kerio pf 2.1.5, works and pings everything.

    Computer 2 - Wireless - Windows xp pro sp2 w/ kerio pf 2.1.5, pings computer 1, pings router, can share files, but cannot ping outside places.


    "Ping request could not find host yahoo.com"

    So it see's no type of internet connection present.
     
  8. gila

    gila Network Guru Member

    did you try pinging yahoo by ip address instead of just by domain name?
    (ping 216.109.112.135)

    have you tried disabling the kerio personal firewall? I know you've got it on the computer that's working but there could still be an issue with the configuration of the software.

    is it possible to hook computer #2 directly to your modem to see if the internet works that way? if it does then it's a router issue, if it doesn't then it's your computer. (note you would probably need to power-cycle your modem after you've got it hooked up)

    I'm not yet convinced that this is a router issue...

    -Jason
     
  9. czeman

    czeman Network Guru Member

    Make sure that "Obtain DNS server address automatically" is selected as well under TCP/IP Properties.
     
  10. boast

    boast Network Guru Member

    Whelp, I didn't backup my old settings on my WRT54G, so after playing around with it to try and fix it, i messed it up more.

    The router doesn't see the modem. I put in my PPPoE settings, but it doesn't connect, and goung to status and clicking on connect results with a window stating it cannot get the modems ip.

    Removing the router and connecting directly to the modem works, but my router can't seem to see it anymore. I tried hard resetting it, but nothing.
     
  11. czeman

    czeman Network Guru Member

    Did you try applying power to the modem and the router in opposite sequences?

    For example:
    Modem then Router
    Router then Modem
     
  12. boast

    boast Network Guru Member

    just did. I can connect to the modem, and I can connect to the router, but putting in my info into the PPPoE thing on the router, it doesn't connect.
     
  13. boast

    boast Network Guru Member

    Man I have no idea why the router + modem isnt working anymore.

    I reset the modem, I factory restored the router. Then all I did was set the PPPoE info and save. Still nothing.
     
  14. czeman

    czeman Network Guru Member

    What firmwave version are you running?
     
  15. boast

    boast Network Guru Member

    Wifi-Box v2.02.2
     
  16. cromrell

    cromrell Network Guru Member

    The WRT54G is the network device which is sharing the DSL connection. ICS shouldn't be enabled on either PC/laptop.

    You would use ICS if you wanted to share the internet connection w/o the router (using a modem/nic, or two nics). When you using the router, both machines should be configured in similar fashion (the only difference is the ip address assigned by DHCP).

    While troubleshooting I would recommend going back to default Linksys firmware... and then migrate to alternate firmware once you are certain that everything is working properly.

    cromrell
     
  17. bluefish

    bluefish Network Guru Member

    1. when you are trying to connect via pppoe on the router what message are you getting? " cannot conenct to pppoe server? or "pppoe authentication failed"?

    2. when you are directly connected to the modem is automatic or you have to use a username and password to sign on?
     

Share This Page