1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Shibby 0097 - BW Limiter + QOS + Captive = No go.

Discussion in 'Tomato Firmware' started by fearz, Aug 17, 2012.

  1. fearz

    fearz Serious Server Member


    I am trying to create a guest wireless VLAN while limiting its bandwidth and also benefit from the Captive Portal..

    Guest VLAN lose internet access if 3 are enabled, after lots of trials, no matter what I do the 3 of them doesn't work together, only if I disable QOS, All is fine...

    Any ideas please?
  2. kthaddock

    kthaddock Network Guru Member

    Upgrade to 100V and test.
  3. fearz

    fearz Serious Server Member

    Are you telling me to try or you know it has been fixed?
  4. fearz

    fearz Serious Server Member

    + i've read that V100 is causing memory leaks / router restarts, so i was waiting for the next release...
  5. kthaddock

    kthaddock Network Guru Member

    There is always people reporting things not working with new releses. I'm using almost all fetures exept nocat and I have no problem and I haven't seen any memory leaks either. Test and make you own opinion.

    Btw Qos and Bw limiter dont work together in Shibbys builds, only Toastman.
  6. shibby20

    shibby20 Network Guru Member

    do not use BW limiter and QoS in the same time. You cant use two traffic manager!

    Memory leaks problem is only when you are using IPv6!
  7. fearz

    fearz Serious Server Member

    Ok, Shibby, thank you for supporting my case, here is what i've done:

    Updated to 101, cleared NVRAM< restored configs from 0097, disabled BW limiter, QOS & Captive enabled, I made a QOS classification called "Guests" configured only the inbound & outbound to 10%, created BR1 Virtual Wireless with DHCP, created a QOS classification of any IP using from will be classified as Guests...

    I set Captive Portal with Site Forwarding to google.com, after I click OK, Nothing happens...I close this window and start browsing, downloading at full speed as if the QOS rule do not exist.

    All I need to do is create a wirless guest network and limit its bandwidth, I am unable to do this with BW limiter + QOS enabled due to what i mentioned above and i am also unable to do it via QOS...

    Would you kindly support?
  8. shibby20

    shibby20 Network Guru Member

    1st) NEVER restore old config on newer version!! NEVER
    2nd) never use QoS and BW Limiter in the same time. This will not work on my tomato version.
    3rd) just make new bridge (br1), make new SSID (for guests) and bridge new SSID to br1. Then use BW Limiter and enable default class for br1. If you need Captive portal, then you can enable it only for br1 interface. BW Limiter will limit download bandwidth but will not (unfortunately) limit upload. I will not figure out how to fix this.
  9. fearz

    fearz Serious Server Member

    But Shibby..The issue is if i enable BW Limiter + Captive + QOS with the settings you just mentioned, there is no browsing when logged in to that guest wireless...just won't resolve anything...once i disable QOS...everything works...thats what im talking about..
  10. pharma

    pharma Network Guru Member

    While I don't think that is supported (BW Limiter + Captive + QOS) the way you are trying, you might try one of the other Mods. And do not restore your old config file ...:)
  11. Elfew

    Elfew Addicted to LI Member

    Dont restore your config file... set all by yourself.

    I use only BW for br1 (multiSSID), QoS is enabled and it works good
  12. fearz

    fearz Serious Server Member

    Ok here is what i did, i restored from zero, cleared nvram, didn't do any other settings than enable QOS, BW Limiter & Captive, created br1 as Shibby mentioned and configured BW limiter to BR1, i use the wireless guest, captive page appears, i click on OK i agree, nothing happens..no connection..i disabled Captive, it works! along with limter and QOS...if i enable Captive & BW limter and disable QOS..it works!

    something wrong with Captive + QOS enabled together...only either of them work with BW limiter...

    I'd highly appreciate your feedback Shibby or Elfew along with Captive enabled...

    Thanks a lot
  13. Elfew

    Elfew Addicted to LI Member

    I dont have any idea what is wrong.

    I use BW only for br1 (virtual wifi network) and captive portal for virtual network...

    QoS is enabled too, but it works good without problems... :(
  14. fearz

    fearz Serious Server Member

    Elfew, i'm supposed to be having the same setup...would you please explain and provide your exact settings?
  15. Elfew

    Elfew Addicted to LI Member

    ok, I use this settings from multiSSID

    after that I enabled BW only for br1 - I set there only 150kB/s upload/download
    after that I enabled Captive portal for br1 only - I set there default wepage etc
    after that I enabled QoS with settings from Toastman topic

    nothing more... it works good for me... I use AIO RT build 101 for ASUS RT-16n
  16. fearz

    fearz Serious Server Member

    I'd appreciate screenshots of your BW limiter & Captive pages....thanks a lot
  17. matt roberts

    matt roberts Serious Server Member

    very similar problem here too.
    using build tomato-E4200USB-NVRAM60K-1.28.RT-N5x-MIPSR2-101-Mega-VPN.bin

    To test the bug, i performed a 30-30-30 reset. flashed and 30-30-30 reset again.
    using all default settings (including open wifi)
    enabled captive portal.
    reboot router.

    Router worked as expspected clients could connect, accept the TOS, and browse the net.

    logged back into router, enabled QOS.
    reboot router.

    TOS not always being presented, acept button would not navigate away from TOS page, entering urls in address bar would eventually timeout.

    disabled QOS, reboot router all is fine.

    reneable QOS, disabled Captive portal. i believe QOS works as expected. Not fully sure how to test though?
  18. Toastman

    Toastman Super Moderator Staff Member Member

    When QOS is enabled, the iptables lines shown in blue are missing ...
  19. fearz

    fearz Serious Server Member

    EXCELLENT findings Toastman...Thanks a lot for this!

    Shibby, Would you kindly fix this in next release?
  20. teknowiz

    teknowiz Serious Server Member

    This issue still seems to be present with latest Shibby 102 build.
  21. fearz

    fearz Serious Server Member

    True, I really hope Shibby respond to us over here!
  22. Rogie Yangco

    Rogie Yangco Reformed Router Member

    Is there any fix for this? I'm running v116 and the problem is still there. Do we need to sacrifice one feature over the other?
  23. Elfew

    Elfew Addicted to LI Member

    Omg, you cannot use bw+qos together!!!!! Choise one of them
  24. Rogie Yangco

    Rogie Yangco Reformed Router Member

    Apologies. I didn't made my question clear. Im talking about QOS+NoCatSplash. I've found a workaround in the forum but it is still not working.
  25. Elfew

    Elfew Addicted to LI Member

    Nocat will be replaced by nodog in future (Victek wrote this). But I think this wont fix this issue. QoS is maintained by Toastman and other devs dont wanna touch to code because it is not their feature
  26. Magdiel1975

    Magdiel1975 Networkin' Nut Member

    I have v132 and Captive Portal is not working for me either while BW limiter is enabled :(

Share This Page