1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Shibby bittorrent transmission gui not working!

Discussion in 'Tomato Firmware' started by vite0150, Jun 20, 2014.

  1. vite0150

    vite0150 Network Newbie Member

    I have a Belkin F7D8302 with shibby 120 k26 USB bigVPN... The problem i have is that i can't access to the GUI... I enable usb, torrent client, GUI, save everything try to access to but the browser doesn't load anything, it shows the message "This webpage is not available"...

    So far i tried 2 browsers, reseting the router, clear nvram, authentication on and off, changed the gui listening port... even tried the BTgui VPN build, but nothing seems to work... Anyone knows if this feature is supported by this router? or if i need to enable/disable something else?

    Also i want to know if i can use the bittorrent feature without the GUI?

    Attached Files:

  2. leandroong

    leandroong Addicted to LI Member

    your transmission binary is set to "/opt/bin". this means that entware transmission optware must be installed.
    vite0150 likes this.
  3. vite0150

    vite0150 Network Newbie Member

    i followed this guide: http://tomatousb.org/tut:optware-installation
    but this command didn't work: chmod +x /tmp/optware-install.sh .... it says, no such file or directory
    The other 2 commands worked fine

    Also i want to know if i need to do what says in the "How optware integrates with TomatoUSB" section...
  4. leandroong

    leandroong Addicted to LI Member

    use script found on /usr/sbin:
    1.) for entware/optware, use "sh /usr/sbin/entware-install.sh"
    2.) for optware, use "sh /usr/sbin/optware-install.sh"

    1. make sure mounted usb harddisk is detected. ls /mnt/<harddisk label> should be present
    2. cd /mnt/<harddisk>
    3. mkdir /mnt/<harddisk>/opt
    4. mount -o bind /tmp/<harddisk>/optware/opt /opt
    5. cd /mnt/<harddisk>/opt
    6. install your optware, "sh /usr/sbin/optware-install.sh"
    7. update optware, "ipkg update" and "ipkg upgrade"
    8. install transmission, ipkg install transmission
    Last edited: Jun 21, 2014
    vite0150 likes this.
  5. vite0150

    vite0150 Network Newbie Member

    This is the method i used:

    wget http://tomatousb.org/local--files/tut:optware-installation/optware-install.sh -O - | tr -d '\r' > /tmp/optware-install.sh
    chmod +x /tmp/optware-install.sh
    sh /tmp/optware-install.sh
    The last line installed correctly optware (the 2nd line was the one that didn't do anything)...

    About your procedure:
    I don't know where or how to opkg update, opkg upgrade, i used this: "opkg update; opkg install transmission-daemon" but it didn't work...

    Would be nice if you have a link of a guide on how to do what you're saying...

    btw, on the guide i followed they suggest to partition the usb, so this is how it looks now:

    Attached Files:

  6. leandroong

    leandroong Addicted to LI Member

    Already included in the Shibby FW, no need to download.
    In your case, use "ipkg update" amd "ipkg upgrade" to upgrade optware.
    To install transmission, "ipkg install transmission"
    note: I forgot to mention that after creating partition you need to bind it.
    ex: mount -o bind /tmp/mnt/<harddisk label>/opt /opt. Then perform, cd /opt and install ipkg optware

    note: corrected my above mention procedures. Just follow it.
    Last edited: Jun 21, 2014
    vite0150 likes this.
  7. vite0150

    vite0150 Network Newbie Member

    looks like is working now!!!
    Thanks a lot!!
  8. remlei

    remlei Networkin' Nut Member

    Im using Entware build instead of Optware since Optware build Transmission frequently crash on me. If you experience it, just use Entware.

Share This Page