1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Shibby FW, Wireless ethernet bridge no internet

Discussion in 'Tomato Firmware' started by leandroong, Nov 22, 2012.

  1. leandroong

    leandroong Addicted to LI Member

    FW: Tomato Firmware 1.28.0000 MIPSR1-102 K26 USB AIO
    This use to be working before, can't remember version start failing. I tested from version 088 to 102, all giving no internet connect on client connected via lan port. Using router ping GUI also fails. Any idea what happens?
    Note: client is getting correct assign local IP and DNS.
     
  2. leandroong

    leandroong Addicted to LI Member

    1. Another problem, while in "WIRELESS ETHERNET BRIDGE MODE", wireless antenna cannot be disabled. It hungs and force me to reboot manually and router would always reboot with wireless enabled.
    2. Connecting wired lan from 2 routers, would not give internet as well. I would lose internet connectivity if I keep the wired connection for long because of conflict.

    This problem is happening only for router under "WIRELESS ETHERNET BRIDGE". No issue for router under "WIRELESS CLIENT".

    Can anyone investigate this matter? Something happen in the source code.
     
  3. shibby20

    shibby20 Network Guru Member

    if i will have some free time i will try to reproduce the problem. For now i haven`t time :/
     
  4. leandroong

    leandroong Addicted to LI Member

    Thanks !!!!
     
  5. leandroong

    leandroong Addicted to LI Member

  6. leandroong

    leandroong Addicted to LI Member

    @Shibby, I think I know where the conflict. There is LAN "Router MAC ADDRESS CONFLICT".
    Both having same MAC VALUE of "00:90:4C:C0:04:51".
    There is no way for me to change that in MAC GUI.
    I tried changing using putty and perform "nvram set...", "nvram commit" and "reboot". Problem, when router reboots it has same old MAC value.

    This is MAC bug. Hope you read this....
     
  7. leandroong

    leandroong Addicted to LI Member

    Solved !!! by following below procedures:
    1. nvram find macaddr
    et0macaddr=00:90:4c:c0:04:51 <=== LAN MAC address
    il0macaddr=00:90:4c:c1:04:51

    2. To change
    nvram set et0macaddr=08:10:74:85:0E:27
    nvram commit

    3. Reboot router

    Finally, my wireless ethernet bridge working fine. Able to make ping to main router and other websites. I still hope that Shibby would allow LAN MAC editable also in the GUI.
     
  8. chris kirby

    chris kirby Serious Server Member

    I am not able to get wireless bridging either working with shibby builds up to 105. Do you know if this MAC bug will be addressed in future builds of shibby? Im having to use dd-wrt for wireless bridges until it works in tomato. Thanks!
     
  9. leandroong

    leandroong Addicted to LI Member

    I'm using WIRELESS ETHERNET BRIDGE and no problem with internet, it plays internet radio well.....
    Note: check your setting:Routing->Mode=Router for it to function well.
    For MC issue, very easy to detect, compare LAN MAC address.
     
  10. chris kirby

    chris kirby Serious Server Member

    Leandroong, thanks for the reply.

    The wireless bridge mode works for a few minutes, then it will drop connection, and then resume randomly. I had Pandora streaming as a test and the music would come and go randomly. I also had a command prompt open constantly pinging google and also pinging the gateway on the lan. The ping would return in under 1ms and then request timed out.

    My gateway is 192.168.2.1 so I set the bridge to static IP of 192.168.2.2 with 192.168.2.1 as the Gateway and DNS. I also changed the Routing mode to ROUTER.

    As a test I used DD-WRT as the bridges and left Tomato as the Gateway. The same issue happened, however when I replaced the gateway with a DD-WRT router, the bridging worked flawlessy. It appears it is something with the gateway config and not the bridges, but it was a clean install of tomato with NVRAM cleared and only a static IP set.

    I was testing this with WPA2-AES and also with no Encryption. Encryption did not seem to be the issue as it happened with both.
     
  11. chris kirby

    chris kirby Serious Server Member

    just a bit more information. This issue started happening when I upgraded my routers to N routers (RT-N16 as gateway and RT-N12 B1 as bridges). Since the N mode requires WPA2 I upgraded to the Shibby/Toastman builds.

    The bridging USED to work flawlessly with B/G mixed mode routers with the original firmware downloaded from tomatousb.org with only WPA encryption.
     
  12. leandroong

    leandroong Addicted to LI Member

    Tomato Firmware 1.28.0000 MIPSR1-105 K26 USB BTgui-VPN
    ZTE ZXV10 H618B
    WPA2 Personal (AES)
    Wireless network: G only

    Note: ISP modem connected directly to main router.
    No problem, playing internet radios for almost 18hrs everyday.
     
  13. chris kirby

    chris kirby Serious Server Member

    I have my wireless mode set to MIXED since I have N and G devices (but no A or B devices). Do you think it could be an issue with N? I know with DD-WRT there is a N/G Mixed mode but with Tomato it looks like N only or Mixed (A/B/G/N).
     
  14. chris kirby

    chris kirby Serious Server Member

    This issue seems to be resolved. I'm not certain but I am pretty sure it was related to an 8 port gigabit switch I had plugged into the gateway router. After replacing the gateway and the 2 bridges is when I noticed the bridges not working (dropping packets randomly).

    I unplugged the 8 port switch and let it sit for a good while. After plugging it back in, everything seems to be working fine. The only thing I can think of is the switch's ARP table still had the MAC addresses of the old gateway and two bridges assigned to the 192.168.2.1 (gateway), 192.168.2.2 (bridge1), and 192.168.2.3 (bridge 2).

    I have been streaming Pandora now for over 45 minutes without any issues.

    I also tested the N mode for the bridges and N speeds do work in Bridge mode.

    Thank you guys!
     
  15. chris kirby

    chris kirby Serious Server Member

    I seemed to jump the gun saying this was working. It WAS working well for a good while, then all of a sudden, pings started dropping again. BUT, I noticed pings were also dropping from a Laptop to the Gateway (wireless) which tells me the issue may not be with the bridges after all, but something with the gateway wireless.

    I tried changing channels, changing from 40Mhz to 20Mhz, changed the antenna wattage from 17 to 60 and even down to 5, all with the same results. Wireless connections pinging the gateway will randomly "request timed out".

    I did notice that in the status page on the gateway the INTERFERENCE level would go from "ACCEPTABLE" to "SEVERE". Channel 6 seemed to give me the best results but every now and then it will go back to SEVERE.

    Could the antenna's from the multiple wireless bridges be interfering with the main antenna on the gateway? From my understand all of the bridges and the gateway must be on the same channel.

    Any help would be greatly appreciated.
     
  16. Herb Radford

    Herb Radford Network Newbie Member

    I'm trying to set up an RT-N66U with Shibby v136 to my main router running Shibby v135 by using wireless client mode (on the RT-N66U). This is in preparation for helping my daughter do the same thing for a small operation which has wireless supplied by the building owner. I can get the RT-N66U up and connected to my main router. Now the problem is that I do NOT have access to the internet. What could be the possible cause(s) for nothing passing through the connection?? I have done this some years ago witth no issues, but not this time.
    The reason for wireless client is that there is sensitive information on the RT-N66U side that must be protected from the host network so bridged mode is not acceptable.

    Herb
     

Share This Page