1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Shibby mod Media Server setup help

Discussion in 'Tomato Firmware' started by CCRS8, Nov 24, 2013.

  1. CCRS8

    CCRS8 Reformed Router Member

    I have been using Shibby mod on my Asus RT-N16 for a few years. Works great - love it!

    I have a USB hard drive connected to the router that I have been using as a central media storage drive for some time. Using "File Sharing" I have been able to connect to the drive from Windows, GNU/Linux, and Android. But now I'd like to be able to connect to the media with my Roku player, and the best way I could find to do that is to use the Roku app "Roksbox" and a media server. Since shibby mod has a media server (miniDLNA) I figured it would not be a problem.

    I enabled the media server, set it to port 8200, set a custom database location, set a media directory to point to my videos, and scanned for media. It seemed to have worked. If I go to http://192.168.1.1:8200 I get the miniDLNA status page and it shows the correct count of media files in each category. However, that's where I am right now. I can't figure out how to actually access my files with Roksbox or any DLNA-compatible client. If I try to navigate to the media directory in my browser, I keep on getting "not found" errors. Same in the DLNA client itself - I can't figure out what to put for my media folders in order to reach the files. Am I missing something?

    In the "Attached Devices" of the USB Support section, I have the following:
    "Partition 'Lacie' ext3 (229.23 GB / 204.45 GB free) is mounted on /tmp/mnt/Lacie"

    On my USB drive I have a folder called "roku" where I am putting the movie files I want to access. I have a folder called minidlna_db where I have the database file.

    In the Media Server section, I have /mnt/Lacie/minidlna_db in the custom path for the database location. After scanning for files, there is a .db file in that directory.

    In the Media Directories section, I have /mnt/Lacie/roku as the Directory, set to scan Video only.

    Any help is greatly appreciated. I really think I have things set up correctly so far, I simply don't know what to enter from here.
     

Share This Page