1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Shibby v105 for RT-N16 breaks WDS?

Discussion in 'Tomato Firmware' started by MatinatorX, Jan 31, 2013.

  1. MatinatorX

    MatinatorX Serious Server Member

    First of all, being a new member, I'd just like to say hello and thank all the developers for their hard work. The things they share with us for free are nothing short of amazing. Thank you!

    I'll readily admit I'm new to Tomato and custom firmware in general. I did a search and tried a few basic things but couldn't come up with any answers. Anyways, I've been running three RT-16N's connected to each other through WDS for a month now, all running Shibby K26USB-1.28.RT-MIPSR2-104-AIO. Today I noticed v105 and v105.1 had been released with the promise of speeding up boot times, which has been my only gripe with the setup so far. I upgraded each router through the WebGUI (saving my main router until last), and then double checked the setting on my main router to make sure nothing funny happened.

    After pouring through all the pages, I noticed that the other two routers no longer showed up in the Device List. Wds0.1 and Wds0.2 were still listed with signal information and transfer speed, however I couldn't get any response by ping or otherwise. Connecting to these routers via a wired connection to a laptop (with a static IP of course) and browsing the configuration showed that it hadn't changed at all.

    I reread the changelog for v105.1 and didn't see anything I figured was relevant, so I backed up the configuration for all three routers and tried setting up the WDS again. This met with zero success, so I restored my settings and downgraded each router back to v104. I waited around 10 minutes for the routers to do their thing, and lo and behold, everything worked again! I went through the steps above again with v105 and had the exact same problem, so I have to wonder if something changed between v104 and v105 to break WDS.

    I'm hoping someone can tell me if I missed something obvious, like if I should have cleared the nvram and started from scratch, or if I really have run into a bug. I'll post any additional information requested if I know how to find it. It's not a dealbreaker of course, but it really would be nice to have the reduced boot time along with a working WDS setup. Any help on the matter would be much appreciated!
  2. MatinatorX

    MatinatorX Serious Server Member

    After getting frustrated I re-flashed all the routers, cleared the nvram and configured absolutely everything from scratch. That, combined with enabling STP on each router, fixed all my communications problems. As this post is pretty useless now, if you happen to be a mod, would you kindly delete this thread for me? Much appreciated!

Share This Page