1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

(shibby1.28) Does more than one hostname for same device in Static DHCP work for you?

Discussion in 'Tomato Firmware' started by lsi235e, May 27, 2012.

  1. lsi235e

    lsi235e Networkin' Nut Member

    On the Static DHCP/ARP/IPT page it says "To specify multiple hostnames for a device, separate them with spaces.".

    When I do this and test it only the first hostname is pingable/accessible? I have tried rebooting the router.

    Does this functionality work? Is there any other method of giving an IP address multiple hostnames on the router?

    I am currently adding entries like below to the hosts file but this is needed for every machine on network so if I could specify these in the router it would be great? name1 name2 name3 name4

    Using Version 1.28 by shibby on a Asus RT-N16.

  2. kthaddock

    kthaddock Network Guru Member

    Have you tried: name1 name2 name3 name4
  3. mvsgeek

    mvsgeek Addicted to LI Member

    It's working as expected on my "test" RT-N16 with the Toastman build in my sig. Toastman page is slightly different - DHCP/ARP/BW vs. DHCP/ARP/IPT.
  4. lsi235e

    lsi235e Networkin' Nut Member

    Yes in the GUI I enter the hostnames with spaces between. I save the settings.

    I then using a win7 machine on the network not the one the hostnames resolve to I try to ping the first hostname this works fine.

    When I try to ping the second hostname it does not work.

    If I nslookup and then type the second hostname it does return the correct IP address!!!!

    Why is nslookup seemingly working but when I ping or use the hostname in any other way it does not work?

    Can anyone running shibby try adding another hostname and seeing if they can ping it?


    Sent from my Blade using Tapatalk 2
  5. lissny

    lissny Networkin' Nut Member

    Can any body make Quota management system.. because data is accounted already.. just condition on that limit..
  6. lsi235e

    lsi235e Networkin' Nut Member

    I have changed to Toastman 1.28.7498.1 but I still can't get the multiple hostnames working. In the DHCP/ARP/BW section I add a MAC address and IP address and two hostnames separated by a space. The first hostname works fine. If I nslookup on a machine on the network it returns the correct IP address but if I ping hostname2 it does not work it says request can't find the host.

    Does anyone have any further suggestions?

  7. kthaddock

    kthaddock Network Guru Member

    I have tested with two hostname and it's pingable. If I set 3 and 4 it doesn't work.
    Don't know how many hostname is allowed in this builds.
    Toastmans 0498.1 build.
  8. mvsgeek

    mvsgeek Addicted to LI Member

    I added an IP address and 7 hostnames - "one" thru "seven", left the MAC address blank.
    NVRAM shows :

    dhcpd_static=00:00:00:00:00:00<<one two three four five six seven<0>
    dhcpd_static_only=0 is a cat5-connected Win 7 PC.

    From 2 different wireless-connected Win XP PC's, I can ping all 7 hostnames ("one" thru "seven").

    The pings were not 100% reliable until after a router reboot - sometimes I'd get "host not found" - but since rebooting it's all working as desired.
  9. lsi235e

    lsi235e Networkin' Nut Member

    Putting them separate in the list does not help either. What could be wrong with my network that causes this? It resolves to the correct IP address if I query the DNS using nslookup why isn't ping or anything else resolving the hostname? Thanks.
  10. mvsgeek

    mvsgeek Addicted to LI Member

    I just upgraded my "test" main to tomato-K26USB-1.28.7498.1MIPSR2-Toastman-RT-Ext.trx and everything still works.

    I also added a MAC address, as well as an IP - still good:)
    Sorry, I just don't seem able to break it:-(
    Is your PC configured for DHCP or static? If static, is the DNS server set to the router's IP?
  11. lsi235e

    lsi235e Networkin' Nut Member

    Thanks for help. I am on Automatic Settings. When I do a ipconfig the gateway is set to my router ip address.

    After an afternoon of searching Google it appears if a append a period to the end of my additional hostnames I can ping them correctly.

    Do you know what I may have in my setup which means I have to add this period and on your setup it appears to work fine?

    What do you have in Basic - Identification?


    (windows 7, asus rt-16, toastman 7498.1)
  12. mvsgeek

    mvsgeek Addicted to LI Member

    Aha! I believe you have nailed it:)

    Router name : abc451
    Hostname : abc451
    Domain: abc

    When the domain is blank, the ping fails. But why does it work for some, but not all of the host names? I will research this further later this evening, but right now SWMBO has dinner plans!
  13. lsi235e

    lsi235e Networkin' Nut Member

    Unfortunately adding a domain on the router has not helped with the problem.

    I have added my domain to the Advanced DNS Properties Add Domain Suffix option and that fixes it as far as all the Windows machines need this option adding. I guess it is better than configuring a hosts file.

    If you do not specify a domain in the router setup you can just add a period in the domain suffix option and the same result applies.
  14. Gagan

    Gagan New Member Member

    Good day,
    I am new in networking,
    It would be great help, if you could advice me below matter.

    I have bought Netgear WNR3500LV2 and flash with Tomato open source firmware,
    It is working perfectly, but we have 30 users,
    Is it possible that i can set data limit (limit quota) 2GB per user in router.
    appreciate ur help in advance .

Share This Page