1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Shibby's v121-extras :Unknown symbol errors

Discussion in 'Tomato Firmware' started by jenom, Sep 7, 2014.

  1. jenom

    jenom Networkin' Nut Member

    Using Shibby' s latest K26RT-N/build5x-121-EN/extras-mips2.tar.gz
    and with Entware when I try to do load extra sound related modules:

    insmod /opt/extras/soundcore
    insmod /opt/extras/snd
    insmod /opt/extras/snd-hwdep
    insmod /opt/extras/snd-page-alloc
    insmod /opt/extras/snd-timer
    insmod /opt/extras/snd-pcm
    insmod /opt/extras/snd-seq-device
    insmod /opt/extras/snd-seq
    insmod /opt/extras/snd-rawmidi
    insmod /opt/extras/snd-seq-midi-event
    insmod /opt/extras/snd-seq-midi
    insmod /opt/extras/snd-mixer-oss
    insmod /opt/extras/snd-pcm-oss
    insmod /opt/extras/snd-usb-lib
    insmod /opt/extras/snd-usb-audio
    insmod /opt/extras/input-core
    insmod /opt/extras/hid
    insmod /opt/extras/usbhid

    I am getting these errors:

    snd_page_alloc: Unknown symbol mem_section
    snd_pcm: Unknown symbol snd_dma_reserve_buf
    snd_pcm: Unknown symbol snd_dma_free_pages
    snd_pcm: Unknown symbol mem_section
    snd_pcm: Unknown symbol snd_malloc_pages
    snd_pcm: Unknown symbol snd_dma_get_reserved_buf
    snd_pcm: Unknown symbol snd_dma_alloc_pages
    snd_pcm: Unknown symbol snd_free_pages
    snd_pcm_oss: Unknown symbol snd_pcm_lib_read
    snd_pcm_oss: Unknown symbol snd_pcm_hw_param_first
    snd_pcm_oss: Unknown symbol snd_pcm_kernel_ioctl
    snd_pcm_oss: Unknown symbol snd_pcm_format_unsigned
    snd_pcm_oss: Unknown symbol _snd_pcm_hw_params_any
    snd_pcm_oss: Unknown symbol snd_interval_refine

    This procedure worked fine with earlier Shibby's version,
    I am thinking maybe something wrong with the EXTRAS package or
    maybe it just did not get updated to the latest firmware?

    Has anybody used this v121 EXTRA package succesfully ?

    Thanks!
     
  2. jenom

    jenom Networkin' Nut Member

    I have a dual band router and in the past always used the K26-RT-N-5X version, although I disabled the 5 ghz band.This time,more sensefully, just got the K26 firmware.
    Of course, I forget about this, and used the Extras from the RT-N-5x
    The Extras package also does not have any version marked in their name, all versions called: Extras
    Got the correct one from K26 section,and now there are no errors.
    Conclusion: Extras must come from a same built, or it will not work !
     

Share This Page