1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Site Update - Security

Discussion in 'General Discussion' started by Toxic, Jul 7, 2005.

  1. Toxic

    Toxic Administrator Staff Member

    Updated Nuke Sentinel to 2.3.1

    Since 23rd June 2005 we have had 39 or so Hacks on this site (inc one Denial of Service) to gain superadmin/god admin status. there is only one reason that such actions against this site are done and this is to deface or bring down Linksysinfo.org

    Malicious Attacks on LI will not be tolerated. IPs will be banned Permanently.

    We will be trying to keep upto date with any Security Patches that we can get hold of.
     
  2. Morpheus

    Morpheus Network Guru Member

    Good Job Simon.
     
  3. Toxic

    Toxic Administrator Staff Member

    Now updated to Nuke Sentinel 2.3.2

    New Features:
    + Re-ordered the lang file to prevent Undefined error.
    + ChatServ updates to replace $x == "" to empty($x) in many locations.
    + Updated Edit Instructions (Includes updates by ChatServ for Patched 3.1).
    + Moved import directory out of the admin directory structure so it can be deleted after importing data easier.
    + Added routines to check range database table for overlaps.
    + Updated import data (ip2country data from the NukeSecripts site).
    + NEW Flood Protection on GET and POST requests. (Thanks to Manuel).
    + Added global for SERVER_ADDR as $nsnst_const['server_ip'] . Can be useful in other scripts for check if the request comes from your server or from a client.
     

Share This Page