1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Slow .html file transfers to an NSLU2

Discussion in 'General Discussion' started by Anonymous, Nov 22, 2005.

  1. Anonymous

    Anonymous Guest

    I've been having lots of problems with slow connection establishment to an NSLU2 from various Windows XP boxes. Eventually I isolated a simple example that seemed to illustrate the problem (or at least one of them). I try to copy a text file from the XP machine to the NSLU2 via an explorer window on the mapped drive. The copy is almost instantaneous. Furthermore, I can delete the file from the window just as quickly. I then rename the file to have a .html extension, and try the copy again. This time the copy takes about 45 seconds for the icon to appear in the window. And deleting the file takes just as long. Repeating this experiment on other mapped drives to other windows machines works fine. I can't figure out if this is a problem with the NSLU2, or just that it shows up a problem elsewhere in my system. Can anyone shed any light on this bizarre behaviour. By the way, I've got V2.3R63 firmware on the linksys, and XP/Pro SP2 on the windows boxes.

    Thanks, Kevin
  2. Anonymous

    Anonymous Guest

    Found the problem. The gateway address wasn't set, and this was causing the NSLU2 to generate a bunch of ARP requests part-way through the file copy. Although why it was doing this for files with a .html extension but not for other files is still a mystery. Anyway, I set the gateway address correctly and the problem goes away.

Share This Page