1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Slow LAN transfer speed (1MB/s)

Discussion in 'Tomato Firmware' started by maple.chick, Feb 7, 2012.

  1. maple.chick

    maple.chick Networkin' Nut Member

    I'm trying to transfer some files over the LAN and the speeds I'm getting are absolutely dismal. I just can't go over 1.1 MB/s on LAN. I'm not even downloading anything or browsing the internet, oddly enough my WLAN hits 2.5MB/s normally.

    I'm running Toastman release 1.28.7632.2 on WRT54G-TM (250 Mhz) with QoS enabled. Should I upgrade to 1.28.7632.3? What maybe causing this slowdown? Is it Q0S?

    Network setup:
    - ISP Router/Gateway:
    - WRT54G-TM:
    - Two computers and are connected via LAN to WRT54G-TM. (These are the two computers where I'm transferring files.)
    - The rest of the devices all connects via wireless.
  2. Porter

    Porter LI Guru Member

    The most simple explanation would be that one of your ethernet devices is just communicating over a 10MBit interface. If those clients are using windows you need to go find the adapter settings and display the status of the connection. There you should find the bandwidth at which it es operating.
    maple.chick likes this.
  3. maple.chick

    maple.chick Networkin' Nut Member

    ^^ You are right. One of the computer is connected at 10Mbps. This computer has a gigabit interface, Atheros AR8131, and I'm running Windows 7 64-bit. Any ideas how do I correct this problem?

    I'm connecting to the router with a 6-ft CAT5e cable.
  4. Porter

    Porter LI Guru Member

    Reboot the computer. :)
    Reboot the wrt54.

    Apart from that:
    Use another cable of the same type.
    Connect to a different ethernet port on the wrt54 (one of the ports on the router could be faulty).
    The ethernet port on the computer could be faulty.

    Update the drivers, although I'm quite sure windows 7 uses drivers that are ok.

    That's all that comes to my mind right now. For the rest there is google. If it seems to be Tomato related please report back!
  5. maple.chick

    maple.chick Networkin' Nut Member

    Well I just forced a '100Mbps Full Duplex' connection and it seemed to have worked. I'm now transferring files at 12 MB/s.

    Still not sure what caused this problem as the cable and ethernet port on the router is still the same.

    Thank you kindly for your help, Porter.
  6. Porter

    Porter LI Guru Member

    You're welcome. :)

Share This Page