1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

slow wireless on new WRT54G v3

Discussion in 'Cisco/Linksys Wireless Routers' started by reebok, May 14, 2005.

  1. reebok

    reebok Network Guru Member

    just yesterday I started having extremely slow wireless speeds on my 2 week old WRT54G. it was fine before, but now I can't get over 10-14K/s on either local file transferring or on the local isp speedtest site. if I plug in my old wireless router, it works as it should, which leads me to believe it's not a wireless card or OS issue. (smc2435w wireless card)
    I've tried linksys official, linksys beta 4.0.07 or whatever and talisman, along with many resets, factory defaults, power cycles, etc. I contacted linksys support but they only advised changing a few wireless values (fragmentation and rts thresholds, as well as beacon interval) which made no difference.
    my wired desktop works fine, as does my wireless laptop if I plug an ethernet cable into and use it wired.
    network setup: cable (moto surfboard 5100) - WRT54G v3 - PC's and RT31P2 (vonage adapter). the laptop is no more than a few feet away, and both XP and netstumbler show a full signal. as I said, it's worked fine before, no idea what has changed.
  2. aaronamd

    aaronamd Network Guru Member

    maybe try a Loooooooooooooooong reset? sometimes the WRT54G will need one after a new firmware flash, try holding down the reset buttom for 30 secounds.
  3. reebok

    reebok Network Guru Member

    I didn't specify but all my resets were 30 seconds, and there have been many of them.
  4. Turbopower67

    Turbopower67 Network Guru Member

    Same problem for me, even after installing the latest Linksys firmware and full factory reset.

    Any idea ??
  5. aaronamd

    aaronamd Network Guru Member

    have you tried changing the default ssid?
  6. reebok

    reebok Network Guru Member

    not sure how that would affect it but I tried it with no change.
  7. aaronamd

    aaronamd Network Guru Member

    somtimes when there are alot of wireless networks with the defualt ssid then the adapter can get confused as to wich one is was and is connected to, I thought that maybe that was it, I guess not.
  8. Toxic

    Toxic Administrator Staff Member

    try enabling Frame Burst in wirless settings.

    whats the signal strength like?
  9. reebok

    reebok Network Guru Member

    still the same
    signal strength is fine, I have a small house and besides it's less than 3 feet away. signal strength is excellent according to xp and netstumbler has it in the high 90's.
    here is my sequence of events which may have screwed it:

    running talisman come to this site, find beta linksys fw's. restore factory defaults. upgrade to high clock beta .7. read more about it and decide to change to low/normal clock v.7.

    I'm pretty sure the problem came up somewhere in there, but not positive. I also had issues like a few other people with the cisco button flashing, etc, and am wondering if that had something to do with it. I doubt it now though, because they don't seem related, plus I've played with it a lot this morning to no avail.
  10. reebok

    reebok Network Guru Member

    well I guess this is user error in my case. I turned off some obscure option in the advanced properties of my wireless nic. 4xAck emulation or some nonsense. I have no idea what/why/where/when/who or how, but the problem is solved now. thanks for the replies.
  11. gregorian

    gregorian Network Guru Member

    once i tinkered with my beacon interval setting and it really influenced the wireless throughput. default value of 100 is fine did you try that?

Share This Page