1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

(Solved) D-Link DIR-868L A1 Stuck in Recovery Mode

Discussion in 'Tomato Firmware' started by Kanuki, Apr 21, 2016.

  1. Kanuki

    Kanuki Serious Server Member

    Hi..

    I just received my DIR-868L A1 a few days ago.

    After I that I flashed it with Shibby's Build 136
    and installed entware and transmission.

    It was working fine for a while until I made some
    script modification and restarted the router then
    it can't bootup anymore.

    - Power LED flashing Orange
    - can ping 192.168.0.1
    - Stuck in Recovery Mode
    - Tried to Flash every version of stock firmware, DD-WRT, and Shibby
    still stuck in Recovery Mode
     
  2. Kanuki

    Kanuki Serious Server Member

    Can anyone guide me how to recover it using Serial cable?

    T_T
     
  3. apvmtan

    apvmtan Reformed Router Member

    Did you try Dlink emergency mode?

    1) Set your computer's ip manually to: 192.168.0.X (not 1) AND set your subnet mask to 255.255.255.0. (Auto IP will NOT work).
    2) Connect Ethernet cable between router and your computer. (Wireless won’t work)
    3) Unplug the power cable to the router
    4) Press the reset button and plug in the power cable when the power led flashes orange (about 15 seconds) release the reset. Go to 192.168.0.1. You will see the emergency mode upgrade screen in the browser
    5)You can upload only Dlink factory image. Download Dlink factory image from Dlink support
    6) Upload dlink firmware and wait at-least couple of minutes. The orange button should stop flashing and the router will reboot.
     
    Kanuki likes this.
  4. Kanuki

    Kanuki Serious Server Member

    Yup...

    No matter what firmware I flashed, it still stuck in Recovery Mode (Emergency Mode).
     
  5. AndreDVJ

    AndreDVJ Addicted to LI Member

    When I bricked my router (Netgear R7000), I had to flash Genie back (using a USB-TTL cable to initiate tftpd).

    After flashed, the router refused to continue to boot as nvram variables were left in a state of mess (to Genie).

    All I had to do, is to press the reset button for 10s or so. Genie recognized and resetted to default settings on its own, and rebooted the router automatically.

    You may need to push the reset button.

    Otherwise, you'll need a USB-TTL cable.
     
    Kanuki likes this.
  6. Kanuki

    Kanuki Serious Server Member

    Thanks... I managed to solve it by using USB-TTL cable to
    issue nvram erase command.

    I had struggling with connecting USB-TTL cable to JTAG
    a little bit because either Online JTAG connector inside
    DIR-868L guide or Cable Guide labeled RT/TX wrongly.
    (RX labeled TX and TX labeled as RX -_-").

    P.S. Reset button did not work in my case.
     
    AndreDVJ likes this.
  7. xavier66

    xavier66 New Member Member

    Hello,

    I have the same issue, can you please help me with the jtag connection (what PINs, what voltage) ?

    Thanks a lot
     
  8. herfes

    herfes New Member Member

    Could you give us more information for solve same problem?
     

Share This Page