[SOLVED] (warning: WL driver reports BSSID 00:00:00:00:00:00)

Discussion in 'Tomato Firmware' started by blackjackel, May 3, 2014.

  1. blackjackel

    blackjackel LI Guru Member

    Tomato Firmware 1.28.0000 MIPSR2-117 K26AC USB AIO-64K

    Asus RT-AC66U

    Virtual Wireless Interfaces list:

    eth1 (wl0)Yes<name1>Access PointLAN (br0)
    eth2 (wl1)Yes<name2>
    Access PointLAN (br0)
    Access PointLAN1 (br1)
    Access PointLAN (br0)

    Wondering if I stumbled upon another bug, i cannot see the wl0.2 network on any devices, and under the virtual wirless interfaces page everything looks normal except for the mac addresses line:

    MAC Address62:A4:4C:XX:XX:XX (warning: WL driver reports BSSID 00:00:00:00:00:00)

    I edited the mac address with XX's but it's a normal mac address.

    When I set the guest wifi network to wl1.1, problem is gone and am able to see the network, and no BSSID warning error.

    Question: If I have it on wl1.1, does this mean I'm using the 5ghz radio for this SSID?
  2. blackjackel

    blackjackel LI Guru Member

    I wish I had the ability to delete threads because I end up solving the problems minutes after posting. I take my time before I ever post here, at least 30 minutes before I ask about what's going on. So it's really a coincidence that I'm solving this minutes after posting.

    I solved the problem by going into mac addresses, then randomizing the mac address for that network, then setting it back to default, that SEEMED to have done the trick.

    I also added a wl1.1 network by the same name and password, then deleted it, then added it again. I don't think this was the part that helped fix it but I'm including it just in case this had something to do with fixing it.
  3. Quad5Ny

    Quad5Ny Networkin' Nut Member

    Thats a good thing. Anyone that has the same problem and comes across your thread from Google will now have a answer. Don't feel stupid about answering your own question. ;)
    Toastman and koitsu like this.
  4. mpegmaster

    mpegmaster Addicted to LI Member

    +1 What Quad5Ny said... :cool:
  5. tcwxx

    tcwxx Network Newbie Member

    Sorry to resurrect an old thread, but I registered just to say this helped me today. I have an RT-N66U and was getting the same error after creating four guest wifi networks at once (wl0.1, wl0.2, wl1.1, wl1.2). I was getting the same error and your post led me to check the MAC addresses in that section; well, it turned out it had created a duplicate MAC address (I think the MAC for the wl1.1 virtual interface was the same as the one for the wl0 physical interface). I deleted all of the virtual WLANs and rebuilt them one at a time (rebooting in between each).

    I suppose that's technically a bug with the Shibby build I was using (link), but going one at a time fixed my issue.

    For good measure, before I created the virtual WLANs again, I changed my router firmware to Shibby's SDK5 build (I was using his SDK6 version) and wiped the nvram. I don't think that part made the difference, but I'm posting it just in case.
  6. segacorpceo

    segacorpceo Network Newbie Member

    I seemed to have fixed the 2.4ghz network not showing up on my
    Asus RT-AC56U by changing the region in my case going from singapore to united states. Will there be a fix in the future for the led status lights that don't work?
  7. Incidentflux

    Incidentflux LI Guru Member

    None of this worked in my case with E2500v1_MIPSR2-138_K26_USB_Max (Shibby).
  8. Incidentflux

    Incidentflux LI Guru Member

    So I resolved this blank MAC address issue, not sure what fixed it, was it deleting and re-building VLANs, defaulting VLAN MAC address after re-build or changing country in wireless to USA.
  9. someburner

    someburner New Member Member

    For me it none of that fixed. In my case it appears to be missing mac for "lan1_hwaddr". It was missing completely from my "bad" nvram, compared to a good dump I had from earlier. There were a few other settings I swapped in but shortly after that one my vif came up on its own and remained after reboot.
  10. Techie007

    Techie007 Serious Server Member

    Tomato has a bug where if you create multiple virtual WiFi networks, the higher numbered ones don't work unless they have a MAC address similar to the first virtual network. Basically:

    wl0 can have any MAC address.
    wl0.1 can have any MAC address.
    wl0.2 can only have a MAC address similar to wl0.1
    wl0.3 can only have a MAC address similar to wl0.1

    Using a non-similar MAC address for wl0.2 or wl0.3 will cause them to quit working and report a MAC address of 00:00:00:00:00:00.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice