1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

*Solved* WRT54G v3.1 and Bit Torrent problems

Discussion in 'Cisco/Linksys Wireless Routers' started by makan, Nov 4, 2005.

  1. makan

    makan Network Guru Member

    Hi!
    I have a problem with my wireless LAN.
    I have a WRT53G v3.1 with the Wireless Network Monitor v.4.2 and the original firmware. On my computer I've got a WUSB54G with the latest drivers. It works like a charm, that is, until I start downloading something with bit torrent. I keep losing my internet connection, and it happens at a random time pattern. I can download without problems for an hour or more (not so often), or the connection drops after five to twenty minutes (more often).
    I then have to Repair the connection via the Windows Wireless Network Connection.
    There are no portable phones in the house, and I have changed the channel to 1, as my neighbour uses 11.
    Normal surfing, no problems, and the same with Skype.
    Any ideas? Do I have to configure something particular in the router that will makes bit torrent more stable?

    Oh, also, I tried to upgrade the firmware in the router, but it wouldn't let me. It kept saying No Contact With The Server, or something.

    Thanks for any help! :)

    Edit: Fixed it! I finally got the firmware upgraded to the latest version, and then I turned off the SPI firewall. So it's one or both of those changes that took care of my problem.
     
  2. danielhaden

    danielhaden Network Guru Member

    The latest versions of HyperWRT have "frequent TCP cleanup" There's also a startup script you can use on Linksys firmware too. I forgot what it was, but it is in one of the stickies over at the forums of hyperwrt.org.
     

Share This Page