1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSH and Thibor 13a

Discussion in 'HyperWRT Firmware' started by kop48, Feb 2, 2006.

  1. kop48

    kop48 Network Guru Member

    hey, quick question:

    I've upgraded my GSv4 to Thibor 13a and am trying to get my SSH to work. I've got SSH turned on in the remote section of my administration page and I can connect to the port, but it doesn't accept my password.

    I definitely think I'm doing something wrong, but I'm at a loss as to what. Any ideas? :)

    Cheers.
     
  2. dvaskelis

    dvaskelis Network Guru Member

    Don't forget you're logging in as root, not as blank.

    If you authenticate with a public key on the router, and the private key on your client doesn't have a password, you can log in without a password.
     
  3. Thibor

    Thibor Super Moderator Staff Member Member

    there isn't a user prompt, only a password. if you enable password login, the password is the same one you use to enter the web interface(admin is default). reboot your router after enabling SSH and password login
     
  4. dvaskelis

    dvaskelis Network Guru Member

    To root or not to root?

    Well, I get slightly different behavior than you describe. Connecting with PuTTY prompts with:

    "login as:"

    I need to respond with "root" for it to work, or put "root" in PuTTY's auto-login username field.

    Same behavior with either password login, or authenticated key login. Thibor 13a with WRT54GS v1.0 CGN1, and acted like this since Thibor firmware added sshd/dropbear.
     
  5. Thibor

    Thibor Super Moderator Staff Member Member

    ahh that would be correct, i use "ssh -l root 192.168.1.1" in linux. forgot about PuTTY.
     
  6. kop48

    kop48 Network Guru Member

    ok, to recap:
    login as root, password same as your web GUI?
     
  7. bcat

    bcat Network Guru Member

    Yep, that should work.
     
  8. kop48

    kop48 Network Guru Member

    No luck - it accepts password and username, then terminates the connection straight away. :(
     

Share This Page