1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange Ethernet Bridge Issue on WRT54G

Discussion in 'Tomato Firmware' started by fizix, Mar 28, 2008.

  1. fizix

    fizix Addicted to LI Member

    First of all, since this is my first post: Hi!

    OK, I've got a WRT54G flashed with Tomato 1.17 firmware. I've set it up as a wireless ethernet bridge to my main router. The gateway is set to the IP of my main router and the static DNS fields are all

    I can ping from the WRT54G to my main router and a PC connected to the WRT54G can access the configuration page for the WRT54G, get to the internet, and ping the main router. Here's my issue:

    No PCs connected to the main router can ping the WRT54G or the PC connected to the WRT54G. I also cannot access the configuration page of the WRT54G from any other PCs connected to the main router. Has anyone else ever seen anything like this?

    It's causing me issues because I want to be able to connect an ethernet based laser printer to the WRT54G but when I do, nobody can reach it even though it's getting an address through DHCP.
  2. TexasFlood

    TexasFlood Network Guru Member

    My main router is a WRT54G v2 with a couple of Motorola WR850G V2/3 attached via WDS, working fine. I just tried to reconfigure one of my WR850G units to "wireless ethernet bridge" mode so I could comment on the subject but could not seem to get it to work at all. It's probably a simple fundamental mistake on my side but I just can't see it. Don't see any evidence of a connection from either router so back to WDS for now. Sorry, wish I could have helped.

    *Edit* Well, I still don't know exactly what was wrong but got it working. In fact, I'm typing through it right now. I wondered if there was some setting from my WDS configuration left over that was causing it not to work. I tried editing some of the settings, like removing WDS MAC addresses, etc, but didn't help. So, after making sure I had a good backup of my current working WDS configuration, I cleared nvram back to factory then just re-entered the critical settings, router address, default gateway & DHCP, SSID, channel, security... Then I saved it and all is now well, working like a charm, no problems getting from either side of the router to the other. And yes, I could get to a laser printer attached to it via a Netgear USB print server. Same approach may work for you, not sure, something to try.
  3. fizix

    fizix Addicted to LI Member

    Thanks for the reply. Maybe I just need to try to clear the nvram, redo the settings, and try again. I'll let you know what happens!
  4. K1nslayer

    K1nslayer LI Guru Member

    Use "Router" mode. Not "Gateway"

    Make sure that you have /Advanced/Routing/Mode set to "Router" Not "Gateway"
    Also make sure that you fill in the address of your real Gateway in /Basic/Network/Default Gateway.

    These are both common errors that cause an ethernet wireless bridge to not work as expected.

  5. fizix

    fizix Addicted to LI Member

    I got it! Wireless isolation was turned on (on the main router) and preventing any wireless clients from talking to each other. Oops! Thanks for all your help!
  6. Kiwi8

    Kiwi8 LI Guru Member

    I dun think this is the problem. I have both routers set to Gateway when using Wireless Ethernet Bridge and it still works.

Share This Page