1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange wifi issue

Discussion in 'Networking Issues' started by Marioluigi64, Aug 3, 2011.

  1. Marioluigi64

    Marioluigi64 Addicted to LI Member

    Hey everyone!

    As the title says, I have been having a strange wifi problem for a while now, and I believe it's on the client end. Before I get started, I'll list what I've got:

    router: Linksys e3000 (running Tomato 1.28.0905 MIPSR2-062 K26 USB AIO by shibby)
    Asus RT-N12 (running dd-wrt v24 (build 14896) in repeater bridge mode)

    problem computers: Dell Inspiron 1521 laptop w/ Windows 7 32bit, AMD TL-58 @ 1.9GHz, & Dell 1505 802.11a/b/g/n wifi card
    13" Intel Macbook (from I believe 2009...) w/ OS X 10.6, Intel a/b/g/n wifi card

    OK, now the problem is with these two laptops (the Dell is mine and the Macbook is my sisters). Both of them will only connect to the router at 54mbps, as if the OS isn't recognizing there is an 'n' capable card installed. Both computers have the same problem, whether they are connected to the e3000 (either 2.4 or 5GHz, it doesn't make a difference), or the RT-N12 repeater in my sisters room. The same problem also occurred with my old router, an Asus RT-N16 (running TeddyBear's Tomato build 54), BTW I still have that router, I am selling it to a friend but I still have it and can test with it if needed.

    I know what you might be thinking, "oh he doesn't have aes encryption selected" or something like that, as that will cause 802.11n connections to revert to 54mbps. The thing is, I do have the proper security (WPA2 AES on both radios), both radios are set to Auto (b/g/n and a/n), and every other device we have connects at full speed (My Thunderbolt phone connects at 72mbps, her iphone at 65mbps, our Xbox 360 at 270mbps on both radios, and our htpc at 300mbps (it uses a D-Link dwa-556).

    I ran a little test and set both radios on the e3000 to n only and both laptops saw the access point, but neither would connect. The Dell gave the very generic "Cannot connect to access point" message and the macbook gave the even more generic "See administrator" message. When I reset the radios on the router to auto, the computers were able to connect again, but still only at 54mbps. It seems like something in either the cards themselves or in both Windows and OS X have become cockeyed and they think that the cards are a/b/g only, but I don't know what to do to fix it. I have looked through the advanced settings in the card driver window on my Dell and all settings that seem pertinent in any way to this problem seem to be set correctly (40MHz intolerant is off, 802.11n preamble is mixed mode, Antenna Diversity is Auto, etc.). As for the Macbook settings, admittedly I'm not much of a Mac expert, but I didn't see any wrongly set options in any of the network settings.

    Any help would be greatly appreciated, because I'm out of ideas :confused:
  2. Marioluigi64

    Marioluigi64 Addicted to LI Member

    Anybody know what to do? Perhaps it's just a freak coinky-dink and both cards decided to go south on me at the same time...
  3. shadowken

    shadowken Networkin' Nut Member

    have you erased the NVRAM for Linksys E3000 ?
  4. Marioluigi64

    Marioluigi64 Addicted to LI Member

    Yes, I did. I always make sure to erase the NVRAM every time I flash a new firmware, so that shouldn't be an issue.

    I decided to try something today just to see it it would work. On the Dell's advanced wifi card settings, I disabled the 2.4GHz band entirely, and what do you know, that worked! The computer promptly connected to the 5GHz AP at 270mbps (my laptop has 2 antennae so that's as good as it's gonna get)! I ran a speedtest (transfer a 2GB file from desktop to laptop) and I reached speeds of 18-19MB/s, more than I ever expected to get.

    So, I thought since disabling the 2.4Ghz band worked, why not try it the other way around? I then disabled the 5GHz band (again on the laptop, not the router) and only had the 2.4Ghz band active. that went nowhere, it still only connected at 54mbps, so I swapped again (2.4 disabled, 5 enabled), and it went right back up to 270mbps. I'm stumped now.

    EDIT to add this:

    When both radios are enabled, both are stuck at 54mbps
  5. shadowken

    shadowken Networkin' Nut Member

    Can you post your wireless settings ?
  6. Marioluigi64

    Marioluigi64 Addicted to LI Member

    Sure. Here are the settings for the Dell:

    40MHz Intolerant: Disabled
    802.11h+d: Loose 11h
    802.11n Preamble: Mixed Mode
    Afterburner: Disabled
    Antenna Diversity: Auto
    AP Compatibility Mode: Higher Performance
    Band Preference: Prefer 802.11a
    Bandwidth Capability: 11a/b/g:20/40MHz
    Bluetooth Collaboration: Disable
    BSS Mode: 802.11n Mode
    BT-AMP: Disabled
    Disable Bands: Disable 802.11g/b
    Disable Upon Wired Connect: Disabled
    Fragmentation Threshold: 2346
    IBSS 54(tm) Protection Mode: Auto
    IBSS Mode: 802.11a/b/g/n Auto
    Locally Administered MAC Address: Not Present
    Minimum Power Consumption: Disabled
    PLCP Header: Auto (Short/Long)
    Priority & VLAN: Priority & VLAN Disabled
    Rate (802.11a): Best Rate
    Rate (802.11b/g): Best Rate
    Roam Tendency: Moderate
    Roaming Decision: Optimize Bandwidth
    RTS Threshold: 2347
    Wake-Up Mode: Magic & WakeUp Frame
    WMM: Auto
    WZC IBSS Channel Number: 11(20MHz)
    XPress (TM) Technology: Disabled

    And to cover all the bases, here are the router settings:


    Wireless Mode: Access Point
    Wireless Network Mode: Auto
    Radio: Enabled
    Security: WPA2 Personal (PSK) + AES
    Channel: 1 - 2.412 GHz
    Channel Width: 40 MHz
    Interference Level: Acceptable
    Rate: 270 Mbps


    Wireless Mode: Access Point
    Wireless Network Mode: Auto
    Radio: Enabled
    Security: WPA2 Personal (PSK) + AES
    Channel: 36 - 5.180 GHz
    Channel Width: 40 MHz
    Interference Level: Acceptable
    Rate: 270 Mbps

    Thanks for the help, shadowken! :)

Share This Page