1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

STUMPED! Can't go to a website, using Tomato firmware

Discussion in 'Tomato Firmware' started by tucktaw, Dec 21, 2009.

  1. tucktaw

    tucktaw Addicted to LI Member

    Hello all - I recently started having problems with a gaming website I've been going to. I noticed it was extremely slow, and then stopped working altogether. I tried clearing my browser's cache and different computers on my network.

    I thought for sure it was a problem on the server end - however, I connected my computer directly to my cable modem and it worked! So, something was screwy with my router. I upgraded my tomato version to 1.27, still no luck. I then did a "Restore Default Router Settings", and still can't go to the site!

    The site I can't access is [removed]. I can ping it fine too.... Help!!

    Router: WRT54GL
    Firmware: Tomato 1.27
     
  2. tucktaw

    tucktaw Addicted to LI Member

    No ideas or any tests I can do? I can't figure out how a reset router could block a webpage. :confused:
     
  3. TexasFlood

    TexasFlood Network Guru Member

    What's the configuration of your client(s)? Are they configured with static network info or to receive DHCP? Either way, do they have all the correct info, IP on the correct subnet, correct subnet mask, correct DNS server, correct gateway? The basic network page needs all this info set to be able to hand it out in DHCP. When you first loaded Tomato, did you do an nvram reset as recommended in the official Tomato FAQ page "Should I reset the configuration after installing Tomato?".
     
  4. tucktaw

    tucktaw Addicted to LI Member

    Thanks for the response, all three computers are DHCP (Ubunut, Vista, Win7). The internet works fine on all three computers, never had any issues. I did an nslookup on the domain, and it seems to respond with the appropriate IP, which I still can't visit in a browser "http://74.208.82.187".

    I do not remember if I did an NVRAM clear when I first loaded Tomato, but I just tried it and I still can't access it. My original guess was that my IP could have been flagged from their server, but then it worked when connected to the cable modem - my external IP wouldn't be different when connected through router/modem, right?

    This really doesn't make any sense to me, I'm going to try and connect directly to the modem again and check my IP to make sure I'm not crazy...
     
  5. TexasFlood

    TexasFlood Network Guru Member

    I can't get a page on http://74.208.82.187 either. Well, actually, I do, it says "Error 404 - Not found, The document you requested is not found." which is a page just not a page for any particular site. There are multiple web sites hosted on that server such as http://www.entertheknow.com/ and http://www.cyberneticpunks.com/, both of which I am able to bring up through my Tomato router. So going to the IP alone isn't going to get you there. The web site, load balancer, or whatever is on the other end must be parsing the URL and redirecting to the right page based on that.
     
  6. tucktaw

    tucktaw Addicted to LI Member

    That's interesting, I have the same problem with http://www.entertheknow.com (tried Vista/Win7).
     
  7. TexasFlood

    TexasFlood Network Guru Member

    PC firewall maybe? The network settings when bypassing the Tomato router could be allowed and the LAN subnet from Tomato not? Try disabling any PC firewalls temporarily to test.
     
  8. tucktaw

    tucktaw Addicted to LI Member

    Still no go. My Win7 machine didn't have a firewall running and neither does my Ubuntu machine (to my knowledge). I disabled "Microsoft Security Essentials" on the third machine, and still can't seem to access either of the domains.
     
  9. Planiwa

    Planiwa LI Guru Member

    Browser filter?

    Have you tried this, from the router:

    Code:
    wget http://www.entertheknow.com
    
    that should give you a file:

    # wget http://www.entertheknow.com/
    Connecting to www.entertheknow.com (74.208.82.187:80)
    # l in*
    -rw-r--r-- 1 root root 15286 Dec 21 19:29 index.html
    #
    Code:
    
    
     
  10. TexasFlood

    TexasFlood Network Guru Member

    I'll be gone for a while but can't really think of anything else now anyway. But I think it must be something in your configuration. Doesn't seem like Tomato itself could be to blame as I can get to those sites through my Tomato router. Good luck, I'll check in here later to see how you made out.
     
  11. tucktaw

    tucktaw Addicted to LI Member

    I think I got it...

    Ok, I've tried resetting my router, 3 different OS's and multiple browsers and none of them seemed to work with my router. When I plug in my computer directly into the cable modem (and reset the modem), it works right away for both domains.

    Turns out I wasn't crazy, the modem assigns the same IP address to my router each time and a different one to my computer when directly connected. Since the rest of the internet works perfectly, doesn't that mean that the external IP address that gets assigned to my router is blocked by their server (78.208.82.187)?
     
  12. tucktaw

    tucktaw Addicted to LI Member

    The wget just blinked for about 30 seconds before I stopped it, didn't seem to connect. I tried wget for google.com and it worked instantly.

    I found a list of domains on that IP address (74.208.82.187) and I can't get to ANY of them! It looks like it's from 1&1 hosting, so I guess I'll contact them and see if it's possible my IP was blocked? Do you all agree that this is not a tomato issue and most likely not a router issue?

    Other sites on the domain from googling:
    * childrenscenterpreschool.org
    * www.entertheknow.com
    * www.penumbra-guild.com [Penumbra-Guild]
    * www.yogels.com [Yogels]

    Thank you TexasFlood for the help!
     
  13. tucktaw

    tucktaw Addicted to LI Member

    Confirmed!

    I spoofed my router's IP address and reset my modem to assign myself a new IP and sure enough I can get to all of the previously mentioned sites! I had already emailed 1&1, it'll be interesting to hear their response.

    Thanks for the help!
     
  14. Planiwa

    Planiwa LI Guru Member

    The solution might be with your ISP.

    Can you please clarify what exactly happens with your IP addresses?

    Does the router get its own IP address consistently, and each PC gets its own IP address consistently? Is that what you were saying? Each device gets its own public IP address from the ISP?
     
  15. TexasFlood

    TexasFlood Network Guru Member

    Glad you got it sorted out, especially since I just got back so don't have to try & think of anything else, :biggrin:
     
  16. Planiwa

    Planiwa LI Guru Member

    That's what I thought, and what I was going to suggest after confirming the apparent MAC-specific IP assignments.

    It looks like your router-specific IP address was poisoned before you got it.

    Glad you got it sortd out. :)
     

Share This Page